SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2010-09-24 03:38:14

scottfines
New Member
Registered: 2010-09-24
Posts: 1

Installing Crunchbang with ATI proprietary drivers

I know, I know, I'm not supposed to, but I like my 3d acceleration and easy window setups with ATI's fglrx drivers, so I set out to install crunchbang on a brand new machine with an ATI FirePro 3D graphics card, and ran into a few issues. After googling around and not coming up with much, I tried a few things and finally found the steps that worked correctly, and I thought I would share them with the world for easier usage.

Firstly, I created a liveUSB of #! using UNetBootin, which is a stupidly simple application to use, and works in Windows and Linux(my work machine runs Ubuntu 10, so I used that). There are other instructions available for how to do that, so I won't go into it now, but it's pretty simple.

After putting the machine together and getting all the hardware set up correctly, I booted into #! off the LiveUsb, which was a matter of putting the usb into a usb drive, and telling my BIOS to boot from USB, and then I was up and running. Simple! I then proceeded to the installation of #! and had no troubles there either.

The trouble started when I booted from my hard drive for the first time. I noticed that my screen resolutions were kind of funky--1024x 768, instead of the expected 1600x900. Having some previous experience with Ubuntu, I figured that the video drivers weren't installed correctly. I happen to like the proprietary fglrx drivers, but there's often trouble with the versions available in the restricted repositories, so I went to ATI's website and downloaded their 8.743.3 drivers, then tried to run them.
    The install appeared to go okay, until I checked the log file in /usr/share/ati/fglrx-installer.log, which read "Failed to build fglrx-8.743.3.3 with DKMS". Not really very informative, but some google-searching told me that DKMS was the Dynamic Kernel Module System, and so that got me to thinking that maybe there was an issue with my kernel.
Sure enough, typing uname -a into the terminal showed my kernel version as 2.6.28-19, which is relatively old. Since there were some issues with the Ubuntu kernel headers and the fglrx driver last year, there was both a kernel update and an ATI update to fix them. My guess is that the latest version of fglrx didn't support the older kernel version. So I needed to update my kernel.
I updated my kernel using the instructions given in http://www.ramoonus.nl/2010/02/linux-ke … ntu-linux/ to version 2.6.33, then restarted the machine. Then I made SURE that fglrx was TOTALLY uninstalled by running sudo apt-get remove --purge fglrx, then I re-installed fglrx, rebooted, and viola! problem solved!

Hope this helps someone else, or at least it'll be around for me to remember the next time I install this excellent distro!

Scott

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo