SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-01-13 17:27:59

rasmith3530
#! Member
From: 50 Miles NW of Maxwell Street
Registered: 2009-01-13
Posts: 51

[SOLVED] IBM Thinkpad X40 and Super Key

After downloading Cruncheee and trying it out on my little EeePC 4G Surf, I decided to replace Xubuntu on my X40 Thinkpad with CrunchBang. The install went just fine, and it appears that all my hardware has been detected (I haven't used a modem in five years, so don't ask!). I do have one issue though.

On my Eee, it appears to use the Home key as the Super key as the shortcut to open applications, per the menu on the desktop. I assume that this key is mapped like the Windows key on a standard keyboard, and that is my problem. The X40 is IBM's attempt to pack as large a punch as possible in as small a package as possible. It features a 12.1" screen, and to save real estate while maintaining key size, they omitted the Windows and Menu keys from the keyboard. Has anyone had one of these machines loaded with CrunchBang, and is there a workaround for this?

I really do like this distro! I'll definitely be talking it up at my local LUG.

Last edited by rasmith3530 (2009-01-23 06:28:38)


Rob Smith
"Linux, because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!"

Offline

Help fund CrunchBang, donate to the project!

#2 2009-01-14 19:03:35

fhsm
#! Junkie
From: New Hampshire, USA
Registered: 2009-01-05
Posts: 445

Re: [SOLVED] IBM Thinkpad X40 and Super Key

Welcome to the odyssey... http://crunchbanglinux.org/forums/topic … y-menulst/

I'm closing in on a solution with AlexelA's help.

Offline

#3 2009-01-15 05:24:25

rasmith3530
#! Member
From: 50 Miles NW of Maxwell Street
Registered: 2009-01-13
Posts: 51

Re: [SOLVED] IBM Thinkpad X40 and Super Key

Newer Thinkpads, like ours but more up-to-date, were available with Linux (I believe SuSe) pre-installed. I wonder what they did on those machines to resolve this. I'm sure that there has to be some somewhat simple workaround, but I just have yet to find it via Google.

EDIT: I've also posted a question regarding this to the Linux-Thinkpad mailing list.

Last edited by rasmith3530 (2009-01-15 05:42:02)


Rob Smith
"Linux, because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!"

Offline

#4 2009-01-15 11:51:28

fhsm
#! Junkie
From: New Hampshire, USA
Registered: 2009-01-05
Posts: 445

Re: [SOLVED] IBM Thinkpad X40 and Super Key

rasmith3530 wrote:

On my Eee, it appears to use the Home key as the Super key as the shortcut to open applications, per the menu on the desktop. I assume that this key is mapped like the Windows key on a standard keyboard, and that is my problem. The X40 is IBM's attempt to pack as large a punch as possible in as small a package as possible. It features a 12.1" screen, and to save real estate while maintaining key size, they omitted the Windows and Menu keys from the keyboard. Has anyone had one of these machines loaded with CrunchBang, and is there a workaround for this?

Unless I've totally missed your question I really do think this is the solution to your problem.  I'm writing this from a thinkpad where Alt_L + f2 gives me a run dialog and Alt_R + space shows me the openbox menu.  How close is this to what you are looking for?

Offline

#5 2009-01-18 02:58:39

rasmith3530
#! Member
From: 50 Miles NW of Maxwell Street
Registered: 2009-01-13
Posts: 51

Re: [SOLVED] IBM Thinkpad X40 and Super Key

fhsm wrote:
rasmith3530 wrote:

On my Eee, it appears to use the Home key as the Super key as the shortcut to open applications, per the menu on the desktop. I assume that this key is mapped like the Windows key on a standard keyboard, and that is my problem. The X40 is IBM's attempt to pack as large a punch as possible in as small a package as possible. It features a 12.1" screen, and to save real estate while maintaining key size, they omitted the Windows and Menu keys from the keyboard. Has anyone had one of these machines loaded with CrunchBang, and is there a workaround for this?

Unless I've totally missed your question I really do think this is the solution to your problem.  I'm writing this from a thinkpad where Alt_L + f2 gives me a run dialog and Alt_R + space shows me the openbox menu.  How close is this to what you are looking for?

Well, what I am actually looking for is a key or key combination that will duplicate the Windows/Super key press, so that I might use this in conjunction with the shortcut keys listed in the default conkyrc to perform functions varying from opening a terminal emulator or web browser, to logging out.

Alt_R + space, and Alt_L +f2 both give me nothing.

EDIT: While reading some documents related to this issue, I came across something that prompted me to check my locale setting. I issued the following command and received the input shown.

~$ env | grep LANG
LANG=en_GB.UTF-8
GDM_LANG=en_GB.UTF-8

When I loaded the machine, as normal, I was prompted for my keyboard settings, to which I responded US. Would there be some sort of compatibility issue here, because the above response shows the environment language as being en_GB, or British? Just curious.

Last edited by rasmith3530 (2009-01-18 14:59:05)


Rob Smith
"Linux, because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!"

Offline

#6 2009-01-18 15:18:16

rasmith3530
#! Member
From: 50 Miles NW of Maxwell Street
Registered: 2009-01-13
Posts: 51

Re: [SOLVED] IBM Thinkpad X40 and Super Key

I was looking at http://crunchbanglinux.org/forums/post/4957/#p4957 as suggested by fhsm, but when I search my /home/user directory, I don't see a ~/.Xmodmap file. If I issue the command xmodmap -pm though, I get the following output...

~$ xmodmap -pm
xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x69)
mod1        Alt_L (0x40),  Alt_R (0x6c),  Meta_L (0xcd)
mod2        Num_Lock (0x4d)
mod3     
mod4        Super_L (0xce),  Hyper_L (0xcf)
mod5        ISO_Level3_Shift (0x5c),  Mode_switch (0xcb)

So, I know that the .Xmodmap file must exist, but what is the path? It does not appear to be directly in my home directory. If I run a find command on .Xmodmap, it comes up empty.


Rob Smith
"Linux, because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!"

Offline

#7 2009-01-18 23:17:45

fhsm
#! Junkie
From: New Hampshire, USA
Registered: 2009-01-05
Posts: 445

Re: [SOLVED] IBM Thinkpad X40 and Super Key

The language locale shouldn't have any effect on your keyboard setup.  It is normal that you don't have ~/.Xmodmap on your system.  It's up to you to create one otherwise the you'll just get the system default (stored else where on your system and which you do not want to change).  If you do make ~/.Xmodmap then it will be parsed and your map changed accordingly each time you login.  Think of ~/.Xmodmap as a way to do a partial over-write of your keyboard map when you login.  You don't have to redefine every key, just those you want to change.  Anything not specified in ~/.Xmodmap is inherited from the default.  This is nice because you can set up per user maps (ex: I don't have a caps lock when I log in but my girlfriend does).

What I find unusual is that Alt+f2 gives you nothing.  Sometimes that run dialog is flaky, let's hope that's what's going on.  What happens if you hit alt+f3, do you get the little menu at the top of your screen?  What about alt+f4 with a window open, does it close?  Given the output of xmodmap -pm that should happen if your alt keys are working.

If you've got a working alt key then you are back at this thread.   The result of the steps in that thread is a right Alt key that has been remapped to be a Super key (labeled as windows key, whatever that is, on most keyboards) and will trigger all of the "Super" shortcuts like Super+space listed in the default conky panel.  The left alt key is unchanged and still works like a normal alt key, such that Alt_L+f2 gives me the run dialog (if #! is in a good mood), Alt_L+F3 gives you the menu, Alt_L + F4 closes a window, etc.   This sounds like what you are looking for, if you are willing to give up one of your alt keys.

If this is in fact what you are after the instructions in the other thread should get you there, but I'm happy to answer questions.  If you are attached to the right alt key you can make anything you want the super key, no magic in the right alt.  If you aren't into fooling around with a config file you could try xfce-setting-show and then go into the keyboard options and see what you can do there.  I can't load that utility with a custom map but maybe it'll give you a gui solution.

Offline

#8 2009-01-19 21:23:46

rasmith3530
#! Member
From: 50 Miles NW of Maxwell Street
Registered: 2009-01-13
Posts: 51

Re: [SOLVED] IBM Thinkpad X40 and Super Key

Alt + F2 does give me the Run dialog box. As you'd written it, I misread and thought you were instructing me to try Alt + L + F2. Funny though, now that I try it running on battery rather then plugged into AC, it is not opening. Maybe that's what you are describing as flaky.

I am reading up on Xmodmap, and will try what you've suggested, reporting back with my results. One thing hits my curiosity though. I am not seeing any response from either my Access IBM key or the two keys that I have above the left and right arrow keys. How about you?


Rob Smith
"Linux, because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!"

Offline

#9 2009-01-20 00:04:26

fhsm
#! Junkie
From: New Hampshire, USA
Registered: 2009-01-05
Posts: 445

Re: [SOLVED] IBM Thinkpad X40 and Super Key

Le'me know how it turns out with .Xmodmap.  I'd really be curious if you gave the xfce-settings-show keyboard (alt+f3, type xfce-settings-show, hit enter, select keyboard from the pop-up window) thing a try.  I'm loathe to break my setup to try it but very curious about what it does.

Access IBM is an interesting case.  It doesn't even register in xev.  Not sure what the story is there.  Because it doesn't even show up as a keyboard input I think it's lost. 
The forward and back keys are over my right and left arrow keys.  I assume this is the same as yours.  Mine are mapped to XF86Back and XF86Forward (default).  This mapping 'should' work but it depends on how developers put their apps together.  I vaguely remember some crazy hack that involved remapping the keys to function keys to get more reliable behavior; however, I haven't looked into in a long time because Firefox 3 included support for FX86Forward and Back.  I wish Thunar did too.

Offline

#10 2009-01-22 09:21:10

rasmith3530
#! Member
From: 50 Miles NW of Maxwell Street
Registered: 2009-01-13
Posts: 51

Re: [SOLVED] IBM Thinkpad X40 and Super Key

I followed your final step on the other page as shown below...

keycode 108 = Super_R
add mod4 = Super_R
remove mod1 = Super_R
remove mod1 = Alt_R

When I then ran ~$ xmodmap ~/.Xmodmap , I received the following error...

xmodmap:  /home/username/.Xmodmap:4:  bad keysym in remove modifier list 'Alt_R', no corresponding keycodes
xmodmap:  1 error encountered, aborting.

Removing the final line above and then re-running ~$ xmodmap /.Xmodmap allowed the command to run without error, but I still did not get a right Alt key that works as a Super key.

One thing that I did note is that when I run the command ~$ xmodmap -pke | less , keycode 134 shows up as Super_R NoSymbol Super_R NoSymbol Super_R. Of course, because I assigned keycode 108 to Super_R through the above command, it also shows up as Super_R, but without the other stuff around it. Could the system be getting confused because two keymaps (108 and 134) are both assigned to Super_R?

Last edited by rasmith3530 (2009-01-22 09:28:28)


Rob Smith
"Linux, because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!"

Offline

#11 2009-01-22 19:39:05

fhsm
#! Junkie
From: New Hampshire, USA
Registered: 2009-01-05
Posts: 445

Re: [SOLVED] IBM Thinkpad X40 and Super Key

Try putting the ~/.Xmodmap back as I showed it and restarting your computer.  For some reason the order of the file that works from the terminal on a running system and the order of the file that works on a booting system are different. 

What did you find when you tried the keyboard GUI?

Offline

#12 2009-01-23 06:16:46

rasmith3530
#! Member
From: 50 Miles NW of Maxwell Street
Registered: 2009-01-13
Posts: 51

Re: [SOLVED] IBM Thinkpad X40 and Super Key

fhsm wrote:

What did you find when you tried the keyboard GUI?

Keyboard GUI?


Rob Smith
"Linux, because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!"

Offline

#13 2009-01-23 06:27:56

rasmith3530
#! Member
From: 50 Miles NW of Maxwell Street
Registered: 2009-01-13
Posts: 51

Re: [SOLVED] IBM Thinkpad X40 and Super Key

Bravo fhsm, it worked! Thanks a bunch!!!

I just opened this browser window to reply to you by using my right Alt key and "w". I also tried the shortcuts for a terminal window and Thunar. I am still able to close an open app with the left Alt key and L-Alt + f3 gets me the program menu at the top of the screen.


Rob Smith
"Linux, because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!"

Offline

#14 2010-08-05 13:15:07

gychang
#! Junkie
From: Phoenix, AZ
Registered: 2009-04-01
Posts: 274

Re: [SOLVED] IBM Thinkpad X40 and Super Key

rasmith3530 wrote:

Bravo fhsm, it worked! Thanks a bunch!!!

I just opened this browser window to reply to you by using my right Alt key and "w". I also tried the shortcuts for a terminal window and Thunar. I am still able to close an open app with the left Alt key and L-Alt + f3 gets me the program menu at the top of the screen.


I am still unclear, I have thinkpad T42 and want the windows super key to work (there is NO superkey), how can I set up so I can use the altL key combo?

gychang

Offline

#15 2010-08-05 13:58:36

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,417

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo