SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-11-22 00:51:58

carbonsink
New Member
Registered: 2009-08-05
Posts: 6

Copy/paste bug [solved]

When I paste text it is sometimes not pasted at the caret (cursor) but at some other random position nearby. It happens in Leafpad, gedit, and in textboxes in Firefox. Very annoying.

I have CrunchBang installed on a Eee PC 1005HA. Everything runs well after a few tweaks, drivers, etc. I've been using it for a couple of months but have this problem that's been with it since day one.

If I ctrl-Z (undo) the wonky paste it is properly undone and my caret is moved to the nearby random position. I then have to cursor back to the correct position to paste which always works the second time. If I moved the caret around and do another copy/paste its wonky again. Its like its lost track of the true caret position at the operating system level, not the application program level (since its a problem with multiple applications).

Anyone else have/had this issue? Anyone know of a fix?

I searched the forums but I don't see any mention of it.

Last edited by carbonsink (2009-11-22 23:56:56)

Offline

Be excellent to each other!

#2 2009-11-22 21:44:11

thil77
#! CrunchBanger
Registered: 2009-01-12
Posts: 193

Re: Copy/paste bug [solved]

don't have a solution, but some information.

Its like its lost track of the true caret position at the operating system level

the cursor position is managed by each application.
and you have the problem with different application.
so the problem is not the cursor position, but more like the copy & paste feature witch is broken.

the first suspect would be the "clipboard manager".
try to disable it in ~/.config/openbox/autostart.sh

# Launch clipboard manager
#(sleep 1s && parcellite) &

Offline

#3 2009-11-22 22:20:12

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 12,507

Re: Copy/paste bug [solved]

If you're using a mouse click to change focus and you click in a text field, the insertion point immediately changes to wherever you clicked.  In many (but not all) applications this also happens if you use a right-click to select 'Paste' from a context menu.


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#4 2009-11-22 22:55:00

carbonsink
New Member
Registered: 2009-08-05
Posts: 6

Re: Copy/paste bug [solved]

thil77: Thanks for thought. In autostart.sh it looks like it is already disabled because this is what I find:
# Launch clipboard manager
#(sleep 1s && parcellite) &

pvsage: I generally don't use the mouse at all when I'm editing, preferring to navigate with the keyboard. However, it is possible I'm inadvertently touching the mousepad as I type. As a test I'll try and figure out a way to disable the mouse pad and only use an external mouse and see if the problem goes away. One downer is that the random insertion point is sometimes not showing in the window (viewport) which makes it less likely that its the case that the touchpad is getting in the way. Thanks.

Offline

#5 2009-11-22 23:56:23

carbonsink
New Member
Registered: 2009-08-05
Posts: 6

Re: Copy/paste bug [solved]

pvsage: Thanks for the suggestion, it allowed me to find this: http://crunchbanglinux.org/forums/topic … e-writing/ (to disable the touchpad conditionally in real time). Implementing it seems to have solved my problem (just did about 15 minutes of heavy text editing with no sign of the issue).

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo