SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-10-20 12:05:57

diogovieira
New Member
Registered: 2009-10-20
Posts: 1

Eee 1101HA

I own a 1101HA Asus EeePC and I like it very much except to the fact that it has several compabilities problems with linux. I am currently running CrunchBang 9.04 and I have managed to surpass some difficulties. So I decided to make this post to help other people solve their problems and to get some solution for myself.

Right now I managed to get wireless, video card driver and synaptics (with no multitouch). Ethernet is supposed to work too based on this but I haven't tested it yet.

Ethernet

Download AR81Family-linux-v1.0.0.10.tar.gz from http://partner.atheros.com/Drivers.aspx

tar -xzvf AR81Family-linux-v1.0.0.10.tar.gz
cd src
make
sudo make install
sudo insmod atl1e.ko

Wireless

sudo aptitude install linux-backports-modules-jaunty

Graphics

As I did not need Compiz I just needed these steps (if you wish to use Compiz follow the extra steps here):

Add this PPA to your /etc/apt/sources.list

deb http://ppa.launchpad.net/ubuntu-mobile/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/ubuntu-mobile/ppa/ubuntu jaunty main

Add the GPG key to the keyring:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C6598A30

Install these:

sudo aptitude install psb-kernel-headers psb-firmware psb-kernel-source poulsbo-driver-3d xpsb-glx psb-modules poulsbo-driver-2d xserver-xorg-video-psb

Reboot

        Warning: It seems these drivers generate lockups and freezes at least for me and this user at ubuntuforums. It happens using 2.6.28-13-generic and 2.6.28-15-generic linux kernel and respective backported drivers.

        Update: It seems there may be a solution here. Apparently, the problem is on the 3d psb package.

Synaptics

Should work ok, except the multitouch. I pretend to add the steps needed to use it here in the future.

Fn keys (Hotkeys)

Seems the most difficult to get to work. I haven't found a solution yet since eee-control, eee-applet, eeeasy scripts and acpi-support are not compatible with 1101HA and eeepc-acpi-scripts is broken in jaunty.

Other

There are many things still missing but I think I addressed the most important ones. I will try to update this with new solutions. Please, if you have one, write a post about it.

Updated (16/10/2009): Graphics (possible solution to freeze problem)

Notes

I need some help by crunchbang developers and/or community because the fn keys really don't work and it seems it is crunchbang's (or ubuntu's) problem, because I talked to people with debian (for example) and they have it working with same packages and kernel modules installed. I am trying to get it working for days.

Thank you

Offline

Help fund CrunchBang, donate to the project!

#2 2010-02-17 15:46:43

tokou
New Member
Registered: 2010-02-17
Posts: 4

Re: Eee 1101HA

Thanks for your help,
I have an 1101HA too and I want to install #! on it, everything works fine, except that I don't have any network (no ethernet, no wifi)

I tried to follow your instructions but since the package build-essentials is not installed, I couldn't compile the sources of the driver.
I tried to download the package , but there's too many dependencies.
I tried to add an iso of ubuntu as a local repository ( because build-essentials is there ), but I need to have dpkg-dev installed in order tu use dpkg-scanpackages
I tried to download the packages of dpkg-dev manually, but there's also  too many dependencies

I don't know what to do more, it's like i'm stuck with a pc with no connection

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo