SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-08-04 18:12:17

Sunai
#! Member
From: Denmark
Registered: 2009-07-16
Posts: 61

Network

Hello again smile

Now that I've installed thunar instead of pcmanfm,  I can't browse the local network through thunar since it doesn't support samba.

So how can I make it work?

I've read this thread: http://crunchbanglinux.org/forums/topic/242/view-lan/

And it seemed that no one really solved the problem using thunar with "samba"

I've tried the:

sudo apt-get install smbnetfs
mkdir ~/.smb
cp -v /etc/samba/smb.conf ~/.smb/
cp -v /etc/smbnetfs.conf ~/.smb/
mkdir ~/network
smbnetfs ~/network

Solution, but it didn't work. When I run the :" smbnetfs ~/network " : command in a terminal , it gives me the::

fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: failed to access mountpoint /home/sune/network: Permission denied

Error::

So here's my question:

Did anyone find a solution? - and what about gnome-commander. Can it be used to browse through my local network ?

Or is there an alternative method?

Sunai smile

Last edited by Sunai (2009-08-04 18:19:18)

Offline

Help fund CrunchBang, donate to the project!

#2 2009-08-04 19:24:23

opothehippo
Member
Registered: 2009-08-01
Posts: 12

Re: Network

I would also like to know, as I use thunar too.

On Thunar's website, in the faq, it talks about browsing a local network. It recommends this guide, so you can try and give that a go.

Offline

#3 2009-08-04 19:32:11

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,372

Re: Network

Try this:

sudo apt-get install fusesmb gvfs-fuse gigolo

and see if Gigolo works for you.

If that doesn't work, then change the volume manager implementation from HAL to unix in Gigolo preferences.

Offline

#4 2009-08-04 20:34:30

stopie
#! Die Hard
Registered: 2009-02-02
Posts: 547

Re: Network

I tried fusesmb and it did not cooperate well so I moved to pyNeighborhood and it  has worked well for me (although I use pcmanfm). The ubuntu forums has a little blurb on setting it up that I'd recommend if fusesmb doesnt work: link

Last edited by stopie (2009-08-04 20:43:27)

Offline

#5 2009-08-05 03:40:32

lewispm
#! Member
From: Collierville, TN
Registered: 2009-07-29
Posts: 87

Re: Network

Sunai wrote:

fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: failed to access mountpoint /home/sune/network: Permission denied

One last thing to try... I think you need to add yourself to the fuse group.  I had to do that when I tried the sshfs thing.


Statler-Openbox on an Acer Extensa 4420.  Its good to be back.

Offline

#6 2009-08-05 16:52:49

Sunai
#! Member
From: Denmark
Registered: 2009-07-16
Posts: 61

Re: Network

I tried the pyneighborhood, and it seems to be working. So i'll stick to it.

Offline

#7 2009-08-06 13:51:55

jschall
#! Member
Registered: 2009-07-24
Posts: 60

Re: Network

Sunai wrote:

I tried the pyneighborhood, and it seems to be working. So i'll stick to it.

Glad it works for you, Sunai!

But nothing works for me sad

Maybe someone with a similar setup can suggest something?

I am running #! 9.04 Lite on an eeePC 701. WiFi is working fine for internet applications, but not for my LAN. My LAN is a Linksys WRT54G router connecting to my ADSL modem and a Linksys NSLU2 network-attached storage unit as well as my desktop Windows PC. I can "see" the NSLU2 from my desktop PC as well as from my wife's Vista laptop.

I have followed the referenced thread on Ubuntu Forum to install pyNeighborhood. I use Nautilus fle manager.

in Nautilus, the "Network" icon can "see" the Windows Network and my "MSHOME" workgroup. But I can click no further with Nautilus - I get "Unable to mount location - failed to retrieve share list from server".

Using pyNeighborhood, "Scan workgroup MSHOME" gives "Failed to scan workgroup MSHOME".

I even turned off my Windows firewall without any difference.

I am beginning to think there is some configuration data missing in my Samba applications.

Anybody know what could be wrong?


- Jeff Schallenberg
Mont Saint-Hilaire, Québec

Offline

#8 2009-08-08 22:41:49

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,372

Re: Network

I wonder if using a newer version of pyneighborhood would help:

https://launchpad.net/~encbladexp/+archive/ppa

Offline

#9 2009-08-10 03:50:26

stopie
#! Die Hard
Registered: 2009-02-02
Posts: 547

Re: Network

Sunai wrote:

I tried the pyneighborhood, and it seems to be working. So i'll stick to it.

w00t! Glad I helped save you some of the headache I endured trying to get the same thing working for three months. Lemme know if you try anything else with positive results down the road.

Offline

#10 2010-03-14 14:43:54

phaedrus
New Member
Registered: 2010-03-14
Posts: 6

Re: Network

Fyi, anyone having problems with Permission denied might check out http://embraceubuntu.com/2005/10/28/how … ing-sshfs/

Instructions there helped me solve my auto-mount problems along with the steps listed here smile

Offline

#11 2010-12-27 10:28:29

sneakwipe
New Member
Registered: 2010-12-27
Posts: 1

Re: Network

Thanks for sharing. Only the current status of your informative topic. I appreciate about it. It really is so useful for all, especially for me because I want to get knowledge of all kinds. I just want to say that your sense to describe, it's nice and easy to understand, so I appreciate the love it. Thanks again!




____________
000-153
000-105
HP2-E31
HP0-J40

Last edited by sneakwipe (2011-01-07 10:20:24)

Offline

#12 2011-07-16 07:01:43

backlashforblow
New Member
Registered: 2011-07-16
Posts: 1

Re: Network

Sunai wrote:

Hello again smile

Now that I've installed thunar instead of pcmanfm,  I can't browse the local network through thunar since it doesn't support samba.

So how can I make it work?

I've read this thread: http://crunchbanglinux.org/forums/topic/242/view-lan/

And it seemed that no one really solved the problem using thunar with "samba"

I've tried the:

sudo apt-get install smbnetfs
mkdir ~/.smb
cp -v /etc/samba/smb.conf ~/.smb/
cp -v /etc/smbnetfs.conf ~/.smb/
mkdir ~/network
smbnetfs ~/network

Solution, but it didn't work. When I run the :" smbnetfs ~/network " : command in a terminal , it gives me the::

fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: failed to access mountpoint /home/sune/network: Permission denied

Error::

So here's my question:

Did anyone find a solution? - and what about gnome-commander. Can it be used to browse through my local network ?

Or is there an alternative method?

Sunai smile



Well, sounds good to me. Helped me out a lot. Thanks

Wedding Hairstyles

Last edited by backlashforblow (2011-07-22 10:59:13)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo