SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-26 16:47:39

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Steam on #! Waldorf

Valve released HL1 on Linux this week, so it's nice time to install steam.

1. Download this script https://gist.github.com/4231563

2. Unarch it with

tar -zxvf gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0.tar.gz

3. Make it executable with

cd gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0
chmod +x steam_bootstrap.sh 

4.  launch it

./steam_bootstrap.sh 

[edit by corenominal]: removed sudo.

5. If you are on AMD64 architecture, add i386 repositories and update package list.

sudo dpkg --add-architecture i386
sudo apt-get update

6. Install nessesary libraries:

sudo apt-get install libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libcurl3-gnutls:i386 libogg0:i386 libpixman-1-0:i386 libsdl1.2debian:i386 libtheora0:i386 libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386 libasound2:i386 libc6:i386 libcairo2:i386 libcups2:i386 libdbus-1-3:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386 libgdk-pixbuf2.0-0:i386 libglib2.0-0:i386 libgtk2.0-0:i386 libnspr4:i386 libnss3:i386 libopenal1:i386 libpango1.0-0:i386 libpng12-0:i386 libpulse0:i386 libstdc++6:i386 libx11-6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxrandr2:i386 libxrender1:i386 zlib1g:i386

7. Restart your machine to update your .bashrc file and write "steam" in console

8. Profit smile

Last edited by corenominal (2013-02-20 23:27:35)


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

Be excellent to each other!

#2 2013-01-26 16:57:41

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

THank you, was trying to find a way. Will get a shoot at this one smile
Will write here how it goes.

Iam happy gaming coming to linux, i will support and play with my linux machines.


Crunchy feeling #!

Offline

#3 2013-01-26 20:12:05

stolid
#! CrunchBanger
Registered: 2012-09-06
Posts: 206

Re: Steam on #! Waldorf

Edit: I got it to work!

By the way, shouldn't you add this step to your guide for 64bit users?:

sudo dpkg --add-architecture i386

Also, I think it's necessary to do an apt-get update as well (the problem I ran into I think).

I used the Kano script a long time ago on my desktop, and I just tested your guide on my laptop. It works.

Last edited by stolid (2013-01-26 20:35:25)


Registered Linux User #555399
crunchbox:     Phenom II X6 1055T | 8GB RAM | OCZ Vertex 4 128GB | Radeon 7870XT | Win7 / #! 11 (i3 WM)
lambdacore:     4x Opteron 8431 | 16GB RAM | 2x1TB mirrored (ZFSoL) | Debian 7 (headless)
crunchtop:     Acer Aspire 1410 11.6" | 2GB RAM | Crucial M4 128GB | #! 11 (i3 WM)

Offline

#4 2013-01-26 20:47:39

Bradi
#! CrunchBanger
From: Poland
Registered: 2013-01-21
Posts: 115

Re: Steam on #! Waldorf

Thanks man, very useful! Perhaps edit your post to specify that this only works for Waldorf

Offline

#5 2013-01-26 21:45:52

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

somthing strange, cant get it to work yet.
i can install games in steam and so on. BUT, cant play any gam9e :S


Crunchy feeling #!

Offline

#6 2013-01-26 21:57:27

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

Tim wrote:

somthing strange, cant get it to work yet.
i can install games in steam and so on. BUT, cant play any gam9e :S

I've updated steam using internal update system and restarted PC. Tried it with Team Fortress - works like charm.


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#7 2013-01-26 22:13:04

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

1359237538-steam-1-png.png
When i try to play a game, team fortress etc.

and when iam trying counterstrike
1359238015-namnl--s-png.png


Crunchy feeling #!

Offline

#8 2013-01-27 00:54:04

MarioMaster100
#! Junkie
Registered: 2011-04-02
Posts: 260

Re: Steam on #! Waldorf

Cool thanks incogn1to works for me only thing is big picture mode is a little glitchy: http://db.tt/Mtd7yPOd and http://db.tt/pCj3l4dM but oh well.
Oh btw if you do source ~/.bashrc you don't have to restart the computer smile

Last edited by MarioMaster100 (2013-01-27 01:09:27)


Thank you everyone for being helpful and answering my questions.
Machinae Supremacy fan for life \m/_(^_^)_\m/

Offline

#9 2013-01-27 01:34:19

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 12,500

Re: Steam on #! Waldorf

@Tim:  GPU/APU driver problem maybe?  This sounds like a scenario where Radeon in particular would truly suck.


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Online

#10 2013-01-27 09:06:45

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

pvsage wrote:

@Tim:  GPU/APU driver problem maybe?  This sounds like a scenario where Radeon in particular would truly suck.

Do you think there is a way to fix it?

lspci wrote:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 IDE Controller (rev 01)
00:03.0 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4300 Series]
02:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe

Played a bit with mr google and found this site
http://pkgs.org/debian-sid/multimedia-m … /download/

installed it, and now theres no warning and the game sound starts, but i can just see my cursor and do nothing.
hmm, will try more, if someone have a tip, its welcome smile

Last edited by Tim (2013-01-27 14:37:49)


Crunchy feeling #!

Offline

#11 2013-01-27 19:11:59

Bradi
#! CrunchBanger
From: Poland
Registered: 2013-01-21
Posts: 115

Re: Steam on #! Waldorf

I have found a way to display the current status of your favourite CS 1.6 servers in conky.

1) Get quakestat, a small (<500kb) tool for querying various types of gameservers

sudo apt-get install qstat

2) Put this in your conkyrc:

${execi 60 quakestat -hls 178.255.41.211:27031 | awk '/RzeZnia/ { print $3, $2}' }

Substitute the ip and server name to match your server of choice; adjust interval to your needs.
This will display the current map and number of players in conky.
For TF2 servers, use -a2s instead of -hls.
Modify awk actions to get more/different info.

I didn't read too deeply into the manual, but it seems that qstat can fetch data for multiple servers, together with players info etc.
More information is available at

man quakestat
/usr/share/doc/qstat/qstatdoc.html (in depth guide)

It's so cool I just had to share this smile

Offline

#12 2013-02-02 00:57:20

MarioMaster100
#! Junkie
Registered: 2011-04-02
Posts: 260

Re: Steam on #! Waldorf

Hmm ran it successfully for a day and now

Fatal Error: Steam failed to load: *SteamStartEngine(0xffaee100) failed with error 1: CMultiFieldBlob(pSerialized): Partial field header at end of record

Thank you everyone for being helpful and answering my questions.
Machinae Supremacy fan for life \m/_(^_^)_\m/

Offline

#13 2013-02-02 07:36:59

zachr
New Member
Registered: 2013-02-02
Posts: 7

Re: Steam on #! Waldorf

Hmm, returned no errors during install process, however when I try to run I get this old friend:

zach@sweatshop:~/gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0$ 
zach@sweatshop:~$ steam
bash: steam: command not found

Any ideas?

Offline

#14 2013-02-02 11:20:18

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

zachr, try

cd ~/.steam/steam
./steam_on_debian.sh

Can you launch it from there?

PS You should restart your PC after installation or just run

source ~/.bashrc

to update variables.

Last edited by incogn1to (2013-02-02 11:23:51)


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#15 2013-02-02 11:28:17

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

MarioMaster100 wrote:

Hmm ran it successfully for a day and now

Fatal Error: Steam failed to load: *SteamStartEngine(0xffaee100) failed with error 1: CMultiFieldBlob(pSerialized): Partial field header at end of record

Did you updated client? Have you tried to reinstall using the same script?


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#16 2013-02-02 15:37:06

MarioMaster100
#! Junkie
Registered: 2011-04-02
Posts: 260

Re: Steam on #! Waldorf

incogn1to wrote:
MarioMaster100 wrote:

Hmm ran it successfully for a day and now

Fatal Error: Steam failed to load: *SteamStartEngine(0xffaee100) failed with error 1: CMultiFieldBlob(pSerialized): Partial field header at end of record

Did you updated client? Have you tried to reinstall using the same script?

Yeah it did update and then it just had that error message every time after. No I didn't try to reinstall yet.


Thank you everyone for being helpful and answering my questions.
Machinae Supremacy fan for life \m/_(^_^)_\m/

Offline

#17 2013-02-02 19:22:02

MarioMaster100
#! Junkie
Registered: 2011-04-02
Posts: 260

Re: Steam on #! Waldorf

Well tried to remove everything it said to and reinstall and it's still saying not everything is removed ?_?


Thank you everyone for being helpful and answering my questions.
Machinae Supremacy fan for life \m/_(^_^)_\m/

Offline

#18 2013-02-02 20:49:24

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

Mario, I would try to reinstall it on the top of prev install.


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#19 2013-02-02 21:06:09

MarioMaster100
#! Junkie
Registered: 2011-04-02
Posts: 260

Re: Steam on #! Waldorf

incogn1to wrote:

Mario, I would try to reinstall it on the top of prev install.

I tried that and it said I had to uninstall stuff and I'd removed what it said and it still won't install...


Thank you everyone for being helpful and answering my questions.
Machinae Supremacy fan for life \m/_(^_^)_\m/

Offline

#20 2013-02-02 23:42:52

zachr
New Member
Registered: 2013-02-02
Posts: 7

Re: Steam on #! Waldorf

incogn1to,

I got steam to run, but for some reason it installed to /root/.local/share/Steam

How would I go about getting it moved/reinstalled to my /home directory?

I got it, running perfectly. Thanks incogn1to!

Last edited by zachr (2013-02-02 23:57:16)

Offline

#21 2013-02-03 04:52:35

MarioMaster100
#! Junkie
Registered: 2011-04-02
Posts: 260

Re: Steam on #! Waldorf

zachr wrote:

incogn1to,

I got steam to run, but for some reason it installed to /root/.local/share/Steam

How would I go about getting it moved/reinstalled to my /home directory?

I got it, running perfectly. Thanks incogn1to!

Alright I figured it out and got it reinstalled and now it's running. zachr, did you get it running from your ~/ directory instead of having to run it after using su?


Thank you everyone for being helpful and answering my questions.
Machinae Supremacy fan for life \m/_(^_^)_\m/

Offline

#22 2013-02-03 23:51:46

Qnttresnyy
New Member
Registered: 2013-02-02
Posts: 9

Re: Steam on #! Waldorf

Hello! I seem to be unable to start steam.

When I enter the following commands:

envy@crunchboom:~/downloads/gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0$ sudo ./steam_bootstrap.sh 
[sudo] password for envy: 
Setting up Steam content in /root/.local/share/Steam
Installing Ubuntu packages
Installing desktop files
Adding Steam to PATH
To uninstall:
rm -rf 
rm -f everything steamish from /root/.local/share/applications
remove [[ -f "/root/.local/share/Steam/setup_debian_environment.sh" ]] && source "/root/.local/share/Steam/setup_debian_environment.sh" from /root/.bashrc
envy@crunchboom:~/downloads/gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0$ 

It looked like it worked, but I don't see the /root/.local/share/Steam directory. Steam is missing, any ideas? (I did follow the rest of the instructions)

Last edited by Qnttresnyy (2013-02-04 00:07:27)

Offline

#23 2013-02-04 19:28:36

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

Qnttresnyy wrote:

Hello! I seem to be unable to start steam.

When I enter the following commands:

envy@crunchboom:~/downloads/gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0$ sudo ./steam_bootstrap.sh 
[sudo] password for envy: 
Setting up Steam content in /root/.local/share/Steam
Installing Ubuntu packages
Installing desktop files
Adding Steam to PATH
To uninstall:
rm -rf 
rm -f everything steamish from /root/.local/share/applications
remove [[ -f "/root/.local/share/Steam/setup_debian_environment.sh" ]] && source "/root/.local/share/Steam/setup_debian_environment.sh" from /root/.bashrc
envy@crunchboom:~/downloads/gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0$ 

It looked like it worked, but I don't see the /root/.local/share/Steam directory. Steam is missing, any ideas? (I did follow the rest of the instructions)


Have you tried to launch "steam" from terminal. What do you see in output?

Last edited by incogn1to (2013-02-04 19:30:23)


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#24 2013-02-05 00:46:19

Qnttresnyy
New Member
Registered: 2013-02-02
Posts: 9

Re: Steam on #! Waldorf

envy@crunchboom:~$ steam
bash: steam: command not found
envy@crunchboom:~$ 

Last edited by Qnttresnyy (2013-02-05 02:09:07)

Offline

Help fund CrunchBang, donate to the project!

#25 2013-02-09 15:42:37

lobo86
New Member
Registered: 2013-02-09
Posts: 9

Re: Steam on #! Waldorf

Maybe you should edit the guide not to run as root-user. Besides that I found it really helpful. Thanks.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo