SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-04-16 14:05:47

kBang
#! Die Hard
From: Calera, AL, USA
Registered: 2009-01-06
Posts: 774

HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Threw some tags in the subject in case someone in the future does a search using the relevant taggs.

Spent over a day off and on trying to resolve my issue without resorting to installing Ubuntu's gnome-specific apps, even though I know they would have resolved my issue (Philip is turning me into a puritan).

Found this, worked immediately (snipping to where I started since previous portions dealt with installing the propietary ATI drivers and the proprietary driver installer that comes stock with Ubuntu/#! works just fine OOTB):

3. aplay -l lists audio devices:

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC883 Analog [ALC883 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC883 Digital [ALC883 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 0/1
Subdevice #0: subdevice #0

...from this, you can see that determine that HDMI out will be plughw:1,3 (that is, card 1, device 3). As mentioned above, it has to be plughw, not just hw.

4. Run sudo alsamixer -c 1

5. There's no option to raise/lower volume, but you can un-mute by hitting 'm'. If you see a box at the bottom of the terminal window with 'mm' in it, you're muted. If it contains '00', you're un-muted.

6. Hit esc to quit.

7. Run aplay on a .wav file to test, like so: sudo aplay -D plughw:1,3 <soundfile>. If your device number was different, use that.

8. Assuming that all works, edit /etc/asound.conf (which may not exist yet), put this in it:

pcm.!default {
type hw
card 1
device 3
}

Again, use your device numbers. Now the 3200 HDMI is your default audio out.

The Alsa wiki page on Digital Out ([url]http://alsa.opensrc.org/index.php/DigitalOut#MythTV[/url]) was super-helpful.

[edit to add:  Original thread I found. ]

Last edited by kBang (2009-04-16 14:08:36)


I view KDE like I view snow. It looks fun and marvelous, it's fun to play in, but after a while I just want someone to take it all away.

Offline

Be excellent to each other!

#2 2009-11-08 00:41:06

Venomous
Member
From: Republic of Texas
Registered: 2009-09-20
Posts: 18

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

thanks a ton, this worked perfectly for me, and just so happened that my card was the same numbers so i just had to copy/paste lol


~/ is where the heart is.

Offline

#3 2010-12-23 10:29:09

Dubstep
New Member
Registered: 2010-12-22
Posts: 9

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

@kBang

THAAAAAAAAAAAAAAAAAANKS!!!!!!!!!!!!


Ummm, we'll have to turn you down a bit. No its not clipping, its just that the subs have over-heated...

Point.blank - Children <<<

Offline

#4 2011-12-12 21:04:18

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Maybe you can help me whit this also, i can play video whit sound whit vlc on my tv.
But all order things i want to play whit HDMI, like streaming video from youtube whit my browser whil not give any sound.
In alsamixer i can not find HDMI, i have a Intel card in my dell inspiron 1525 and running Linux Mint Debian Edition.

I know its a old topic but i hope i can stil use it.


Acer Aspire 5749: Debian Testing

Offline

#5 2011-12-13 09:28:41

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Hi Johan
Post output of

aplay -l

Offline

#6 2011-12-13 09:47:22

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Here is my output.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

You can call me Bas in stead of Johan wink


Acer Aspire 5749: Debian Testing

Offline

#7 2011-12-13 10:38:31

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Hi Bas smile

Have you tried running the rest of the commands from the first post?
It should work for you too.

Doei

Offline

#8 2011-12-13 10:48:39

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

kruijf wrote:

Here is my output.

$ aplay -l
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

You can call me Bas in stead of Johan wink

To make life a little easier for you. Look at the output of aplay -l (it's a command that lists the soundcards as the ALSA system sees them). It says your HDMI output is recognized as the third device (3) on the soundcard zero (0). Create a file named .asoundrc in /home/yourusername. Paste this in:

pcm.!default {
type hw
card 0
device 3
}

Run

sudo service alsa-utils stop
sudo alsa force-reload
sudo service alsa-utils start

You should have the HDMI output as default.

Last edited by el_koraco (2011-12-13 12:39:56)

Offline

#9 2011-12-13 11:28:49

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

I maked the file asound.conf in /etc whit the selected tekst.
And restarted alsa, now i have sound from my laptop on my tv.
How can i switch between sound on tv and back to my laptop speakers? is there a easy way to do that?


Acer Aspire 5749: Debian Testing

Offline

#10 2011-12-13 11:32:44

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

kruijf wrote:

]
How can i switch between sound on tv and back to my laptop speakers? is there a easy way to do that?

Depends on what you mean by easy. You can rename the /etc/asound.conf, then restart ALSA as described. Rename it back to /etc/sound.conf and restart ALSA to get HDMI back. There's no automatic hotplugging option. For that you would need Pulseaudio.

Last edited by el_koraco (2011-12-13 11:33:36)

Offline

#11 2011-12-13 11:45:49

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

I dont like pulse, its not working good for me.
So then i whil rename the conf file when needed.


Acer Aspire 5749: Debian Testing

Offline

#12 2011-12-13 12:04:19

Awebb
The Singularity
Registered: 2009-07-23
Posts: 2,812

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Good job so far, but wouldn't setting it up in the alsamixer curse interface and saving it to the alsa daemon do the trick as well?


I'm so meta, even this acronym

Offline

#13 2011-12-13 12:35:38

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

idk
I am on crunchang 1102 for the moment and I dont have
alsa-force-reload
?

Edit:
oh - that should be:

sudo alsa force-reload

which reloads alsa kernel modules...

Last edited by xaos52 (2011-12-13 12:35:53)

Offline

#14 2011-12-13 12:39:38

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Yup, a slash too many. Editing original post...

Offline

#15 2011-12-13 21:32:10

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Should it be possible to do the switching whit a script?


Acer Aspire 5749: Debian Testing

Offline

#16 2011-12-13 22:00:43

kowloonboy
#! Junkie
Registered: 2011-10-13
Posts: 443

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

This is my output:

kowloonboy@blackbox:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

So for my .asoundrc I put this:

pcm.!default {
type hw
card 0
device 1
}

then

sudo service alsa-utils stop
sudo alsa force-reload
sudo service alsa-utils start

But after this, I didn't get any sound at all, so I deleted the .asoundrc. How can I get the digital to work?


"To me, the extraordinary aspect of martial arts lies in its simplicity. The easy way is also the right way, and martial arts is nothing at all special; the closer to the true way of martial arts, the less wastage of expression there is." - Bruce Lee

Offline

#17 2011-12-13 22:47:05

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

Some one knows the program Qasmixer??
It has a lot in it but i dont see the switch option, the screen tells me it has: http://xwmw.org/qasmixer/qasmixer_galle … en_05.html


Acer Aspire 5749: Debian Testing

Offline

#18 2011-12-13 23:01:46

kowloonboy
#! Junkie
Registered: 2011-10-13
Posts: 443

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

That look like a cut down version of alsamixer. http://en.wikipedia.org/wiki/File:Alsamixer.png

Last edited by kowloonboy (2011-12-13 23:02:47)


"To me, the extraordinary aspect of martial arts lies in its simplicity. The easy way is also the right way, and martial arts is nothing at all special; the closer to the true way of martial arts, the less wastage of expression there is." - Bruce Lee

Offline

#19 2011-12-13 23:03:33

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

I had the hope that whit qas you could switch, but in there i even can not find it.


Acer Aspire 5749: Debian Testing

Offline

#20 2011-12-13 23:56:21

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

kruijf wrote:

I had the hope that whit qas you could switch, but in there i even can not find it.

You can't do a live switch of the sound output in ALSA, the mixers only let you adjust sound on a card. You can have different programs using different sound cards in ALSA, but you can't have Youtube play from HDMI, and then switch to the laptop speakers on the fly.

Offline

#21 2011-12-14 00:13:35

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

On the fly switch is not nesesary, but it would be nice that switching is possible to do graphical.
Instead of renaming your .conf file each time, sorry but i always search for a easy graphical way if i think that it must be possible.
I think i want to mutch wink


Acer Aspire 5749: Debian Testing

Offline

#22 2011-12-14 00:20:18

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

You have to reset ALSA anyway, and you have to do it via CLI. Maybe make a few  aliases in your .bashrc

alias alsalaptop='sudo mv /etc/asound.conf /etc/asoundconfbak'
alias alsahdmi='sudo mv /etc/asouncconfbak /etc/asound.conf'
alias alsareset='sudo service alsa-utils stop && sudo alsa force-reload && sudo service alsa-utils start'

So you'd run alsalaptop to rename the file, and alsareset to reload ALSA, and alsahdmi followed by alsareset to move HDMI as the default card. Or try using Pulseaudio and have some of your apps, like the music or video player, use ALSA directly.

Offline

#23 2011-12-14 00:38:28

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

I have a look tomorow into that to make a shortcut of this lines.


Acer Aspire 5749: Debian Testing

Offline

#24 2011-12-14 09:52:28

kruijf
#! Member
From: Soest, Netherlands
Registered: 2011-06-12
Posts: 76
Website

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

This is working fine for me thanks.


Acer Aspire 5749: Debian Testing

Offline

Help fund CrunchBang, donate to the project!

#25 2013-11-05 20:04:48

RecNes
New Member
Registered: 2013-11-04
Posts: 3

Re: HDMI ATI HDA SOUND - How I got HDMI sound working in #!

I did not do anything above but I saw HDMI output in mixer configuration. While switched to HDMI no sound output but video speed increased. smile) When I switch back to analog,  everything went to normal. I tried a few times and I get same results.

What should I do to use HDMI sound?

Crunchband Waldorf (Updated)
ATI Radeon HD 3400 graphics.

Last edited by RecNes (2013-11-05 20:05:21)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo