SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-09-25 01:35:32

dkeg
#! Die Hard
From: Mid-Atlantic Grill
Registered: 2011-12-05
Posts: 716

[SOLVED]Waldorf - failed to execute login command

D/L'd the new image today.  Success all the way through until I try to login.  Tried to login through recovery mode, purge and reinstall slim, but no change.  Did that a couple times actually.  Also tried to select openbox as the session as one blog I read mentioned the session wasn't initialized until one was selected.  That did not work either.  This is super frustrating.  Doesn't look like too many are running into this, so my expectation is realistic.  If anyone has a suggestion, I'd appreciate it.

Very anti climatic.  Few beers and back into statler for now should ease the pain cool

thanks,

Last edited by pvsage (2012-09-27 12:41:56)


grill it | the rocky path may just be the best path

Offline

Be excellent to each other!

#2 2012-09-25 03:20:17

swftech
#! CrunchBanger
From: SW Florida
Registered: 2012-06-08
Posts: 106
Website

Re: [SOLVED]Waldorf - failed to execute login command

My first thought was to purge slim as well dkeg. I did a quick search and found this and thought it might help. Does failsafe work at all?
http://forums-web2.gentoo.org/viewtopic … b6#6435581

Last edited by swftech (2012-09-25 03:23:21)

Offline

#3 2012-09-25 11:27:36

dkeg
#! Die Hard
From: Mid-Atlantic Grill
Registered: 2011-12-05
Posts: 716

Re: [SOLVED]Waldorf - failed to execute login command

thanks swftech.  I'll check it out tonight after work and kid in bed big_smile


grill it | the rocky path may just be the best path

Offline

#4 2012-09-25 16:20:54

TemperingPick
Member
Registered: 2010-07-13
Posts: 16

Re: [SOLVED]Waldorf - failed to execute login command

Hey there. I had the same issue as you. Here's how I fixed it.

Boot into rescue mode, then create a home directory for your user. It's not made yet for some reason. Then create a .xinitrc file in your directory and add exec openbox-session (if using openbox). Reboot and it should let you login now.

Last edited by TemperingPick (2012-09-25 16:36:40)

Offline

#5 2012-09-25 16:59:56

dkeg
#! Die Hard
From: Mid-Atlantic Grill
Registered: 2011-12-05
Posts: 716

Re: [SOLVED]Waldorf - failed to execute login command

hey thanks TemperingPick!  I'll try that first tonight.  Can't wait!


grill it | the rocky path may just be the best path

Offline

#6 2012-09-25 18:38:26

logs_con
#! CrunchBanger
From: Farnham Surrey
Registered: 2009-12-10
Posts: 104
Website

Re: [SOLVED]Waldorf - failed to execute login command

I've come up against this one too,

Thank you TemperingPick, you've got me at least to a usable desktop.

to further complicate things my fstab appears to be completely empty too.

very strange.


This week's operating systems (subject to change)
LAPTOP : Crunchbang Waldorf AMD64 Openbox / openSUSE 13.1 x86_64 KDE 4.12 / Win7 64bit
DESKTOP : Crunchbang Waldorf AMD64 Openbox / openSUSE 13.1 x86_64 KDE 4.11.3 / Winvista 64bit

Offline

#7 2012-09-26 00:58:06

dkeg
#! Die Hard
From: Mid-Atlantic Grill
Registered: 2011-12-05
Posts: 716

Re: [SOLVED]Waldorf - failed to execute login command

yeah man that worked.  Thanks!  Still confused why it is that way.  That can't be right.  Anyway, thanks again. 

marking solved


grill it | the rocky path may just be the best path

Offline

#8 2012-09-26 05:14:59

grimmgoat
New Member
Registered: 2012-09-26
Posts: 1

Re: [SOLVED]Waldorf - failed to execute login command

Had the same issue installing from the latest "Waldorf Testing Image: 20120924" 64 bit.

When I installed I used the option that sets a separate /home partition. worked smoothly until login then "failed to execute login command".

I created a home folder, and was able to login, but the /home/user directory isn't on the home partition. once logged in I saw the home partition when I first opened thunar.

reinstalled with the all in one partition and it isn't an issue. everything works well.

I'm wondering, but don't know enough to check, if the user directory is being created in that directory but the system isn't mounting the /home partition on startup?

Last edited by grimmgoat (2012-09-26 05:16:28)

Offline

#9 2012-09-26 07:33:57

tivasyk
Member
From: kyiv, ukraine
Registered: 2010-08-30
Posts: 17
Website

Re: [SOLVED]Waldorf - failed to execute login command

beg your pardon, but why has this been marked as [solved]? moving the contents of the entire /home partition for the distro to work, or having an empty fstab after install qualifies now for a solution? =/

p.s. yes, obviously the same problem here, and moving home is not an option.

Last edited by tivasyk (2012-09-26 08:23:17)


[ corenominal mccoder has created a masterpiece. this is a linux distro. all craftsdwarfship is of the highest quality. it is crafted of scripts. it menaces with spikes of code. it menaces with spikes of theming. it depicts an image of a crunch. it depicts an image of a bang. the crunch is crunching. the bang is banging. ]

Offline

#10 2012-09-26 08:09:55

logs_con
#! CrunchBanger
From: Farnham Surrey
Registered: 2009-12-10
Posts: 104
Website

Re: [SOLVED]Waldorf - failed to execute login command

So it looks like it's an issue with installing with a separate home partition?

For whatever reason the fstab is not being generated correctly and the system
is falling back to an empty home folder on the root partition.
Does this sound right?

I've rolled back to the August release for the time being but am happy to have another go with the new image
If I can help with troubleshooting.

Last edited by logs_con (2012-09-26 08:10:46)


This week's operating systems (subject to change)
LAPTOP : Crunchbang Waldorf AMD64 Openbox / openSUSE 13.1 x86_64 KDE 4.12 / Win7 64bit
DESKTOP : Crunchbang Waldorf AMD64 Openbox / openSUSE 13.1 x86_64 KDE 4.11.3 / Winvista 64bit

Offline

#11 2012-09-26 08:23:36

tivasyk
Member
From: kyiv, ukraine
Registered: 2010-08-30
Posts: 17
Website

Re: [SOLVED]Waldorf - failed to execute login command

first of all: i would probably be able to resolve the issue in the end by googling, searching this forum etc... call me lazy though but i just want to get to x's before i start palying with the newly installed distro. unless it's dd-wrt on my router of course ;-)

here's what i've tried:

1) installing #! waldorf 20120924 from a liveusb over formatted ext4 system partition and a separate ext4 /home partition with an existing user home folder;
2) installing #! waldorf 20120924 from a liveusb over formatted ext4 system partition and a separate ext4 /home partition without an existing home folder;

both times slim refused to login with the user credentials set up during install process. so... currently stuck with a liveusb session.

Last edited by tivasyk (2012-09-26 08:27:37)


[ corenominal mccoder has created a masterpiece. this is a linux distro. all craftsdwarfship is of the highest quality. it is crafted of scripts. it menaces with spikes of code. it menaces with spikes of theming. it depicts an image of a crunch. it depicts an image of a bang. the crunch is crunching. the bang is banging. ]

Offline

#12 2012-09-26 13:38:17

raidensub
New Member
Registered: 2012-09-10
Posts: 6

Re: [SOLVED]Waldorf - failed to execute login command

I have the same problem with the last 32bit image. I did a search in google and someone  suggests to look in /var/log/slim.log. In there i get :

cannot move skel.tar.gz to /home......

I think the installer can't create the home partition like you said.

Last edited by raidensub (2012-09-26 13:38:54)

Offline

#13 2012-09-26 14:20:41

dkeg
#! Die Hard
From: Mid-Atlantic Grill
Registered: 2011-12-05
Posts: 716

Re: [SOLVED]Waldorf - failed to execute login command

tivasyk wrote:

beg your pardon, but why has this been marked as [solved]? moving the contents of the entire /home partition for the distro to work, or having an empty fstab after install qualifies now for a solution? =/

p.s. yes, obviously the same problem here, and moving home is not an option.

I marked it solved b/c I am the OP.  And for me it is solved.  Please read the entire thread before chiming in.  If you follow the below solution kindly posted by @TemperingPick you should successfully be able to login.  If you need more details on the process, just post back and we or I will be happy to provide that instruction. 

TemperingPick wrote:

Hey there. I had the same issue as you. Here's how I fixed it.

Boot into rescue mode, then create a home directory for your user. It's not made yet for some reason. Then create a .xinitrc file in your directory and add exec openbox-session (if using openbox). Reboot and it should let you login now.

If the moderators want me to 'unsolve' this, than I can do that no problem.  Ultimately, its for the good of the community.  So @mods can you let me know if I should 'unsolve'.  Thanks.


grill it | the rocky path may just be the best path

Offline

#14 2012-09-26 14:39:23

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,984

Re: [SOLVED]Waldorf - failed to execute login command

I'm going to go ahead and change this to [un-SOLVED], as I am experiencing the same problem.

@Philip/corenominal:  WTF?? hmm


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#15 2012-09-26 14:48:41

dkeg
#! Die Hard
From: Mid-Atlantic Grill
Registered: 2011-12-05
Posts: 716

Re: [SOLVED]Waldorf - failed to execute login command

+1 pvsage.  I agree with that decision.  I was unaware this was more widespread issue as when I had first posted I felt I was the minority.  Not glad it is more widespread, but happy I can be part of an ultimately better release.  I knew something bigger had to be at play here.


grill it | the rocky path may just be the best path

Offline

#16 2012-09-26 14:51:36

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,984

Re: [SOLVED]Waldorf - failed to execute login command

Seems to not be a problem if everything is installed to a single partition, but I know many Debian users prefer to have a separate /home partition, if not the majority.


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#17 2012-09-26 14:54:06

dkeg
#! Die Hard
From: Mid-Atlantic Grill
Registered: 2011-12-05
Posts: 716

Re: [SOLVED]Waldorf - failed to execute login command

funny enough is that I did choose the option to have a separate /home partition.  Since I thought I f'd up somewhere I installed for a second time with same result.


grill it | the rocky path may just be the best path

Offline

#18 2012-09-26 15:18:51

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,984

Re: [SOLVED]Waldorf - failed to execute login command

I just noted in the latest development thread that there was no /etc/fstab created with the latest install image.  At first blush, this appears to be the crux of the issue.


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#19 2012-09-27 08:46:52

tivasyk
Member
From: kyiv, ukraine
Registered: 2010-08-30
Posts: 17
Website

Re: [SOLVED]Waldorf - failed to execute login command

dkeg wrote:
tivasyk wrote:

beg your pardon, but why has this been marked as [solved]? moving the contents of the entire /home partition for the distro to work, or having an empty fstab after install qualifies now for a solution? =/

I marked it solved b/c I am the OP.  And for me it is solved.  Please read the entire thread before chiming in.  If you follow the below solution kindly posted by @TemperingPick you should successfully be able to login.  If you need more details on the process, just post back and we or I will be happy to provide that instruction.

sorry, my comments must have sounded arrogant =/ they were not meant to be that way (it's just that english is not my native language and picking the right words to express myself is not easy).

i can and i have resolved the issue for myself rather quickly. what i wanted to express is that this thread is the «landing site» for people with the same problem searching for solution. not all of them are experts or even very confident linux users. markign the thread as [solved] would have been misleading for them as it was for me.

having said that, i also understand your logic when marking it as [solved]. i just hope the issue gets really-really solved some time soon =)

pvsage wrote:

I just noted in the latest development thread that there was no /etc/fstab created with the latest install image.  At first blush, this appears to be the crux of the issue.

most probably this is it: by re-starting with the liveusb, mounting the / volume on hdd, creating .xinitrc with exec openbox-session and creating the /etc/fstab based on the disk-manager info for the /home i was finally able to login correctly with /home automounted.

Last edited by tivasyk (2012-09-28 22:46:05)


[ corenominal mccoder has created a masterpiece. this is a linux distro. all craftsdwarfship is of the highest quality. it is crafted of scripts. it menaces with spikes of code. it menaces with spikes of theming. it depicts an image of a crunch. it depicts an image of a bang. the crunch is crunching. the bang is banging. ]

Offline

#20 2012-09-27 12:41:06

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 11,984

Re: [SOLVED]Waldorf - failed to execute login command

^ Yay!!! cool

Corenominal, our benevolent despot, was apparently already of the problem before it hit us; he said in the development thread that a quick repacking is in the works, so I'll go ahead and re-mark the thread as [SOLVED].


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#21 2012-09-27 12:56:40

tivasyk
Member
From: kyiv, ukraine
Registered: 2010-08-30
Posts: 17
Website

Re: [SOLVED]Waldorf - failed to execute login command

pvsage wrote:

^ Yay!!! :cool:
Corenominal, our benevolent despot, was apparently already of the problem before it hit us; he said in the development thread that a quick repacking is in the works, so I'll go ahead and re-mark the thread as [SOLVED].

great news, thank you for the update!

Last edited by tivasyk (2012-09-27 14:25:01)


[ corenominal mccoder has created a masterpiece. this is a linux distro. all craftsdwarfship is of the highest quality. it is crafted of scripts. it menaces with spikes of code. it menaces with spikes of theming. it depicts an image of a crunch. it depicts an image of a bang. the crunch is crunching. the bang is banging. ]

Offline

#22 2012-09-27 14:01:48

dkeg
#! Die Hard
From: Mid-Atlantic Grill
Registered: 2011-12-05
Posts: 716

Re: [SOLVED]Waldorf - failed to execute login command

@tivasyk, no worries man, its all good.  cool


grill it | the rocky path may just be the best path

Offline

#23 2012-09-28 23:55:47

tivasyk
Member
From: kyiv, ukraine
Registered: 2010-08-30
Posts: 17
Website

Re: [SOLVED]Waldorf - failed to execute login command

now the issue must be really solved with the release of the updated waldorf image.

p.s. i hope you enjoy the #! as much as i do =) check out this wallpapers set up on deviantart, it ideally fits the waldorf's dark theme.

linux_crunchbang11_01.jpg


[ corenominal mccoder has created a masterpiece. this is a linux distro. all craftsdwarfship is of the highest quality. it is crafted of scripts. it menaces with spikes of code. it menaces with spikes of theming. it depicts an image of a crunch. it depicts an image of a bang. the crunch is crunching. the bang is banging. ]

Offline

#24 2012-10-02 17:25:10

gunt
Member
Registered: 2012-01-30
Posts: 27

Re: [SOLVED]Waldorf - failed to execute login command

Hi guys I was getting the same error many times.

Failed to excute login command

I use the debian custom script from Stanie with a few tweaks.
http://crunchbanglinux.org/forums/post/261842/#p261842

I fix this editing the xinitrc file  in /etc/X11/xinitrc

#!/bin/sh

# /etc/X11/xinit/xinitrc
#
# global xinitrc file, used by all X sessions started by xinit (startx)

# invoke global X session script
#. /etc/X11/Xsession
exec openbox-session

I explain this in the stanie post here
>>   http://crunchbanglinux.org/forums/post/261842/#p261842

If anyone have the same problem you can fix it this way and from there try to install slim again or lightdm.
Remember to uncomment the line

. /etc/X11/Xsession

After you install another display manager

Offline

Be excellent to each other!

#25 2012-11-29 11:57:17

settecplus
New Member
Registered: 2012-11-29
Posts: 7

Re: [SOLVED]Waldorf - failed to execute login command

Hi guys!
I know this has been marked as solved, but since this solution , in fact, didn't solve my issue, I just gonna share what really solved it for me.
After installing the latest image from scratch, with NO separate /home partition, everything was working ok for a few days. Then, after an upgrade, I had the dreaded "cannot execute login command".
/var/log/slim.log was just showing and unexpected signal 15, but no other strange errors.
I tried uninstalling and reinstalling slim, but it was a no-go.
Finally the solution:
- as already stated, create the .xinitrc in your home, with exec openbox-session
- edit /etc/slim.conf and change the login_cmd to: login_cmd exec /bin/bash - ~/.xinitrc %session

Please keep in mind I'm not an expert linux user, so do it at your own risk smile

Luc

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo