Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-05-05 19:59:47

#! Member
From: Germany
Registered: 2012-05-05
Posts: 71

Installing NVIDIA official Linux Drivers

Here is a tutorial for installing the official NVIDIA Driver on Crunchbang Waldorf
Normaly there are all drivers in the kernel, but I recognized that my graphiccardfan
was loud and up to 100%... So I tried the official driver from NVIDIA.
On OpenSuse it worked, but on Crunchbang I had a lot of problems and a few
hours of work. So here is the simpliest solution I found.
Special thank to the guide from kri5 on crunchbang forum. … g-statler/
and to all people writing posts in this thread on debianforum

-> I'm not a linux geek or profi, so I don't garantee that everything I write is right.
But it should work. So give it a try.

First Download the official driver to for example "Downloads" (standard Folder)

Then Logout and Press   CTRL+ALT+F1 to go to the terminal.
Login with your login data.

1. Disabling X-Server / Graphical Desktop

sudo /etc/init.d/slim stop

2. Disable Kernel "Nouveau"

sudo nano /etc/modprobe.d/blacklist.conf

Add the following lines here.

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

Then press Ctrl+o to save and confirm save location with enter.
Then press Ctrl+x to close nano-editor

3. Remove all installed NVIDIA drivers

sudo apt-get remove --purge nvidia*

4. Remove Kernelfiles

sudo apt-get remove nouveau

5. Restart your PC

sudo reboot

6. Login to console again with CTRL+ALT+F1
and stop X-Server / Slim again as in step 1

7. Go to the directory where the driver was saved

cd downloads

8. TRY installing driver with

sudo sh

If it does as it should there should be everything okay, but as it was with me there appeared an error.
There was no Kernel-Source tree installed. In OpenSuse there is an tutorial given wich works with Suse
but not with crunchbang so here is the tutorial for crunchbang

9. Install module assistand for kernel building

sudo apt-get install module-assistant

10.  Prepare your Kernel

sudo m-a prepare

11. Try to install the driver again and it should WORK big_smile

sudo reboot

Last edited by DerLateinProfi (2012-05-05 20:08:30)

Are you sad if you're not happy?
Are you running Windows when Linux got broken?
-> No! You'll fix it big_smile So be happy!


Be excellent to each other!

#2 2012-05-05 20:04:27

Registered: 2011-03-09
Posts: 4,396

Re: Installing NVIDIA official Linux Drivers

a how-to as your first post. that is always great smile
only thing i was wondering when reading this is 'where is the link to the NVIDIA driver?'
of course you can Google it, but would be more logical (to me) to include the link in the how-to, for ease-of-use purposes.

that said, why don't you head over to the Introductions subforum and get yourself a real welcome from the community? smile


#3 2012-06-17 01:45:58

Registered: 2012-06-16
Posts: 35

Re: Installing NVIDIA official Linux Drivers

I keep getting:
ERROR: Unable to determine the version of the kernel sources located in '/lib/modules/3.2.0-2-686-pae/source'. Please make sure you have installed the kernel source files for your kernel and that they are properly configured; on Red Hat Linux systems, for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM installed. If you know the correct kernel source files are installed, you may specify the kernel source path with the '--kernel-source-path' command line option.

I tried this: … n-waldorf/
Now my GUI's completely gone.

Last edited by Chris740 (2012-06-17 04:12:44)


#4 2012-06-17 09:07:36

The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Installing NVIDIA official Linux Drivers

You trying different things makes it difficult to guess what went wrong.
If you could post the output of

cat /var/log/Xorg.0.log

it would help.


#5 2012-06-17 20:25:57

Registered: 2012-06-16
Posts: 35

Re: Installing NVIDIA official Linux Drivers

I re-installed CrunchBang. I'll be starting from scratch. Following the instructions on this thread, now I get:

Building kernel module:
(I see a progress bar go to 100%)

ERROR: Unable to build the NVIDIA kernel module.

ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. etc...

Last edited by Chris740 (2012-06-18 01:13:18)


#6 2012-06-18 09:10:18

The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Installing NVIDIA official Linux Drivers

I guess you dont have the linux headers installed:
Try this:

sudo apt-get install linux-headers-$(uname -r)

Then restart the command that produced the error.

If you get the same error, post the output of the command:

sudo cat /var/log/nvidia-installer.log

in this forum.


#7 2012-06-19 01:24:36

Registered: 2012-06-16
Posts: 35

Re: Installing NVIDIA official Linux Drivers

The full output is to long to post here. The first error I get is:
   test -e include/generated/autoconf.h -a -e include/config/auto.conf || (        \
       echo;                                \
       echo "  ERROR: Kernel configuration is invalid.";        \
       echo "         include/generated/autoconf.h or include/config/auto.conf are
       echo "         Run 'make oldconfig && make prepare' on kernel src to fix it
   .";    \

Attempting to enter:
sudo make oldconfig
make: *** No rule to make target 'oldconfig'. Stop
Same with make prepare.

Last edited by Chris740 (2012-06-19 02:34:00)


#8 2013-03-17 23:26:25

New Member
Registered: 2013-03-17
Posts: 2

Re: Installing NVIDIA official Linux Drivers

Thanks DerLateinProfi.

After black screens from other non-CLI solutions I tried this and everything popped up with all monitors working perfectly.


#9 2013-04-06 11:10:55

Registered: 2012-11-06
Posts: 27

Re: Installing NVIDIA official Linux Drivers

How can you uninstall the nvidia driver if i wanna use the open source driver again?


#10 2013-04-07 15:57:56

Registered: 2012-12-29
Posts: 29

Re: Installing NVIDIA official Linux Drivers

This worked for me with a few issues though (see below) Thanks so much!
I run a NVIDIA GeForce GTX260

A few Issues:

On step 2 - sudo nano /etc/modprobe.d/blacklist.conf
Issue: I did not have this file. and when I tried to create it, it still didn't do the trick.
Fix:  The nvidia driver I downloaded from their site has an error message that says something like "nouveau is still active and we can't install the drivers, we can add a file to /etc/modprobe.d/ which will disable nouveau for SOME distros - yes/no?"  I said yes and rebooted.  This disabled nouveau for me.

Issue2: I was presented with another error message that said somethign like "the version of gcc doesn't match what was used to build your kerel.   Are you sure you want to proceed? Do you know what you're doing!?! yes/no"
Fix: I lied and said yes I know what i'm doing.  It went on w/o a hitch.

Issue3: It asked if I wanted to install some 32bit compatible opengl stuff.
Fix: I said nope.  I run 64bit #! so I felt like this would be a bad idea. (if someone knows that this was a bad choice let me know)

After that It ran, I rebooted and screen layout editor had all the resolutions and settings I'd expect.  I then played Rochard and the graphics issues I was having w/ the nouveau driver went away (I weird blur effects that looked horrible. Also, whenever I picked something up w /the G-Lifter it looked like a solid circle).

Again thanks so much!   big_smile


Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: zapp

Debian Logo