SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-12-29 20:05:45

okanagansage
New Member
Registered: 2011-12-29
Posts: 3

[Solved] How do I disable switching workspaces using the scrollwheel?

Hi, I just downloaded CrunchBang 10. I need to get a few things working but first I want to stop the scroll-wheel from changing workspaces. This keeps happening when I am trying to scroll down on a page and the cursor is not over the browser.

I know this is a minor thing but it is annoying and I want to change it. Thanks.

Last edited by okanagansage (2011-12-29 21:57:55)

Offline

Help fund CrunchBang, donate to the project!

#2 2011-12-29 20:28:08

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: [Solved] How do I disable switching workspaces using the scrollwheel?

Do you intend to use more than one workspace?

I only use one and by changing to one workspace eliminates the change when scrolling

having said that, here you can find a solution


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#3 2011-12-29 20:41:22

2ManyDogs
dv#!
From: elsewhere
Registered: 2011-11-22
Posts: 1,346

Re: [Solved] How do I disable switching workspaces using the scrollwheel?

Edit rc.xml

Find the following section:

<context name="Desktop">
      <mousebind button="Up" action="Click">
        <action name="DesktopPrevious"/>
      </mousebind>
      <mousebind button="Down" action="Click">
        <action name="DesktopNext"/>
      </mousebind>

comment it out so it looks like this

<context name="Desktop">
      <!-- 
      <mousebind button="Up" action="Click">
        <action name="DesktopPrevious"/>
      </mousebind>
      <mousebind button="Down" action="Click">
        <action name="DesktopNext"/>
      </mousebind>
      -->

edit: Don't forget to reconfigure Openbox after you make this change and save the file. Either use the Reconfigure Openbox menu option, or type "openbox --reconfigure" in a terminal. (added in case anyone else happens on this thread and forgets this very important step).

edit: I see VastOne beat me to it... Oh well, at least I learned how to use code brackets hmm

Last edited by 2ManyDogs (2011-12-30 16:57:41)


Be eggsalad to each other.

Offline

#4 2011-12-29 20:43:35

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: [Solved] How do I disable switching workspaces using the scrollwheel?

^ Yours is laid out here and will be one more that a user will find when a search is done..

Well done big_smile

Last edited by VastOne (2011-12-29 20:43:48)


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#5 2011-12-29 20:50:10

2ManyDogs
dv#!
From: elsewhere
Registered: 2011-11-22
Posts: 1,346

Re: [Solved] How do I disable switching workspaces using the scrollwheel?

Thanks -- this has actually been bugging me too, and this question made me go figure out how to do it and how to post the answer with code brackets. I'm learning something new every day.


Be eggsalad to each other.

Offline

#6 2011-12-29 22:03:21

okanagansage
New Member
Registered: 2011-12-29
Posts: 3

Re: [Solved] How do I disable switching workspaces using the scrollwheel?

Thanks VastOne and 2ManyDogs. That's much better. I made a backup of rc.xml and named it rc.xml.backup. I'm assuming this won't cause any problems having it in the same folder.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo