SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-12-15 00:16:57

DB_Cooper
#! Member
From: A narrowboat, English canals
Registered: 2010-01-23
Posts: 56

Another Slim problem? (SOLVED)

Just downloaded and installed but cannot get past the username/password bit. If I input the correct username/password it returns briefly to the previous text screen then back to the username screen. If I input the incorrect username/password it just returns me to the username screen.

I've tried both graphical and text installs. It works well in virtualization and as a live usb

Never had a problem before.

Any ideas?

My #! Alpha 2 is getting a little slow now (too much going on) and I would like to get things speeded (sic|) up again.

Dan

Last edited by DB_Cooper (2011-12-15 19:25:14)


Dan

Offline

Help fund CrunchBang, donate to the project!

#2 2011-12-15 00:48:12

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: Another Slim problem? (SOLVED)

I would recommend using tty1 (ctrl/alt/f1) and login to make sure you have a login at all..


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#3 2011-12-15 01:17:44

DB_Cooper
#! Member
From: A narrowboat, English canals
Registered: 2010-01-23
Posts: 56

Re: Another Slim problem? (SOLVED)

The login works through tty but when there, startx doesn't, well, start x. Or does that only work as root?

Looks like it may be a Slim problem.


Dan

Offline

#4 2011-12-15 01:22:29

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: Another Slim problem? (SOLVED)

From tty1 you could run

sudo apt-get install lightdm

and chose it as your dm when asked

Then reboot and see if you can login

This will verify if it is a SliM issue


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#5 2011-12-15 01:44:58

DB_Cooper
#! Member
From: A narrowboat, English canals
Registered: 2010-01-23
Posts: 56

Re: Another Slim problem? (SOLVED)

No, it's not locating lightdm. I knew I should never have started this tonight.

Anyway, #! Alpha 2 was excellen!!!


Dan

Offline

#6 2011-12-15 01:48:51

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: Another Slim problem? (SOLVED)

I was not aware lightdm was not in Stable

Sorry about that

You could install gdm instead

sudo apt-get install gdm

VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#7 2011-12-15 02:00:03

DB_Cooper
#! Member
From: A narrowboat, English canals
Registered: 2010-01-23
Posts: 56

Re: Another Slim problem? (SOLVED)

I'm on a dongle here and it won't go on-line without network manage up and running.

I'll try again in the morning with a reinstall of the iso onto the flash drive. The downloaded iso has a good md5sum so that's all tickety boo.

Many thanks VastOne for your help.


Dan

Offline

#8 2011-12-15 08:35:26

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,016

Re: Another Slim problem? (SOLVED)

Take a look at ~/.xsession-errors when logging in through tty1 wink


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres
Github

I am a #! forum moderator. Feel free to send me a PM with any question you have!

Online

#9 2011-12-15 11:38:54

kelean
#! CrunchBanger
Registered: 2009-01-21
Posts: 178

Re: Another Slim problem? (SOLVED)

When you installed did you use your home directory from a previous install.  I had that same problem when I used my home dir.  I think it has something to do with the switch from gdm to slim.

Offline

#10 2011-12-15 14:07:00

donkeyotay
#! CrunchBanger
From: Everywhere
Registered: 2011-01-28
Posts: 192

Re: Another Slim problem? (SOLVED)

If you have used your old /home then I had a similar problem & after much to-ing & fro-ing & a great deal of help on these forums, I did a clean install. Just couldn't find a way around the problem
HTH
Simon


I didn't say it was your fault... I said I was going to blame you.

Offline

#11 2011-12-15 14:14:14

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,016

Re: Another Slim problem? (SOLVED)

To both of you, did you check if you had a ~/.xinitrc file? Cause if you don't, SLiM won't work


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres
Github

I am a #! forum moderator. Feel free to send me a PM with any question you have!

Online

#12 2011-12-15 16:15:32

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: Another Slim problem? (SOLVED)

If you did use an existing /home on your install and used the same login name, it is possible it is a permissions issue

If that is what you did,  you can run this from tty1 and it should correct the issue

login to tty1 then

sudo su
chown -R yourusername:yourusername /home/yourusername

VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#13 2011-12-15 19:19:06

DB_Cooper
#! Member
From: A narrowboat, English canals
Registered: 2010-01-23
Posts: 56

Re: Another Slim problem? (SOLVED)

Many thanks to VastOne, donkeyotay & kelean. I was indeed using the existing home partition and this conflicted with Slim. Copied, deleted and renewed.

I note that papnominal does recommend a clean install but I ignored him as I thought I knew better. What does he know, He's from Lincolnshire. Oh silly me.

Cheers one and all.

#! Alpha two  is indeed now dead. Long live #! 10-2011125 (it just doesn't have the same ring)


Dan

Offline

#14 2011-12-15 19:20:42

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: Another Slim problem? (SOLVED)

Great to hear DB  smile

Make sure and edit the original post title with a (Solved)


VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#15 2011-12-15 19:38:24

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: Another Slim problem? (SOLVED)

DB, I was surprised to read you were still using Alpha-2, but it was a dandy little distro, wasn't it!  Also happy to know you've got a fix on this.

Offline

#16 2011-12-15 19:47:30

DB_Cooper
#! Member
From: A narrowboat, English canals
Registered: 2010-01-23
Posts: 56

Re: Another Slim problem? (SOLVED)

If it ain't broke and all that. I also had quite a few customizations that I'll have to repeat (if I can remember how) with the new install including stuff not in the repos.

That's the problem with this forum, It gives you ideas above your station.

The joy of Linux.


Dan

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo