SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-07-06 08:26:51

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,619
Website

HowTo: Fully disable screensaver/screen blanking

Just in case somebody wants to turn of blanking of the screen (beyond disabling the screensaver) here is a failsafe tongue method:

- edit your autostart and add

xset -dpms &
xset s noblank &
xset s off &

- if you have an xorg.conf file, edit it as root and add in the section "ServerLayout":

Option          "BlankTime"     "0"
Option          "StandbyTime"   "0"
Option          "SuspendTime"   "0"
Option          "OffTime"       "0"

and in the section "Monitor":

Option          "DPMS"

where you can alternatively just add:

Option          "NODPMS"

without the aforementioned ServerLayout options

Last edited by machinebacon (2011-07-06 08:27:42)

Offline

Be excellent to each other!

#2 2011-07-18 20:03:30

Bane
#! CrunchBanger
From: Carlisle, UK
Registered: 2008-12-28
Posts: 135

Re: HowTo: Fully disable screensaver/screen blanking

@machinebacon

Thanks for that.

I usually use XBMC for viewing vids (from a flash drive (no HD yet)), but sometimes, while I'm working on PC I want to watch summat via VLC. However, the screen goes blank after a short while (obviously the power management is a bit unreliable - I don't use a screensaver). I even told VLC (i think in vlc.conf) not to blank - to no avail.

I added your 3 lines to autostart.sh & it worked a treat.

Again, thank you very much big_smile


Hail #!

Offline

#3 2011-07-21 12:05:53

bozhkov
#! Junkie
Registered: 2009-12-29
Posts: 463

Re: HowTo: Fully disable screensaver/screen blanking

http://crunchbanglinux.org/forums/topic … reensaver/

In this thread I wondered if it is possible to create a script to enable/disable screen blanking - which in my opinion would be a better variant than to disable it completely. Now I am trying Ubuntu and its Unity interface - there is a really convenient program there called Caffeine which can disable screen blanking automatically - when you're seeing a flash video or you can set it to disable it when VLC is on. smile You have to check if it is available for debian.

Offline

#4 2011-07-22 18:05:53

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,619
Website

Re: HowTo: Fully disable screensaver/screen blanking

Thanks for the info. I actually really wanted to disable the blanking completely - so it turns never ever black.

For those who want DPMS, there is still the (x)screensaver which can act as conventional screensaver and of course the xset commands, which could be easily called by a script or keybindings/shortcuts. xset has all the power management options (xset dpms force on / xset dpms force off) as well as screensaver (xset s off / xset s on) and blanking function (xset s blank) etc. In this case the changes in xorg.conf are not needed. I have only mentioned them for the sake of completeness.

Offline

#5 2011-07-25 09:35:09

Bane
#! CrunchBanger
From: Carlisle, UK
Registered: 2008-12-28
Posts: 135

Re: HowTo: Fully disable screensaver/screen blanking

After working perfectly for a while now my screen becomes a giant X!!! hmm


Hail #!

Offline

#6 2011-07-25 10:29:40

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,619
Website

Re: HowTo: Fully disable screensaver/screen blanking

Bane wrote:

After working perfectly for a while now my screen becomes a giant X!!! hmm

You have used the three xset commands in autostart? There shouldn't be a problem. Have you recently upgraded your system/kernel/xserver (by upgrading, eg.)?
Comment the three entries and reboot/restart gdm.

Offline

#7 2011-08-08 10:57:29

bozhkov
#! Junkie
Registered: 2009-12-29
Posts: 463

Re: HowTo: Fully disable screensaver/screen blanking

https://launchpad.net/~caffeine-developers/+archive/ppa

Can anyone try it on #! openbox (the hardy version) as I don't have it atm. Accotrding to this site it could be installed on debian testing (from 2010) which was later on released as Squeeze, so I reckon it is possible.

Offline

#8 2012-01-16 16:31:31

ostralopithicus
New Member
Registered: 2011-11-01
Posts: 2

Re: HowTo: Fully disable screensaver/screen blanking

I've successfully installed Caffeine and it works!  It required some bits though that I couldn't get through squeeze, so I took a bit of risk and briefly added ubuntu lucid repository with the lucid repo for caffeine and then added caffeine. I then removed the ubu repos and 'upgraded' the components that had been downgraded to get caffeine to install, minus one or two new prerequisites.  Crossed my fingers and launched it and it works.

For those that don't know, caffeine automatically turns off the screensaver and powersaving when flash player or anything you put into the list activates. It then turns them back on automatically when they are finished.  Works very well with flashplayer - disables screensaver for the duration of the vid and no more.

Last edited by ostralopithicus (2012-01-16 16:35:19)

Offline

#9 2012-03-22 16:59:34

pjbrunet
#! Member
From: Austin, Texas
Registered: 2011-07-30
Posts: 90
Website

Re: HowTo: Fully disable screensaver/screen blanking

"After working perfectly for a while now my screen becomes a giant X!!! "

I'm having the same problem.  I'm playing wackamole here, I disable one screensaver and another one takes over, very frustrating. 

I added the three commands to autostart and rebooted but I don't have xorg.conf.  Should I create xorg.conf just for these commands?  That's what I'm going to try next.


PHP Developer http://Tomakefast.com

Offline

#10 2012-03-22 17:34:05

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: HowTo: Fully disable screensaver/screen blanking

Did you install the latest version of the kernel - 3.2.0-0.bpo.2-arch - perhaps?

Offline

#11 2012-03-25 01:54:18

pjbrunet
#! Member
From: Austin, Texas
Registered: 2011-07-30
Posts: 90
Website

Re: HowTo: Fully disable screensaver/screen blanking

@xaos, I know very little about kernels.  uname -r says 2.6.32-5-686.  I'm not even sure if it's my fault I'm having this problem because last month I installed several power-saving packages, mostly intending to reduce heat off my desktop, but along with those packages I'm thinking my screen saver could have been affected.  So the big "X" (that periodically moves around the screen and changes sizes) came after I removed all of the "screen saver" packages on my system I could find using Synaptic.  Well, I didn't want to waste a ton of time configuring xorg.conf, especially since everyone is saying xorg.conf is obsolete now.  So my solution was just to re-install XScreenSaver--the maximum amount of time is 720 minutes, which is enough time to watch a movie so problem solved, I guess.  The devil you know vs. the devil you don't.  But if I disable XScreenSaver, the mysterious "backup" screensaver kicks in.  LOL.


PHP Developer http://Tomakefast.com

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo