SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 Re: Help & Support (Stable) » [Solved] Heimdall install problems? » 2014-06-27 18:11:52

No need for apologies.
Glad I could help.
And I appreciate you taking the time to tell us it worked.  smile

#2 Re: Help & Support (Stable) » [Solved] Heimdall install problems? » 2014-06-24 16:13:30

You need the version from backports for package libusb-1.0-0-dev

See http://backports.debian.org/Instructions/ for instructions on how to do this.
Follow instructions for 'wheezy'.

In short:
1. edit /etc/apt/sources.list
2. run sudo apt-get update
3. run sudo apt-get -t wheezy-backports install libusb-1.0-0-dev
4. restart the 'make' command that gave you errors. It should run OK now.

#3 Re: Help & Support (Stable) » boot operation take long time » 2014-06-24 12:18:04

The sensible thing to do in this case is examine what has been installed after the initial install.
You can find that out in file /var/log/apt/history.log if you are using apt, or /var/log/aptitude if using aptitude.
Remove these packages one by one and check your boot time.

Do not autostart services that you do not need after every boot. I am looking at skype for instance. Start it manually if you really need to use it.

#4 Re: Help & Support (Stable) » [Solved] Heimdall install problems? » 2014-06-23 19:42:44

One way to check if 'libusb-1.0-0-dev' is installed is:

apt-cache policy libusb-1.0-0-dev

Another way is

dpkg -L libusb-1.0-0-dev

The second one lists all files in the package. The file you seem to be missing is '/usr/include/libusb-1.0/libusb.h', which defines the libusb_log_level enumeration.

#5 Re: Help & Support (Stable) » [Solved] Heimdall install problems? » 2014-06-23 12:06:54

Works for me too. (But I am on Debian sid.)

Looks like you are missing package 'libusb-1.0-0-dev'.

Restart from the beginning, especially watch for installation of mentioned package in the fist step (sudo apt-get install ...)
Copy/paste the whole line to prevent typo's.
Both cli and frontend work.

#6 Re: Help & Support (Stable) » boot operation take long time » 2014-06-23 10:16:12

@overkill

1. How to slim down your initrd:

   Check initrd filesize in /boot ( ls -alh /boot )

   As root, edit /etc/initramfs-tools/initramfs.conf:

   replace

MODULES=most

by

MODULES=dep

   Save the file and rebuild initramfs:

sudo update-initramfs -u

   Check initrd file size in /boot. Compare with the original file size.

   Reboot to test if it works.

   Remarks:
   
   1. Your initrd is 26MB. On a default lubuntu install it is 19M. How come?
   2. This will shave off only a fraction of your total boot time.
   3. You have kernel version Linux version 3.13.0-29-generic running. Default is Linux version 3.13.0-24-generic. How come? Where did you get it from?

2. For the 5s your system needs to the HP screen, google for 'slow boot on BIOS' for suggestions to cure.

3. Mounting your root file system does NOT take excessively long.

Conclusion:

Your system boots in approx 22s according to the logs, including bringing up the wireless. I don't use upstart and I don't know it well enough to judge if that is reasonable or not. I guess systemd can do better?

So it takes 30s or more to set up your working environment up to the login prompt. Use suggestions from previous posts to reduce that time, or post more information ( start by posting output of 'ps -eF' after logging in,to show what you have running ).

#7 Re: Help & Support (Stable) » boot operation take long time » 2014-06-22 09:21:46

@overkill:

1. Unpacking initramfs takes 0.5s, not 5s. Your initramfs is BIG. I am sure it can be reduced in size by only including in it what you really need.
2. Mounting your root filesystem does take 5s, which is a lot. probably because the root partition is BIG.
Post output of

df -ah

to show us the size and usage.

#8 Re: Off Topic / General Chat » koraco says may all your dreams come true » 2014-01-17 14:41:47

Hi el_k,

Did not recognize you in that show. Must say you looked better with the beard and the sunglasses. smile

Best wishes to you and the #! crowd.

xaos

#9 Re: Help & Support (Stable) » [SOLVED]autostart command (before slim login?) - hybrid graphics setup » 2013-11-15 10:27:25

The sudo commands wont work either. Change them to

echo DIGO | sudo tee /sys/kernel/debug/vgaswitcheroo/switch

idem for the second one.

#10 Re: Help & Support (Stable) » [SOLVED more or less] Changing recovery mode screen size » 2013-07-19 09:33:12

Or you could retain kms settings but specify your own resolution:
See this post

#11 Re: Help & Support (Stable) » [SOLVED more or less] Changing recovery mode screen size » 2013-07-17 13:59:52

To eliminate misunderstandings, you must realize that xrandr only has an effect for graphical applications - for xserver clients.
xrandr has no effect on the virtual console(s).

It is possible that you have to re-enter the xrandr command after a wake-up from sleep or hibernation.

if you want everything in a lower resolution - virtual consoles and xserver clients, you could add the 'nomodeset' kernel parameter.

#12 Re: Help & Support (Stable) » [SOLVED more or less] Changing recovery mode screen size » 2013-07-17 12:46:46

@OP - So the EDID info from your screen is correct.
Post output of

xrandr

to see which alternatives are available.

#13 Re: Help & Support (Stable) » [SOLVED more or less] Changing recovery mode screen size » 2013-07-17 11:51:16

The 'native resolution' of your screen is detected as being 1200x1600.
This is the so-called EDID info presented by your screen. The info could be wrong.
Post your /var/log/Xorg.0.log file please, to see that info.

#14 Re: Help & Support (Stable) » [SOLVED more or less] Changing recovery mode screen size » 2013-07-17 10:36:04

This is caused by 'Kernel Mode Setting' stepping in.
See the Debian wiki for more information.
What gfx card do you have? Post output of

lspci -knn | grep -EiA2 vga

#15 Re: Help & Support (Stable) » No functioning audio or touchpad after recent upgrade » 2013-07-13 09:55:11

Post complete output from commands

uname -rv
sudo udevadm --debug trigger --verbose
sudo cat /etc/modprobe.d/alsa-base.conf
lsmod|grep snd

#17 Re: Help & Support (Stable) » Error Installing Kernel 3.9-0.bpo.1-amd64 » 2013-07-12 18:11:46

You are not over generous with the information you provide.

The procedure should have shown you where the error log is located: /var/cache /modass/...

Please post the complete log file.

#18 Re: Help & Support (Testing/Unstable) » Weird graphic rendering in CrunchBang 11 » 2013-07-12 16:23:56

Did you do a normal install on the second system or somehow - rsync perhaps? - copied over the files?

Post output of

xrandr
cat /var/log/Xorg.0.log

from the malfunctioning system please.

#21 Re: CrunchBang Talk » Joe's repo grab-bag (testing like it's 1999) » 2013-07-12 14:46:42

@DJ, concerning LFS:

Did you verify the system requirements before you started building LFS, especially the requirement that /bin/sh should be link to /bin/bash?

The build instructions assume that the Host System Requirements, including symbolic links, have been set properly:

    bash is the shell in use.

    sh is a symbolic link to bash.

    /usr/bin/awk is a symbolic link to gawk.

    /usr/bin/yacc is a symbolic link to bison or a small script that executes bison.

Just another guess at what could have made things poop out for you  smile

#22 Re: Help & Support (Testing/Unstable) » Gthumb stopped working [Solved] » 2013-07-11 19:08:09

Are you mixing repos?
What repo are you tracking?
Post your /etc/apt/sources.list file please.

I installed gthumb myself now - on a Debian jessy system - and it works OK.
Of course it could be your data that is causing problems.

#23 Re: Help & Support (Testing/Unstable) » boot problem (lvm?) » 2013-07-11 19:01:50

How would i mount the volume group from the grml cd?

1. boot into live system from grml CD - enable lvm
2. create a mount point and mount the lvm, e.g.
mkdir /tmp/lvm1
sudo mount /dev/mapper/vg_debian-root /tmp/lvm1

How would I check the initramfs of the internal hd?

lsinitramfs <path-to-your-initramfs-fileon hd>

#24 Re: Help & Support (Testing/Unstable) » [SOLVED?] ### WARNING ### for users following jessy and using LVM » 2013-07-11 18:49:13

Never mind.

False alarm, caused by

this post
this bug report
and new package - libllvm3.2:amd64 (1:3.2repack-10) ... - being installed when you dist-upgrade jessy.

However,
I did the dist-upgrade and everything is still working OK for me.

Proviso:
I was already running kernel 3.9-1-amd64 #1 SMP Debian 3.9.8-1 - perhaps the problem occurs when upgrading from an older kernel?

Conclusion:
Thread with caution.

#25 Re: Help & Support (Testing/Unstable) » Gthumb stopped working [Solved] » 2013-07-11 16:53:55

And the common error 4:

The cause was a user-mode read resulting in no page being found.

(also known as a null pointer dereference).

Nothing usable in there.

Try removing and re-installing gthumb.
No guarantees it will work.
Could be an error in one of it dependencies too.

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo