SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#76 2015-09-06 10:23:14

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: Weather Conky - Finnish and International - Ilmatieteen Laitoksen Sää

just a small reminder:
some distros already use conky 1.10.x versions by default, using the new lua syntax.
My conky uses the old syntax. I haven't tried it, but I'm 99% sure that this script will not work with the new version. even converting it (the conky 1.10 versions come with a converter script) won't be sufficient, because the shell script produces actual (old) conky syntax.

I have yet to make a decision what to do with this in the future... for now:
on archlinux i can choose to install conky 1.9, but i have to see if it's possible to have both versions installed.
debian stable has not yet hit the 1.10 version.

Offline

Be excellent to each other!

#77 2015-09-06 15:29:17

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Weather Conky - Finnish and International - Ilmatieteen Laitoksen Sää

I discussed the possibility with both installed not long ago.  I don't think it is possible.  Unless you are a coder and took the code of v1.10 for example and changed all instances of conky to "konky" (example) and then recompiled it.

Depends list looks fairly compatible:

conky-all v1.9.0-6 & v1.10.0-1

double entry - common to both
single entry - see tail

Depends list

    dep: libaudclient2 (>= 2.3)
    dep: libaudclient2 (>= 2.3)

    dep: libc6 (>= 2.17)
    dep: libc6 (>= 2.17)

    dep: libcairo2 (>= 1.8.0)
    dep: libcairo2 (>= 1.8.0)

    dep: libcurl3-gnutls (>= 7.16.2)
    dep: libcurl3-gnutls (>= 7.16.2)

    dep: libdbus-glib-1-2 (>= 0.78)
    dep: libdbus-glib-1-2 (>= 0.78)

    dep: libgcc1 (>= 1:4.2.1) [mips, mipsel, powerpc] - conky-all_1.10.0-1 only

    dep: libgcc1 (>= 1:4.4.0) [armhf] - conky-all_1.10.0-1 only

    dep: libgcc1 (>= 1:4.7) [arm64] - conky-all_1.10.0-1 only

    dep: libglib2.0-0 (>= 2.12.0)
    dep: libglib2.0-0 (>= 2.12.0)

    dep: libimlib2 (>= 1.4.5)
    dep: libimlib2 (>= 1.4.5)

    dep: libiw30 (>= 30~pre1)
    dep: libiw30 (>= 30~pre1)

    dep: liblua5.1-0
    dep: liblua5.1-0

    dep: libncurses5 (>= 5.5-5~)
    dep: libncurses5 (>= 5.5-5~)

    dep: librsvg2-2 (>= 2.35.2) - conky-all_1.10.0-1 only

    dep: libstdc++6 (>= 4.9) - conky-all_1.10.0-1 only

    dep: libtinfo5
    dep: libtinfo5

    dep: libx11-6
    dep: libx11-6

    dep: libxdamage1 (>= 1:1.1)
    dep: libxdamage1 (>= 1:1.1)

    dep: libxext6
    dep: libxext6

    dep: libxfixes3
    dep: libxfixes3

    dep: libxft2 (>> 2.1.1)
    dep: libxft2 (>> 2.1.1)

    dep: libxml2 (>= 2.7.4)
    dep: libxml2 (>= 2.7.4)

    dep: libxmmsclient6 (>= 0.7DrNo)
    dep: libxmmsclient6 (>= 0.7DrNo)

    dep: libxnvctrl0 [amd64, i386]
    dep: libxnvctrl0 [amd64, i386]

    sug: apcupsd
    sug: apcupsd

    sug: audacious
    sug: audacious

    sug: moc
    sug: moc

    sug: mpd
    sug: mpd

    sug: xmms2
    sug: xmms2

Conky v1.10 is in testing and sid though.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo