Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-05-22 22:57:15

Registered: 2013-03-25
Posts: 16

Umount a cifs share as user mounted by Autofs on "Jessie"

Hello, after dist-upgrade to Debian 8 I have a problem. Autofs is still mounting fine but only root can umount the cifs share. Seems like the option "users" lost its function. Instead I*ve tried "uid=1000,gid=1000" but still I have no permission to umount. If I perform a reboot or shutdown, it takes a while, a few minutes. I guess because of that issue. Any hint is appreciated.


FRITZ!NAS -fstype=cifs,users,username=ftpuser,password= ://

/etc/mtab is a symlink to /proc/mounts

/etc/auto.cifs-shares /media/cifs autofs rw,relatime,fd=6,pgrp=2620,timeout=300,minproto=5,maxproto=5,indirect 0 0
// /media/cifs/FRITZ!NAS cifs rw,nosuid,nodev,noexec,relatime,vers=1.0,cache=strict,username=ftpuser,domain=FRITZ-NAS,uid=0,noforceuid,gid=0,noforcegid,addr=,unix,posixpaths,serverino,acl,rsize=61440,wsize=65536,actimeo=1 0 0

Even tried to remove the symlink and use mtab as a file but it did not work either and the symlink is back after reboot anyway.


Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo