SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-03-25 08:23:22

Arminius
New Member
Registered: 2014-08-07
Posts: 5

SOLVED: Jessie: Job for sysfsutils.service failed

After upgrading Waldorf to Jessie I keep getting the following error message, even if no new packages are being installed:

$ sudo apt-get update
...
$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
Setting up sysfsutils (2.1.0+repack-4) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Job for sysfsutils.service failed. See 'systemctl status sysfsutils.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript sysfsutils, action "start" failed.
dpkg: error processing package sysfsutils (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 sysfsutils
E: Sub-process /usr/bin/dpkg returned an error code (1)

The systemctl --failed output is:

$ systemctl --failed
  UNIT               LOAD   ACTIVE SUB    DESCRIPTION
● snort.service      loaded failed failed LSB: Lightweight network intrusion det
● sysfsutils.service loaded failed failed LSB: Set sysfs variables from /etc/sys
$ systemctl status sysfsutils.service
● sysfsutils.service - LSB: Set sysfs variables from /etc/sysfs.conf
   Loaded: loaded (/etc/init.d/sysfsutils)
   Active: failed (Result: exit-code) since Wed 2015-03-25 09:03:52 CET; 9min ago
  Process: 2843 ExecStart=/etc/init.d/sysfsutils start (code=exited, status=1/FAILURE)

The contents of /etc/sysfs.conf is:

#
# /etc/sysfs.conf - Configuration file for setting sysfs attributes.
#
# The sysfs mount directory is automatically prepended to the attribute paths.
#
# Syntax:
# attribute = value
# mode attribute = 0600 # (any valid argument for chmod)
# owner attribute = root:wheel # (any valid argument for chown)
#
# Examples:
#
# Always use the powersave CPU frequency governor
# devices/system/cpu/cpu0/cpufreq/scaling_governor = powersave
devices/system/cpu/cpu0/cpufreq/scaling_governor = cpufreq_conservative
# 
# Use userspace CPU frequency governor and set initial speed
# devices/system/cpu/cpu0/cpufreq/scaling_governor = userspace
# devices/system/cpu/cpu0/cpufreq/scaling_setspeed = 600000 
#
# Set permissions of suspend control file 
# mode power/state = 0660
# owner power/state = root:power

Otherwise the distro works fine. I.e. I can install and remove packages without any problems, but I keep getting this annoying message. Can I fix this by editing sysfs.conf or another configuration file, or will I have to wait for the next sysfs release?

Last edited by Arminius (2015-03-25 13:51:39)

Offline

Help fund CrunchBang, donate to the project!

#2 2015-03-25 12:03:26

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: SOLVED: Jessie: Job for sysfsutils.service failed

If you think you can manage without sysfsutils, then you can prevent the service from trying to start with

sudo systemctl disable sysfsutils.service

BTW you also have snort.service failing as well


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#3 2015-03-25 12:58:57

heart1010
Member
Registered: 2015-03-13
Posts: 16

Re: SOLVED: Jessie: Job for sysfsutils.service failed

When dist-upgrading waldorf to jessie do we have to change something regarding sysvinit <-> systemd!? waldorf used sysvinit and after the dist-upgrade jessie uses systemd default without anything the user has to change/delete/config/install?

Offline

#4 2015-03-25 13:50:35

Arminius
New Member
Registered: 2014-08-07
Posts: 5

Re: SOLVED: Jessie: Job for sysfsutils.service failed

damo wrote:

If you think you can manage without sysfsutils, then you can prevent the service from trying to start with

sudo systemctl disable sysfsutils.service

You were right. After uninstalling sysfsutils, the problem went away and systemd no longer complains about snort.

Thanks!

Offline

#5 2015-03-25 14:04:45

Arminius
New Member
Registered: 2014-08-07
Posts: 5

Re: SOLVED: Jessie: Job for sysfsutils.service failed

heart1010 wrote:

When dist-upgrading waldorf to jessie do we have to change something regarding sysvinit <-> systemd!? waldorf used sysvinit and after the dist-upgrade jessie uses systemd default without anything the user has to change/delete/config/install?

dist-upgrade seems to be taking care of the sysvinit <-> systemd transfer. At least I didn't have to do anything.

When I ran systemctl --all I got a couple of not-found listings, though.

For example:

  UNIT                      LOAD      ACTIVE   SUB       DESCRIPTION
...
● var-lock.mount            not-found inactive dead      var-lock.mount
● var-run.mount             not-found inactive dead      var-run.mount
● keymap.service            not-found inactive dead      keymap.service
...

However, they don't seem to be causing any problems.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo