SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-02-02 04:44:49

cloverskull
#! Junkie
Registered: 2013-10-26
Posts: 377

No sound from speakers until I plug in and then unplug headphones

Hey guys, running sid, everything up-to-date as of Feb 1 2015. I'm kind of at a loss here...anything that uses sound is muted until I plug in headphones and then unplug them. It's as if pulse is outputting everything to the headphone jack and ignoring the speakers. Not really sure how to troubleshoot this. I haven't removed pulse or done anything funky with sound. The sound control applet has odd behavior of showing everything muted even if I try to change to unmuted. This hasn't always been this way - not really sure when or why this changed. Any ideas on how to troubleshoot?

Offline

Be excellent to each other!

#2 2015-02-03 06:34:08

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: No sound from speakers until I plug in and then unplug headphones

It is Pulse. How about looking into pavucontrol and then change from headphones to speakers.

Offline

#3 2015-02-04 06:01:16

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: No sound from speakers until I plug in and then unplug headphones

That's called headphone jack detection.

$EDITOR /etc/pulse/default.pa

comment this line

load-module module-switch-on-port-available

restart pulse and pray.


Sweaty lads picking up the soap | I love the new "Ignore user" button

Offline

#4 2015-02-04 14:37:37

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: No sound from speakers until I plug in and then unplug headphones

Off topic: Hello Bacon. smile

Offline

#5 2015-02-04 15:31:45

cloverskull
#! Junkie
Registered: 2013-10-26
Posts: 377

Re: No sound from speakers until I plug in and then unplug headphones

Interestingly enough this seems to have automagically fixed itself. I did an apt-get update and dist-upgrade today after not powering on my sid laptop for a couple weeks (been traveling) and after that...it just works. Thanks for the help though guys!

Offline

#6 2015-02-04 18:38:50

twoion
Moderator
Registered: 2012-05-11
Posts: 1,648

Re: No sound from speakers until I plug in and then unplug headphones

Oh, the joys of pulseaudio. Please, add [SOLVED] to the OP's title.

Last edited by twoion (2015-02-04 18:39:27)


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo