SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-01-14 18:03:08

oinkerz
Member
Registered: 2014-01-07
Posts: 20

VPS - vncviewer Issue

Hey guys. This isn't really a CrunchBang problem as I'm fairly certain it's just the fact I'm running it on a VPS. But I'm still hoping someone might have some insight on what I can do to solve the problem.

Basically I'm just trying to VNC to other servers from my VPS where I have CrunchBang installed. But when I attempt to VNC to any server, whether it's a server with an actual desktop interface or if it's just a CLI server, I get this error:

VNC server default format:
32 bits per pixel.
Least significant byte first in each pixel
True colour: max red 255 green 255 blue 255, shift red 16 green 8 blue 0
Can't cope with 24 bits-per-pixel

I did a bit of Googling and it seems as though as it's simple as what it says, my VPS is not running at a high enough bits-per-pixel. What I was wondering, is this something that is set on my VPS or can I change this somehow in the display configuration in CrunchBang on my VPS?

Any help would be greatly appreciated!

Offline

Be excellent to each other!

#2 2014-01-18 01:20:05

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: VPS - vncviewer Issue

Did you try:

man vncviewer

From this option text:

-FullColour, -FullColor
         Tells the VNC server to send full-colour pixels in the best format for  this
         display.   By default a low colour mode is used until AutoSelect decides the
         link is fast enough.   However  if  the  server's  native  pixel  format  is
         colourmapped  (as opposed to truecolour) then the server's format is used by
         default.

It looks like you might need to connect using:

vncviewer -FullColor

Offline

#3 2014-01-21 23:59:29

oinkerz
Member
Registered: 2014-01-07
Posts: 20

Re: VPS - vncviewer Issue

I tried that, however it seems that option doesn't exist. Where do you see -FullColor in the man page? I don't see it on my man page or the online man pages.

I attempted to use -bgr but that gave me the same result.

Offline

#4 2014-01-22 00:14:33

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: VPS - vncviewer Issue

It shows up in my man page.  I have this version:

VNC Viewer Free Edition 4.1.1 for X - built Jan 30 2013 16:07:52

And it's on this online man page:
http://linux.die.net/man/1/vncviewer
However, if the option doesn't work for you - then it's some other issue anyway...

EDIT: The FullColor option says it's the default, and it sends the best format FOR THIS DISPLAY... So, maybe your local X display has a lower bit depth than the remote vnc server.  You might want to try to set your default X display depth to 32 bits...  If your video card and physical screen can handle 32 bit depth, that is...

Something like this:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    32
    SubSection     "Display"
        Depth       32
    EndSubSection
EndSection

Last edited by retf (2014-01-22 00:37:33)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo