SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2011-11-08 14:22:48

kowloonboy
#! Junkie
Registered: 2011-10-13
Posts: 443

Re: Little MOC how-to

Sorry I got it.

Using the equalizer
+---
+The default keys for the equalizer are:
+'e' - Refresh equalizer
+'E' - Toggle equalizer (on/off)
+'k' - Select next preset
+'K' - Select previous preset
+
+Each of these actions results in a message displayed in the message area.
+This message will be overriden by the next action.


"To me, the extraordinary aspect of martial arts lies in its simplicity. The easy way is also the right way, and martial arts is nothing at all special; the closer to the true way of martial arts, the less wastage of expression there is." - Bruce Lee

Offline

Help fund CrunchBang, donate to the project!

#27 2011-11-08 22:52:22

safetycopy
urban legend
From: The Chatsubo
Registered: 2010-04-03
Posts: 1,311

Re: Little MOC how-to

Great how-to! I've almost got things working, but the volume keys . and , don't adjust my volume. The volume bar moves, but the actual volume doesn't change hmm I'm assuming this has something to do with the ALSA settings in ~/.moc/config, but I'm not sure...


i wonder if i missed the warning
Skinny Puppy, Love in Vein

Offline

#28 2011-11-08 23:03:51

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: Little MOC how-to

^ I told you don't touch it big_smile Kidding, it is this line:

# ALSA mixer device.
AlsaMixer         = PCM

# Second ALSA mixer device.
AlsaMixer2        = Master

try changing PCM to Master and Master to PCM


Sweaty lads picking up the soap | I love the new "Ignore user" button

Offline

#29 2011-11-08 23:06:56

safetycopy
urban legend
From: The Chatsubo
Registered: 2010-04-03
Posts: 1,311

Re: Little MOC how-to

^ That's the one - thanks mate big_smile


i wonder if i missed the warning
Skinny Puppy, Love in Vein

Offline

#30 2011-11-08 23:07:39

d2ogch3n
#! CrunchBanger
From: here
Registered: 2010-01-15
Posts: 201

Re: Little MOC how-to

^ that's odd. If you press 'x' does it cycle through Master PCM etc and do , and . work for any of those? If so you can set which is default in your ~/.moc/config. Mine looks like;

# ALSA mixer device.
AlsaMixer               = Master
 
# Second ALSA mixer device.
AlsaMixer2              = PCM
 
# ALSA output device.
AlsaDevice              = default

EDIT: Too slow smile

Last edited by d2ogch3n (2011-11-08 23:08:27)


.signature

Offline

#31 2011-11-08 23:11:26

safetycopy
urban legend
From: The Chatsubo
Registered: 2010-04-03
Posts: 1,311

Re: Little MOC how-to

Cheers for posting though, slow poke wink


i wonder if i missed the warning
Skinny Puppy, Love in Vein

Offline

#32 2011-11-10 14:01:04

safetycopy
urban legend
From: The Chatsubo
Registered: 2010-04-03
Posts: 1,311

Re: Little MOC how-to

Just a little note: I had to change the album part of of OnSongChange to get the album title to scrobble:

--album %r

(i.e. I changed %b to %r).

So, my OnSongChange line now looks like this:

OnSongChange = "/usr/lib/lastfmsubmitd/lastfmsubmit --artist %a --title %t --length %d --album %r"

Last edited by safetycopy (2011-11-10 14:01:27)


i wonder if i missed the warning
Skinny Puppy, Love in Vein

Offline

#33 2011-11-10 14:23:02

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Little MOC how-to

^ Oh, that is new info, thanks.

Offline

#34 2011-11-16 06:44:46

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Little MOC how-to

Also, if you want to improve your sound output with Alsa further, you could install the package libasound2-plugin-equal. Oh, it will boost your sound even more!

Now, I use just some of the EQ presets and am adjusting the sound through alsaequal, it is a bomb. And I have to say that it is actually the best sound I ever had on my Linux box.

This works only beginning with Wheezy but sure you could install it manually.

The project site.

How to configure it the easy way on Debian.

Enjoy.

Edit: Forgot a screenie of alsaequal in action. smile

Bildschirmfoto_16_11_2011_07_46_11.jpg

Last edited by ivanovnegro (2011-11-16 06:48:04)

Offline

#35 2012-05-31 19:11:23

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: Little MOC how-to

Every bump has a reason:

http://crunchbanglinux.org/wiki/howto/moc

Congratulations Davidoff big_smile


Sweaty lads picking up the soap | I love the new "Ignore user" button

Offline

#36 2012-05-31 19:43:51

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Little MOC how-to

^ Hey hey hey. Nice work æmáquina! I am honored. big_smile

You are really digging into the Wiki. Let us beat the Arsch Wiki.

Offline

#37 2012-06-04 06:47:08

h8uthemost
#! Junkie
Registered: 2011-08-09
Posts: 302

Re: Little MOC how-to

I'm not sure if my question is a moc thing or Scrotwm thing but I thought I would start here first.

I'm trying to implement some custom keybinds for moc in Scrotwm and through some searches I have found some. But I'm wanting to make more that I haven't been able to find yet. For example a keybind to Quit the client.

The keybinds I've found so far look like this:

program[mocp_prev]      = mocp -r
bind[mocp_prev]         = XF86AudioPrev
program[mocp_next]      = mocp -f
bind[mocp_next]         = XF86AudioNext
program[mocp_toggle]    = mocp -G
bind[mocp_toggle]       = XF86AudioPlay

And what I'm confused on is the -r, -f, and -G after 'mocp' in each example. What are those characters for and how do I figure what characters to use after 'mocp' for a Quit command?


We are a nice, friendly community here and I hope we stay that way.

Offline

#38 2012-06-04 06:53:36

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: Little MOC how-to

r = reverse
f = forward
G = ...Go?

To kill the moc server, you use `mocp -x`.  (x = exit)  To close the client (i.e. the terminal curses interface) just press q.  (q = quit)

The shortcuts should mostly be in the man page and the help file.

Offline

#39 2012-06-04 09:36:56

h8uthemost
#! Junkie
Registered: 2011-08-09
Posts: 302

Re: Little MOC how-to

Damn... Yeah you're right, those commands are listed in the man page. I always forget to look through those. I was looking through the keymap.examples file like the site suggested. I have to post a note to constantly remind me of the man page. tongue

Anyways, your suggestion works:

program[mocp_exit]      = mocp -x
bind[mocp_exit]         = (a keybind)

The above quits mocp.
Thank you pvsage.


We are a nice, friendly community here and I hope we stay that way.

Offline

#40 2012-06-19 19:41:10

SabreWolfy
#! Die Hard
Registered: 2009-03-09
Posts: 1,285

Re: Little MOC how-to

Thanks for this thread -- came here to get EQ setup in MOC smile


Support #!Waldorf • Debian sid • Xubuntu • siduction • Peppermint • OpenBox • Xfce • LXDE •

Offline

#41 2013-01-12 15:58:27

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: Little MOC how-to

so i started using MOC again!
one thing bothers me, maybe some1 can help:
when i close the interface and reopen it while playing sth, it always shows some outdated playlist on the right hand pane.
i changed my ~/.moc/config to those values:

StartInMusicDir		= yes
SavePlaylist		= no
SyncPlaylist		= yes

- amongst others, but these would seem to be relevant to the problem decribed.
???
thanks in advance.
d.

ps: is it possible to get mocp to play audio formats like m4a, wma,...?

Last edited by ohnonot (2013-01-12 16:00:09)

Offline

#42 2013-01-12 16:00:38

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Little MOC how-to

What about this:

SavePlaylist		= no

Change it to:

SavePlaylist		= yes

Though I never had to touch this setting.

Offline

#43 2013-01-13 07:55:27

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: Little MOC how-to

thanks ivanovnegro!
but sorry, i've been changing the config before i posted - i think it's the exact same line you're talking about - now the playlist pane is always empty.
is there no setting to always save playlist on exit?

edit: i changed saveplaylist back to yes and now it seems to work. i am totally sure it didn't work before. (muttering and grumbling to himself)

Offline

#44 2013-02-03 08:52:28

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: Little MOC how-to

i have to get back to this.
i am again having trouble with the playlist not being saved, although saveplaylist is set to yes.
it's the same with the softmixer_savestate setting. meaning, mocp always starts in 100% volume although the setting is yes and i have changed the volume.
i wonder if this is a glitc in mocp or am i missing sth.
i always quit mocp with a capital Q. so it's usually s and then Q.
???

Offline

#45 2013-06-14 15:18:10

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Little MOC how-to

Followed ivanovnegro's HowTo right up to the theme part not worried about that yet.

MusicDir              = "/media/5/Music"
StartInMusicDir = yes

It doesn't play ... What I get:
2013_06_14_12_06_22_1920x1080_Sector11.jpg

"What's this "Could not find codec parameters?" thing?

1. - gmusicbrowser plays the songs,
2. -  audacity plays them, and
3. - mplayer plays them ...

in a couple of words: Help please.

Last edited by Sector11 (2013-06-14 15:24:59)


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#46 2013-06-14 17:16:26

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Little MOC how-to

Strange. Obviously a codec problem.

Look at this:

http://moc.daper.net/node/873

I would try to remove the moc-ffmpeg-plugin (only needed for wma, acc, m4a) and then try again.
Could be Debian proper borked it with the libav/ffmpeg mess.

Offline

#47 2013-06-14 18:21:45

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Little MOC how-to

ivanovnegro wrote:

Strange. Obviously a codec problem.

Look at this:
http://moc.daper.net/node/873

I would try to remove the moc-ffmpeg-plugin (only needed for wma, acc, m4a) and then try again.
Could be Debian proper borked it with the libav/ffmpeg mess.

Yea, I researched all that first before coming here - my error - I should have mentioned Googling with no positive results first.

I started with getting just 'moc' because a friend said they used it ... when it didn't work I did a search here found your HowTo and got moc-ffmpeg-plugin - it still didn't work.

I then tried mp3blaster and got "Failed to open sound device"

Strange, any GUI app (I've tried) works - both CLI apps I have tried don't.  sad


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#48 2013-06-14 19:43:36

benhee
Member
From: North West UK.
Registered: 2009-10-28
Posts: 41

Re: Little MOC how-to

..I've had the same problem since new #! install, re-installed as per Ivan's suggestion i.e without moc-ffmpeg-plugin & now alls well,
...thanks Ivanovnegro !!!

Offline

#49 2013-06-14 20:36:40

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Little MOC how-to

sector11 wrote:

Failed to open sound device

Waldorf uses now Pulse, maybe there is something with this. MOC uses only Alsa AFAIK but that should not be a problem.

Edit: Is your line looking like this:

# Sound driver - OSS, ALSA, JACK, SNDIO (on OpenBSD) or null (only for
# debugging).
# You can enter more than one driver as a colon-separated list. The first
# working driver will be used.
SoundDriver = JACK:ALSA:OSS

# Jack output settings.
JackOutLeft = "alsa_pcm:playback_1"
JackOutRight = "alsa_pcm:playback_2"

# OSS output device.
OSSDevice = /dev/dsp

# OSS Mixer device.
OSSMixerDevice = /dev/mixer

# OSS Mixer channel: pcm or master.
OSSMixerChannel = pcm

# Second OSS Mixer channel: pcm or master.
OSSMixerChannel2 = master

# ALSA mixer device.
AlsaMixer = PCM

# Second ALSA mixer device.
AlsaMixer2 = Master

# ALSA output device.
AlsaDevice = default

Last edited by ivanovnegro (2013-06-14 20:39:55)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo