SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-06-03 12:50:36

tty-tourist
#! CrunchBangian
From: within the swirl
Registered: 2013-05-26
Posts: 281

Notifications don't fade very nicely

The notifications provided by xfce4-notifyd don't fade well on my system (using Waldorf).

Actually they fade as the should but before disappearing completely they turn black for a split second kinda ruining the fade effect.

Does anyone else get this? Any idea on how to fix it or alternatively on how to turn off fading?

Tried the different themes and settings in xfce4-notifyd-config but that doesn't change it ...

Thanks!

Last edited by tty-tourist (2013-06-03 16:27:00)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-06-03 16:55:24

monkey of rage
#! Member
From: The Net.
Registered: 2013-02-27
Posts: 55

Re: Notifications don't fade very nicely

# Shadow
shadow = true;
no-dnd-shadow = true;
no-dock-shadow = true;
#clear-shadow = true;
#shadow-radius = 7;
#shadow-offset-x = -7;
#shadow-offset-y = -7;
shadow-opacity = 0.4;
# shadow-red = 0.0;
# shadow-green = 0.0;
# shadow-blue = 0.0;
shadow-exclude = [ "n:e:xfce4-notifyd", "class_g ?= Notify-osd" ];
#shadow-ignore-shaped = false;

Last edited by monkey of rage (2013-06-03 17:01:20)


Bang on, Crunchy.
monkey

Offline

#3 2013-06-03 18:57:42

tty-tourist
#! CrunchBangian
From: within the swirl
Registered: 2013-05-26
Posts: 281

Re: Notifications don't fade very nicely

Last edited by tty-tourist (2013-06-03 18:58:48)

Offline

#4 2013-06-09 10:26:01

RichardGv
#! Member
From: People's Republic of China
Registered: 2013-01-13
Posts: 52

Re: Notifications don't fade very nicely

compton -f --fade-exclude 'argb'

Offline

#5 2013-08-02 10:21:02

GekkoP
#! Junkie
From: Vicenza (Italy)
Registered: 2013-06-17
Posts: 297
Website

Re: Notifications don't fade very nicely

Is there a solution to this? I got the same issue.

Offline

#6 2013-08-02 12:31:29

RichardGv
#! Member
From: People's Republic of China
Registered: 2013-01-13
Posts: 52

Re: Notifications don't fade very nicely

Offline

#7 2013-08-02 13:58:19

GekkoP
#! Junkie
From: Vicenza (Italy)
Registered: 2013-06-17
Posts: 297
Website

Re: Notifications don't fade very nicely

you're right.
But:
1) i want to keep openbox
2) turning off fading in argb windows didn't work
3) notification-daemon instead of xfce4-notifyd works, but it's not displaying all the notification I had with xfce4-notifd.

Last edited by GekkoP (2013-08-02 14:06:38)

Offline

#8 2013-08-02 14:07:50

RichardGv
#! Member
From: People's Republic of China
Registered: 2013-01-13
Posts: 52

Re: Notifications don't fade very nicely

compton --fade-exclude 'class_g = "Xfce4-notifyd"'

Last edited by RichardGv (2013-08-02 14:10:25)

Offline

#9 2013-08-02 14:16:40

GekkoP
#! Junkie
From: Vicenza (Italy)
Registered: 2013-06-17
Posts: 297
Website

Re: Notifications don't fade very nicely

In the case of notification-daemon, it's not displaying volume controls.
Turning off fading in argb just did nothing.
I already tried

compton --fade-exclude 'class_g = "Xfce4-notifyd"'

and the issue is still here.

So I installed notify-osd and the issue is gone.

Last edited by GekkoP (2013-08-02 14:17:11)

Offline

#10 2013-08-02 14:41:44

GekkoP
#! Junkie
From: Vicenza (Italy)
Registered: 2013-06-17
Posts: 297
Website

Re: Notifications don't fade very nicely

Ok, back to xfce4-notifyd cause it is more easy to configure.
Finally I got something better. It's just a workaround, but it's better than before.
This is my compton.conf:

# Shadow
shadow = false;
no-dnd-shadow = true;
no-dock-shadow = true;
#clear-shadow = true;
#shadow-radius = 7;
#shadow-offset-x = -7;
#shadow-offset-y = -7;
shadow-opacity = 0.4;
# shadow-red = 0.0;
# shadow-green = 0.0;
# shadow-blue = 0.0;
shadow-exclude = [ "n:e:xfce4-notifyd" ];
#shadow-ignore-shaped = false;

# Opacity
menu-opacity = 0.9;
#inactive-opacity = 0.9;
#frame-opacity = 0.7;
inactive-opacity-override = false;
alpha-step = 0.06;

# Fading
fading = true;
# fade-delta = 30;
fade-in-step = 0.03;
fade-out-step = 0.03;
no-fading-openclose = true;
fade-exclude = [ "n:e:xfce4-notifyd" ];

# Other
mark-wmwin-focused = true;
mark-ovredir-focused = true;
detect-rounded-corners = true;
detect-client-opacity = true;
#refresh-rate = 0;
#vsync = "none";
dbe = false;
paint-on-overlay = false;
sw-opti = false;

# Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = false; opacity = 0.85; };
};

Last edited by GekkoP (2013-08-02 14:56:21)

Offline

#11 2014-04-19 04:23:25

memeplex
New Member
Registered: 2014-04-19
Posts: 5

Re: Notifications don't fade very nicely

For gtk3 CSD stock dialogs:

I've extensively tested this and debugged openbox related code. The culprit is not compton nor openbox. The artifact takes place even without a compositor (but too fast, so you need to pause execution to appreciate it). The artifact also appears under pekwm, awesome and fluxbox, but the default light background makes it less noticeable that the black background openbox sets.

I guess gtk3 is the one to blame for clearing the window too quickly.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo