SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-03-20 13:45:45

Philippe1
Member
Registered: 2012-12-19
Posts: 37

[SOLVED] AssaultCube not launching anymore since upgrade

Using home directory: /home/philippe/.assaultcube_v1.1
current locale: fr_CA.UTF-8
init: sdl
init: net
init: world
init: video: sdl
init: video: mode
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  137 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x120000f
  Serial number of failed request:  35
  Current serial number in output stream:  35

Last edited by Philippe1 (2013-03-21 12:49:35)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-03-20 14:40:21

Barnabyh
#! Die Hard
From: Church of the Subgenius
Registered: 2012-11-07
Posts: 825
Website

Re: [SOLVED] AssaultCube not launching anymore since upgrade

From the output, it looks related to your nvidia driver (the NV-GLX). Did xorg update drivers or did you apply the recent kernel update? If you're using proprietary drivers you might have to recompile the kernel modules.

Let us know if that helped.  big_smile

Last edited by Barnabyh (2013-03-20 14:41:11)

Offline

#3 2013-03-20 15:30:56

Philippe1
Member
Registered: 2012-12-19
Posts: 37

Re: [SOLVED] AssaultCube not launching anymore since upgrade

Thanks for the quick response!

Yes, there has been an update with xorg video drivers.
I feel like a complete newbie, but how do you recompile a kernel? Is there an "easy" way?

Offline

#4 2013-03-20 17:44:59

Barnabyh
#! Die Hard
From: Church of the Subgenius
Registered: 2012-11-07
Posts: 825
Website

Re: [SOLVED] AssaultCube not launching anymore since upgrade

Last edited by Barnabyh (2013-03-20 17:49:30)

Offline

#5 2013-03-21 05:00:49

Philippe1
Member
Registered: 2012-12-19
Posts: 37

Re: [SOLVED] AssaultCube not launching anymore since upgrade

I followed your link and remembered, reading the thread, using smxi to install the video drivers a while ago.
So I used it again and skipped directly to the graphics part.
It Worked!!!

So if you ever play AssaultCube, lookout for General_MIDI...

Thanks again Barnabyh!

Offline

#6 2013-03-21 06:56:40

orionthehunter
#! Constellation
From: Japan
Registered: 2011-04-09
Posts: 967
Website

Re: [SOLVED] AssaultCube not launching anymore since upgrade

Offline

#7 2013-03-21 12:51:22

Philippe1
Member
Registered: 2012-12-19
Posts: 37

Re: [SOLVED] AssaultCube not launching anymore since upgrade

Of course!

I forgot, but it's true that I appreciate it when I browse through the forum and I see which problem is solved.

Offline

#8 2013-03-21 15:12:49

Barnabyh
#! Die Hard
From: Church of the Subgenius
Registered: 2012-11-07
Posts: 825
Website

Re: [SOLVED] AssaultCube not launching anymore since upgrade

Great stuff, pleased I could help! Have fun then, General_MIDI.

And yes, from time to time I play Assaultcube for a bit, every couple of years that is. I play under the same pseudonym.

Cheers~
Barnabyh

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo