SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-03-16 11:04:07

zalew
#! Junkie
From: Warsaw, .PL
Registered: 2012-03-28
Posts: 374

Openbox: switch workspace by moving mouse to edge of the screen - how?

there is this part in rc.xml

<screenEdgeWarpMouse>false</screenEdgeWarpMouse>
    <!-- Set this to TRUE to move the mouse pointer across the desktop when
switching due to hitting the edge of the screen -->

but changing it to true had no effect.

how to do it?
I'm on current Waldorf.

thanks

Offline

Be excellent to each other!

#2 2013-03-16 13:52:20

PackRat
#! Die Hard
From: USA
Registered: 2011-03-03
Posts: 1,572

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?


"It does not require many words to speak the truth." - Chief Joseph, Nez Perce tribe

Offline

#3 2013-03-16 19:22:30

zalew
#! Junkie
From: Warsaw, .PL
Registered: 2012-03-28
Posts: 374

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

ouch, that's too bad sad

arent' there any scripts to solve it, maybe using this xdotool?

Last edited by zalew (2013-03-16 19:23:48)

Offline

#4 2013-03-16 19:25:23

porkpiehat
#! Die Hard
Registered: 2012-10-02
Posts: 1,007

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

Offline

#5 2013-03-16 19:46:49

PackRat
#! Die Hard
From: USA
Registered: 2011-03-03
Posts: 1,572

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

The scroll wheel should be working by default.

I would suspect it could be scripted, but I couldn't find that solution when I searched.


"It does not require many words to speak the truth." - Chief Joseph, Nez Perce tribe

Offline

#6 2013-03-16 19:48:39

porkpiehat
#! Die Hard
Registered: 2012-10-02
Posts: 1,007

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

Last edited by porkpiehat (2013-03-16 19:52:37)

Offline

#7 2013-03-16 20:02:12

zalew
#! Junkie
From: Warsaw, .PL
Registered: 2012-03-28
Posts: 374

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

zalew ~
$ xdotool behave_screen_edge right set_desktop --relative --help
Usage: set_desktop desktop
--relative    - Move relative to the current desktop. Negative values OK
^C
zalew ~
$ xdotool behave_screen_edge right set_desktop --relative 1
^C
zalew ~
$ xdotool behave_screen_edge left set_desktop --relative -1
set_desktop: unrecognized option '-1'
Usage: set_desktop desktop
--relative    - Move relative to the current desktop. Negative values OK
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
Command failed.
^C

Offline

#8 2013-03-16 20:31:22

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

like this?

xdotool behave_screen_edge --delay 500 left set_desktop --relative -- -1 & xdotool behave_screen_edge --delay 500 right set_desktop --relative -- +1 &

otherwise; super+f1 and super+f2 is the way i jump (when not in mouse mode)

Last edited by brontosaurusrex (2013-03-16 20:33:53)

Offline

#9 2013-03-16 21:05:29

zalew
#! Junkie
From: Warsaw, .PL
Registered: 2012-03-28
Posts: 374

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

Last edited by zalew (2013-03-16 21:06:50)

Offline

#10 2013-03-16 21:16:00

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

Last edited by brontosaurusrex (2013-03-16 21:20:51)

Offline

#11 2013-03-16 21:24:03

zalew
#! Junkie
From: Warsaw, .PL
Registered: 2012-03-28
Posts: 374

Re: Openbox: switch workspace by moving mouse to edge of the screen - how?

when I reach the right border I should 'pass the wall' and be on the left side of the next screen, not the right one.

and now I noticed the 'delay' doesn't do what I thought it will. it doesn't wait on the edge for 500ms, I can barely touch it and after 500ms it switches me.

how can I disable those settings now?

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo