SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-02 12:49:42

schwim
#! Die Hard
From: Interweb's #1 Devotee
Registered: 2012-10-11
Posts: 1,031
Website

Working Netflix in #!

EDIT: I would like to suggest that you do not follow this how-to for Netflix in #! and instead, follow the handy and simple process that these guys have created.  The difference between the two methods in regards to performance and ease of use is night and day.  I will leave the topic intact for the sake of continuity but strongly urge you to use the link above to get your Netflix on.

Heya guys and gals!

With the assistance of bp, I have working Netflix in Crunchbang Waldorf 32 bit(I'll be trying 64 bit later today).  For purposes of condensation, Here's what you have to do, including BP's instructions, without which I never would have been able to do it.

Add the PPA repository:

sudo apt-add-repository ppa:ehoover/compholio

Change the .list file to redirect the request to latest Ubu version:

sudo geany /etc/apt/sources.list.d/ehoover-compholio-wheezy.list

Change the two lines to the following:

deb http://ppa.launchpad.net/ehoover/compholio/ubuntu quantal main
deb-src http://ppa.launchpad.net/ehoover/compholio/ubuntu quantal main

Save file.

Update:

sudo apt-get update

Install Netflix app:

sudo apt-get install netflix-desktop

The following steps are where it departs from the standard Ubu install.  Debian handles the MS license acceptance differently than Ubuntu, so we have to get the application to "see" that we accepted the license on the fonts.

Make sure you have the MS Truetype fonts installed:

sudo apt-get install ttf-mscorefonts-installer

Run the following command in terminal:

sudo echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | sudo debconf-set-selections

Run the Netflix app. On first run, it will handle the initial installation procedures(Firefox, Silverlight, Wine patches, etc.)

netflix-desktop

Enjoy!

Last edited by schwim (2014-03-07 23:21:33)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-01-02 15:24:17

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: Working Netflix in #!

I believe you left out one crucial step:  From where did you install apt-add-repository?  This is not in the Squeeze repos.

Offline

#3 2013-01-02 16:25:18

schwim
#! Die Hard
From: Interweb's #1 Devotee
Registered: 2012-10-11
Posts: 1,031
Website

Re: Working Netflix in #!

Hi there pvsage,

I've edited the post to reflect Waldorf. It was very early when I wrote it smile

If you can help me figure out how to add this for statler, I will test it and see if I can tailor instructs for it.

Offline

#4 2013-01-02 17:04:45

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: Working Netflix in #!

Sta(t)ler may be too sta(b)le to get it working with Netflix, at least using the Compholio Silverlight Wine hack. neutral  Considering Wheezy's release is just around the corner, I'm not sure there's much sense in pursuing that angle.  Glad you've got it working in Waldorf though; well done!

Offline

#5 2013-01-06 12:34:56

skybert
New Member
Registered: 2013-01-06
Posts: 1

Re: Working Netflix in #!

schwim wrote:

With the assistance of bp, I have working Netflix in Crunchbang Waldorf 32 bit(I'll be trying 64 bit later today).

Thanks to your post I got Netlfix up and running on my Debian Wheezy box. There were no 64 bit packages for quantal yesterday, so I had to use oneiric instead. Also, I had to run the post-install scripts manually since netflix-desktop assumes that you're using sudo (and I'm not). I've jotted down what I did here: http://www.skybert.net/debian/netflix-o … ezy-64bit/

Also thanks for an excellent forum, I've several times come by here and noticed a very positive and helpful atmosphere.

-Torstein

Offline

#6 2013-01-20 22:32:14

barkbombardier
#! Member
Registered: 2011-09-07
Posts: 77

Re: Working Netflix in #!

Do I need to have wine installed for this?

Offline

#7 2013-01-20 23:19:26

schwim
#! Die Hard
From: Interweb's #1 Devotee
Registered: 2012-10-11
Posts: 1,031
Website

Re: Working Netflix in #!

Hi there Bark,

The Netflix PPA includes a custom version of wine called wine-compholio.  This can coexist on a system with the standard version of wine.  You shouldn't have to do anything else than is listed in the how-to.

Offline

#8 2013-01-22 10:44:13

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

Re: Working Netflix in #!

Thanks schwim, got it working without a hitch on 64bit waldorf.

In case anyone wonders, the playback quality seems just as good as on windows or android.

Offline

#9 2013-01-23 02:08:17

schwim
#! Die Hard
From: Interweb's #1 Devotee
Registered: 2012-10-11
Posts: 1,031
Website

Re: Working Netflix in #!

Very glad to hear you're up and running Chris.  I've also found the performance to be comparable to my phone and Win install.

Offline

#10 2013-01-25 05:42:41

einfarben
New Member
Registered: 2012-07-28
Posts: 3

Re: Working Netflix in #!

Thank you so much for this guide. I had no idea how to get past the fonts issue, and now I have netflix up and running just fine
(32-bit Waldorf).
As with anything dealing with wine (in my experience) the mouse movement is finnicky as hell, but the playback is as good as my old windows partition could manage.


lenin: #! waldorf i686
shelly: arch x86_64
monster: Mac OS10.6.?

Offline

#11 2013-01-25 18:13:35

antiv0rtex
#! Die Hard
From: Earth
Registered: 2012-10-05
Posts: 574

Re: Working Netflix in #!

Evidently, the impossible has been achieved. Good work, schwim and bp! big_smile

Offline

#12 2013-01-31 19:55:12

horuden
New Member
From: Utah
Registered: 2012-07-01
Posts: 6
Website

Re: Working Netflix in #!

I had trouble with the

echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | debconf-set-selections

Every time I tried to run it it would hang when it ran debconf-set-selections.  I googled around a bit and found that you have run this instead, it worked perfectly for me after that:

sudo sh -c "echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | debconf-set-selections"

Thank you for the awesome tip!! I am so happy to have netflix on my new laptop big_smile

Offline

#13 2013-02-01 04:02:31

ming482
New Member
Registered: 2013-02-01
Posts: 1

Re: Working Netflix in #!

I'm having trouble installing netflix-desktop.

When I run apt-get for it I get :

sudo apt-get install netflix-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 netflix-desktop : Depends: wine-browser-installer but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then I tried explicitly installing wine-browser-installer and got:

sudo apt-get install wine-browser-installer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-browser-installer : Depends: wine-compholio (>= 1.5.19~quantal1) but it is not installable
E: Unable to correct problems, you have held broken packages.

Any ideas? 

Thanks in advance.

Offline

#14 2013-02-01 16:51:13

jasonwert
Member
From: Traverse City, Michigan
Registered: 2008-12-18
Posts: 46
Website

Re: Working Netflix in #!

I'm seeing the same issues as ming482. I'm using Waldorf 64bit


Give A Monkey A Brain and He'll Swear He's the Center of the Universe

Offline

#15 2013-02-16 05:47:47

JLloyd13
#! Member
Registered: 2012-08-08
Posts: 83

Re: Working Netflix in #!

same issues as above here. my system isn't install virtual packages. may make a different thread about virtual packages

Offline

#16 2013-02-16 06:00:42

JLloyd13
#! Member
Registered: 2012-08-08
Posts: 83

Re: Working Netflix in #!

may have found a work around. using dpkg to add i386 as an arch, so far wine-compholio (and about 150 i386 libs packages) are installing. after that will try for netflix-desktop. wish me luck! also, for some reason aptitude won't install wine-compholio, only apt-get

EDIT--

just to let you guys know, now enjoying netflix on my computer. and sorry for bumping a dying thread.

Last edited by JLloyd13 (2013-02-16 06:07:13)

Offline

#17 2013-02-16 14:11:29

gatohaus
New Member
From: DC, USA
Registered: 2010-09-02
Posts: 6

Re: Working Netflix in #!

@JLLoyd  -- I think there were a fair number of us 64bitters that hit a dead end with this..   Thanks for finding a work around!


#! Statler..  it's the Debian tastiness that I finally couldn't resist.

Offline

#18 2013-02-16 20:44:10

JLloyd13
#! Member
Registered: 2012-08-08
Posts: 83

Re: Working Netflix in #!

no problem. I was stuck on this for some time myself. for those wondering how exactly to add an arch to dpkg just type this in a terminal

su -c 'dpkg --add-architecture i386'

multi arch is probably something good to have anyway, although be mindful that it will download a lot of 32-bit libs on first run (if you want to fetch these libs for a different reason the ia32-libs package should pull most needed ones in) 

also farther above in this thread there was someone who said he used the oneiric repos because 64-bit wasn't in the latest ones, that could also work for some people although it didn't for me (I still had to enable i386)

Last edited by JLloyd13 (2013-02-16 20:44:44)

Offline

#19 2013-02-19 04:00:41

cism
Member
From: Seattle
Registered: 2013-02-14
Posts: 18

Re: Working Netflix in #!

After including the proper repositories/modifying my sources list, attempts to install netflix-desktop and such meet with:

The following packages have unmet dependencies:
netflix-desktop : Depends: wine-browser-installer but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So, tried Lloyd's dpkg idea, but my attempts at using 'su -c' are met with authentication failure (noob-error, I'm sure). I suppose I'd assumed that my sudo password would function for this as well...


-[cism]

Offline

#20 2013-02-19 16:21:23

cwwgateway
Member
Registered: 2012-12-03
Posts: 16

Re: Working Netflix in #!

"su -c" requires the root password, whereas "sudo" uses the user's password. If you prefer sudo, you can run

sudo dpkg --add-architecture i386

And this works the same way as any other sudo command. To make sure it worked, run

sudo dpkg --print-foreign-architectures

The output should be "i386"

Edit:
I forgot to say that this worked fine for me on my 64-bit Sid install with multiarch enabled. This along with getting steam working means I can get rid of my Ubuntu install.

Last edited by cwwgateway (2013-02-19 16:22:58)

Offline

#21 2013-02-22 20:32:48

JLloyd13
#! Member
Registered: 2012-08-08
Posts: 83

Re: Working Netflix in #!

^ I just used su because a lot of debian based distros don't come with sudo installed/configured by default, where as su is always there. If using su will you need the root password, and not your user one. sorry I didn't catch that, my user/root password are the same so I don't even notice  tongue

Last edited by JLloyd13 (2013-02-22 20:33:29)

Offline

#22 2013-02-28 14:21:14

g33zr
#! Die Hard
From: Never Never Land
Registered: 2013-02-19
Posts: 635

Re: Working Netflix in #!

The workround to access Netflix was more work than with Ubuntu-based distros, but it works just as well as with another distro, such as Mint. Who needs Windows or Mac OS X?!  ]:D


It's never too late to learn something new! wink

OHCG | LXer

Offline

#23 2013-03-02 19:14:18

mosesgunn
#! CrunchBanger
Registered: 2012-10-20
Posts: 133

Re: Working Netflix in #!

I have installed i386 architecture, but I am still getting this error.  I am running Walforf 64.  I have done everything, added the repo, updated, etc.  What's up?

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 netflix-desktop : Depends: wine-browser-installer but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Oh, I'm also getting a gpg signing error for the compholio ppa.  What's up?

Last edited by mosesgunn (2013-03-02 19:23:18)

Offline

#24 2013-03-05 01:34:05

mosesgunn
#! CrunchBanger
Registered: 2012-10-20
Posts: 133

Re: Working Netflix in #!

Anybody?

Offline

Help fund CrunchBang, donate to the project!

#25 2013-03-26 23:37:49

shawn789
New Member
Registered: 2013-03-25
Posts: 1

Re: Working Netflix in #!

@mosesgunn

I was having the same issue. I think that after you do the 'dpkg --add-architecture i386', you have to go into /etc/apt/sources and add "[arch=amd64,i386]" between 'deb' and the source url on each line that says 'deb <url> waldorf main'.

I also added the line:

deb http://http.us.debian.org/debian wheezy main

at the bottom and that seemed to have done the trick. I'm not sure which of these did the trick but doing them both worked for me.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo