SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-02-28 16:37:05

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Synaptic Pakage Manager disables xcompmgr.

I just noticed this a few day ago while MrPeachy was helping me work on my conky. I had to go to Synaptic to grab a couple debs (which turned out to be outdated). Anyway I opened Synaps, entered password and my screen flashed, disabling xcomp.

I opened Synaps several times after to narrow the issue down.
Opening synaptic in terminal does not disable xcomp.

It reminds me of what happens when you restart x.

EDIT:
I'm using latest image with 3.2 bpo kernel.
Xcomp is enabled in autostart.
I am not using a priprietary driver.
I'm using openbox.

Last edited by falldown (2012-02-29 17:47:18)

Offline

Help fund CrunchBang, donate to the project!

#2 2012-02-28 18:39:35

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Re: Synaptic Pakage Manager disables xcompmgr.

I guess my first assumption was correct. It is indeed synaptic package manager.
When opening a file as root (with right click menu) the same Root privilege password screen opens, but doesn't cause the screen to flicker or disable xcomp.

I really don't know how long this issue has been going on. I hardly ever use Synaptic so the problem isn't a huge issue, but this might help others who do use it.

Last edited by falldown (2012-02-28 18:49:14)

Offline

#3 2012-02-28 18:52:15

2ManyDogs
dv#!
From: elsewhere
Registered: 2011-11-22
Posts: 1,346

Re: Synaptic Pakage Manager disables xcompmgr.

(bunch of useless stuff deleted)

Last edited by 2ManyDogs (2012-02-28 18:54:23)


Be eggsalad to each other.

Offline

#4 2012-02-28 18:56:55

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Re: Synaptic Pakage Manager disables xcompmgr.

No No.. re-post 2ManyDogs!!  your POST was VERY useful and on the right path!!!!

gksudo synaptic

disabled xcomp.

( big_smile yea I use apt-get for everything)

Last edited by falldown (2012-02-28 20:56:39)

Offline

#5 2012-02-28 19:52:53

2ManyDogs
dv#!
From: elsewhere
Registered: 2011-11-22
Posts: 1,346

Re: Synaptic Pakage Manager disables xcompmgr.

Well, I don't know how helpful I can be, since I had to go to wikipedia and the Arch wiki to even see what xcompmgr did...

But if "gksudo synaptic" disables xcomp, does any other "gksudo" call? Like "gksudo geany" for example?

What if you just use "sudo synaptic" from a terminal? What if you use "gksu" instead of "gksudo"?

You might find something useful in the Arch wiki (here).

Last edited by 2ManyDogs (2012-02-28 19:53:21)


Be eggsalad to each other.

Offline

#6 2012-02-28 21:15:25

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Re: Synaptic Pakage Manager disables xcompmgr.

2ManyDogs wrote:

Well, I don't know how helpful I can be, since I had to go to wikipedia and the Arch wiki to even see what xcompmgr did...

I'm just too vague sometimes. My apologies. smile

2ManyDogs wrote:

But if "gksudo synaptic" disables xcomp, does any other "gksudo" call? Like "gksudo geany" for example?

What if you just use "sudo synaptic" from a terminal? What if you use "gksu" instead of "gksudo"?

sudo synaptic doesn't bring up the graphical interface.. so that works fine.
Ok so every other app that I gksudo'ed did nothing to xcomp.
Which led me to try this.
On a fresh reboot I gksudo synaptic.. (which disables xcomp)
then I close out synaptic.. and enable xcomp
Then I gksudo synaptic again after (I manually enabled xcomp)
xcomp stays on..
so now I think it has something to do with xcomp and autostart.

Offline

#7 2012-02-28 23:20:43

2ManyDogs
dv#!
From: elsewhere
Registered: 2011-11-22
Posts: 1,346

Re: Synaptic Pakage Manager disables xcompmgr.

Weird. That is consistent with my tests, though -- I started xcompmgr from the command line (not in autostart) and could not kill it no matter what I did after that. Maybe it has something to do with exactly where you start xcomp in the autostart file, or how long you wait before or after... I know some apps want that "sleep 2s" before or after.

(edit) -- I tried running it from autostart, and no matter where I put the "xcompmgr &" in autostart, it starts fine and can't be killed no matter what else I run, even "gksudo synaptic" -- so I'm afraid I don't know what's going on.

Last edited by 2ManyDogs (2012-02-28 23:36:18)


Be eggsalad to each other.

Offline

#8 2012-02-28 23:48:40

2ManyDogs
dv#!
From: elsewhere
Registered: 2011-11-22
Posts: 1,346

Re: Synaptic Pakage Manager disables xcompmgr.

Hey! I found this thread -- looks like it may be a bug in xcompmgr...

Don't know why I can't duplicate it. What version of xcompmgr do you have?

Last edited by 2ManyDogs (2012-02-29 00:01:15)


Be eggsalad to each other.

Offline

#9 2012-02-29 01:44:08

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Re: Synaptic Pakage Manager disables xcompmgr.

2ManyDogs Thank you for your help on this. I'm running version 1.1.3. I'm checking the link now.
xcomp is no longer being developed from what I read on another forum.

Well that settles it.. I will just use cairo-compmgr for my compositing needs.   

Thank you for your help!

Last edited by falldown (2012-02-29 02:01:18)

Offline

#10 2012-02-29 02:03:53

2ManyDogs
dv#!
From: elsewhere
Registered: 2011-11-22
Posts: 1,346

Re: Synaptic Pakage Manager disables xcompmgr.

Looks like the current version in the stable repo is 1.1.5-1 (and this is the version I was testing with). Not sure if that would make any difference, but you might apt-get update...

(and you're welcome smile)

Last edited by 2ManyDogs (2012-02-29 02:05:17)


Be eggsalad to each other.

Offline

#11 2012-02-29 02:32:53

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Re: Synaptic Pakage Manager disables xcompmgr.

The bash script posted in this thread does not solve the issue.

Last edited by falldown (2012-02-29 15:12:34)

Offline

#12 2012-02-29 03:33:05

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Synaptic Pakage Manager disables xcompmgr.

falldown wrote:

I guess there are 2 options here.

1. Use the bash script posted in this thread (as 2ManyDogs mentioned)
or
2. Use another composite manager.

I will mark this as solved.

I used that bash script --- called it up from autostart just like it says ... after a few weeks of the thing blinking off and on I got soooooo annoyed I commented it out and now I'm back to:

I don't use a composite manager!


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#13 2012-02-29 15:09:06

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Re: Synaptic Pakage Manager disables xcompmgr.

Sector11 wrote:

I used that bash script --- called it up from autostart just like it says ... after a few weeks of the thing blinking off and on I got soooooo annoyed I commented it out and now I'm back to:

I don't use a composite manager!

Thank you S11.. I didn't try the script after I read that xcompmgr was no longer being developed.
I switched on cairo-compmgr. (which has been running smooth)

I'm curious as to why this "bug" is selective?

I will re-open this thread and see if anyone else chimes in. big_smile

Offline

#14 2012-02-29 15:19:31

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Synaptic Pakage Manager disables xcompmgr.

falldown wrote:
Sector11 wrote:

I used that bash script --- called it up from autostart just like it says ... after a few weeks of the thing blinking off and on I got soooooo annoyed I commented it out and now I'm back to:

I don't use a composite manager!

Thank you S11.. I didn't try the script after I read that xcompmgr was no longer being developed.
I switched on cairo-compmgr. (which has been running smooth)

I'm curious as to why this "bug" is selective?

I will re-open this thread and see if anyone else chimes in. big_smile

What that script does is turns on whenever it is turned off, so in that respect it works ... BUT the {blink-off}...{blink-on} was so annoying!

Also turn it off in the OB menu...{blink-on} AHHHHHHHHHH had to comment it out in autostart and log out.  big_smile


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#15 2012-02-29 15:27:54

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Re: Synaptic Pakage Manager disables xcompmgr.

Sector11 wrote:

Thank you S11.. I didn't try the script after I read that xcompmgr was no longer being developed.
I switched on cairo-compmgr. (which has been running smooth)

I'm curious as to why this "bug" is selective?

I will re-open this thread and see if anyone else chimes in. big_smile

What that script does is turns on whenever it is turned off, so in that respect it works ... BUT the {blink-off}...{blink-on} was so annoying!

Also turn it off in the OB menu...{blink-on} AHHHHHHHHHH had to comment it out in autostart and log out.  big_smile

Thats what my screen does when xcomp kicks off.. it blinks.
In my opinion it looks exactly like x-server is being reset.

Offline

#16 2012-02-29 16:22:13

falldown
#! Samurai
Registered: 2011-09-01
Posts: 1,727

Re: Synaptic Pakage Manager disables xcompmgr.

Ok so I did some more digging.

After a reboot (with xcomp in autostart)
I start synaptic with right-click menu/system
Screen flashes as the window that ask for root password pops up.
I click ok and screen flashes.. xcomp as well as conky restarts.

Looking at my .xsession-error log after this process
Shows me that
conky restarts
and tint2 restarts
Doesn't show an error for xcomp
nor does it say that x-server has restarted.


EDIT:

killall conky
killall -SIGUSR1 tint2

Neither code disables xcompmgr

Last edited by falldown (2012-02-29 16:40:56)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo