SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-01-05 23:24:04

celem
New Member
Registered: 2012-01-05
Posts: 1

Broadcom BCM4313 not detected

I booted live image of crashbang on my Asus Eee SeaShell e/w a Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller and it is not recognized. It IS recognized by the currently loaded OS - PeppermintOS (http://peppermintos.com/) based on Ubuntu. Appropriate output is pasted below:

OUTPUT OF uname -r
2.6.39-bpo.2-486
02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    Subsystem: AzureWave Device [1a3b:2047]
OUTPUT OF lsmod
Module                  Size  Used by
acpi_cpufreq           12704  1 
mperf                  12387  1 acpi_cpufreq
bridge                 55118  0 
cpufreq_userspace      12520  0 
cpufreq_stats          12550  0 
stp                    12368  1 bridge
cpufreq_powersave      12422  1 
bnep                   17147  2 
cpufreq_conservative    12987  0 
rfcomm                 31929  0 
bluetooth              88140  10 bnep,rfcomm
crc16                  12327  1 bluetooth
fuse                   51519  3 
joydev                 16869  0 
snd_hda_codec_realtek   207702  1 
snd_hda_intel          21529  1 
snd_hda_codec          57741  2 snd_hda_codec_realtek,snd_hda_intel
i915                  286502  2 
snd_hwdep              12906  1 snd_hda_codec
brcmsmac              494927  0 
snd_pcm                52675  2 snd_hda_intel,snd_hda_codec
snd_seq                39027  0 
mac80211              160214  1 brcmsmac
snd_timer              22133  2 snd_pcm,snd_seq
eeepc_wmi              12471  0 
drm_kms_helper         26550  1 i915
asus_wmi               18080  1 eeepc_wmi
snd_seq_device         12995  1 snd_seq
uvcvideo               52490  0 
drm                   133245  3 i915,drm_kms_helper
sparse_keymap          12680  1 asus_wmi
videodev               61226  1 uvcvideo
pci_hotplug            26303  1 asus_wmi
cfg80211              107034  2 brcmsmac,mac80211
i2c_algo_bit           12706  1 i915
snd                    38148  10 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
media                  13664  1 videodev
tpm_tis                12949  0 
psmouse                50618  0 
i2c_core               19022  5 i915,drm_kms_helper,drm,videodev,i2c_algo_bit
evdev                  13048  17 
tpm                    17476  1 tpm_tis
tpm_bios               12799  1 tpm
serio_raw              12758  0 
battery                12957  0 
pcspkr                 12515  0 
soundcore              12878  1 snd
ac                     12552  0 
rfkill                 18476  4 bluetooth,asus_wmi,cfg80211
wmi                    13018  1 asus_wmi
video                  17345  1 i915
processor              22676  2 acpi_cpufreq
power_supply           13283  2 battery,ac
button                 12783  1 i915
snd_page_alloc         12841  2 snd_hda_intel,snd_pcm
squashfs               30799  1 
loop                   17747  2 
aufs                  116137  1864 
nls_utf8               12416  2 
nls_cp437              12417  2 
vfat                   16989  2 
fat                    44149  1 vfat
ide_generic             8209  0 [permanent]
ide_core               65519  1 ide_generic
usb_storage            34951  2 
uas                    12975  0 
sd_mod                 35060  4 
crc_t10dif             12332  1 sd_mod
ahci                   20897  0 
libahci                22199  1 ahci
libata                132026  2 ahci,libahci
uhci_hcd               21850  0 
ehci_hcd               34829  0 
scsi_mod              134453  4 usb_storage,uas,sd_mod,libata
usbcore                99121  6 uvcvideo,usb_storage,uas,uhci_hcd,ehci_hcd
atl1c                  31155  0 
thermal                13058  0 
thermal_sys            17667  3 video,processor,thermal
OUTPUT OF iwconfig
OUTPUT OF sudo cat /etc/network/interfaces
auto lo
iface lo inet loopback

lo        no wireless extensions.

eth0      no wireless extensions.

pan0      no wireless extensions.

Offline

Help fund CrunchBang, donate to the project!

#2 2012-01-06 05:05:41

roccity1
New Member
Registered: 2009-03-26
Posts: 7

Re: Broadcom BCM4313 not detected

You may need to load proprietary drivers? can you try sudo modprobe wl? This is the broadcom-sta driver. If not see if you can install it with sudo apt-get install broadcom-wl and then modprobe wl. After this try sudo ifconfig -a.

Offline

#3 2012-01-06 05:18:22

roccity1
New Member
Registered: 2009-03-26
Posts: 7

Re: Broadcom BCM4313 not detected

sorry got a little excited answering. I have checked and tried to apt-get broadcom-wl and it appears that it is not found. i did find this on the debian wiki http://wiki.debian.org/wl#Squeeze. you will need some things like module-assistant and blacklist brcm80211. You can give it a try and see what happens.

Offline

#4 2012-01-06 08:08:58

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Broadcom BCM4313 not detected

Install #! and you can make it work with either b43 or wl module.
hth

Offline

#5 2012-05-12 01:17:23

uberbdon
#! CrunchBanger
Registered: 2009-09-13
Posts: 135

Re: Broadcom BCM4313 not detected

Sorry for bumping this old thread, but I'm having the same issue as the OP.

Offline

#6 2012-05-12 09:40:58

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Broadcom BCM4313 not detected

It seems it is not working with the live image.
You will have to install to HD to get it to work.

Offline

#7 2012-05-12 12:11:34

TitanMech
Banned
From: Blue Zone 3
Registered: 2011-08-28
Posts: 930

Re: Broadcom BCM4313 not detected

I got this to work on my netbook which is an Asus eee pc 1051x by typing this into a temrinal:

sudo apt-get install module-assistant wireless-tools firmware-brcm80211 

Reboot the machine, then once its rebooted check the wireless interface is being detected by typing into a terminal:

 iwconfig 

Offline

#8 2012-05-13 03:29:31

nuxero
#! Member
From: Somewhere
Registered: 2011-12-04
Posts: 60
Website

Re: Broadcom BCM4313 not detected

The needed package is firmware-brcm80211 so type in a terminal sudo apt-get install firmaware-brcm80211, reboot and magic happens big_smile

Offline

#9 2013-08-29 11:48:15

ltpitt
Member
Registered: 2013-08-29
Posts: 12

Re: Broadcom BCM4313 not detected

a) Hi to everyone I am a new (enthusiast) user big_smile

b) Thanks a lot for the suggestion: nuxero's package worked like a charm to enable wifi network using crunchbag on my asus 1215n big_smile

Offline

#10 2014-11-24 01:03:47

Geeman265
New Member
Registered: 2014-03-06
Posts: 2

Re: Broadcom BCM4313 not detected

As above just wanted to say this worked for me too. Awesome stuff guys!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo