SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-10-21 12:43:15

ackernan
#! Junkie
Registered: 2011-01-10
Posts: 403

(Solved) Update/pgp errors

I just did fresh install of Statler and I get pgp errors when I try to update with sudo apt-get update.

W: GPG error: http://packages.crunchbanglinux.org statler Release: The following signatures were invalid: BADSIG CBF7B2D9FC2682F1 Philip Newborough (aka corenominal) <mail@philipnewborough.co.uk>
W: GPG error: http://security.debian.org squeeze/updates Release: The following signatures were invalid: BADSIG AED4B06F473041FA Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>

How can I fix this?  CB-Welcome is not updating/installing correctly, I assume because of this.

Last edited by ackernan (2011-10-22 01:23:11)

Offline

Help fund CrunchBang, donate to the project!

#2 2011-10-21 12:58:52

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: (Solved) Update/pgp errors

sudo apt-get install crunchbang-keyring
sudo apt-get update

Offline

#3 2011-10-21 21:11:14

ackernan
#! Junkie
Registered: 2011-01-10
Posts: 403

Re: (Solved) Update/pgp errors

el_koraco wrote:
sudo apt-get install crunchbang-keyring
sudo apt-get update

crunchbang-keyring package is not available.

tony@crunchbang-test:~$ sudo apt-get install crunchbang-keyring
[sudo] password for tony: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package crunchbang-keyring
tony@crunchbang-test:~$ 

I tried adding the keys manually with no success, I still get a pgp error when I run sudo apt-get update.

tony@crunchbang-test:~$ gpg --keyserver subkeys.pgp.net --recv AED4B06F473041FA && gpg --export --armor AED4B06F473041FA | sudo apt-key add -
gpg: requesting key 473041FA from hkp server subkeys.pgp.net
gpg: key 473041FA: "Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
OK
tony@crunchbang-test:~$ gpg --keyserver subkeys.pgp.net --recv CBF7B2D9FC2682F1 && gpg --export --armor CBF7B2D9FC2682F1 | sudo apt-key add -
gpg: requesting key FC2682F1 from hkp server subkeys.pgp.net
gpg: key FC2682F1: "Philip Newborough (aka corenominal) <mail@philipnewborough.co.uk>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
OK

Last edited by ackernan (2011-10-21 21:46:05)

Offline

#4 2011-10-22 01:22:39

ackernan
#! Junkie
Registered: 2011-01-10
Posts: 403

Re: (Solved) Update/pgp errors

I don't know why it's working, but it is.  I used gedit to disable every repo, one at a time, between updates.  Then I enabled the repos, one at a time, doing apt-get update after each one.

Offline

#5 2011-10-22 01:23:50

ackernan
#! Junkie
Registered: 2011-01-10
Posts: 403

Re: (Solved) Update/pgp errors

unsuscribe

Offline

#6 2011-11-10 14:40:08

KapitaenM
Member
From: Massachusetts
Registered: 2010-06-15
Posts: 41

Re: (Solved) Update/pgp errors

After suffering this little inconvenience on my Sid installation, I found the solution was indeed to disable the repositories, then enable Squeeze, reload, enable CB, reload.

Pretty easy, but weird. Glad to have stumbled in here, just wanted to confirm the methodology tongue

Last edited by KapitaenM (2011-11-10 14:40:43)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo