SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-04-28 12:58:52

fhsm
#! Junkie
From: New Hampshire, USA
Registered: 2009-01-05
Posts: 445

Make Terminator use eLinks to open ctrl+click links

$ touch ~/bin/runelinks
$ gedit ~/bin/runelinks

Last edited by fhsm (2009-06-22 03:05:23)

Offline

Be excellent to each other!

#2 2011-07-07 17:09:05

txtmsg
Member
From: los angeles
Registered: 2010-08-30
Posts: 39

Re: Make Terminator use eLinks to open ctrl+click links

reviving this thread although i'm simply trying to make firefox my default rather than chromium.

$ sudo update-alternatives --display x-www-browser
x-www-browser - auto mode
  link currently points to /home/driscoll/bin/firefox/firefox
/home/driscoll/bin/firefox/firefox - priority 150
/usr/bin/chromium-browser - priority 40
Current 'best' version is '/home/driscoll/bin/firefox/firefox'.

as you can see above, firefox is my x-www-browser but when i right-click "open link" in terminator, the link opens in chromium.

is the problem here that firefox is located in my home dir? should i make a symlink somewhere else and point to it?

Offline

#3 2011-07-07 17:42:30

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: Make Terminator use eLinks to open ctrl+click links

Hi txtmsg,

if you are using XFCE, you could run

exo-preferred-applications

and check the Browser there.

What happens if you open

x-www-browser

and

xdg-open http://www.crunchbanglinux.org

from terminal?

Offline

#4 2011-07-07 18:48:35

txtmsg
Member
From: los angeles
Registered: 2010-08-30
Posts: 39

Re: Make Terminator use eLinks to open ctrl+click links

x-www-browser

Offline

#5 2011-07-07 19:02:00

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: Make Terminator use eLinks to open ctrl+click links

It creates links to  ~/.local/share/xfce4/helpers/
you find your custom-WebBrowser.desktop there
Probably you have lines there like

X-XFCE-CommandsWithParameter=/usr/bin/chromium-browser "%s"

X-XFCE-Commands=/usr/bin/chromium-browser "%s"

so you can change them to /usr/bin/firefox "s%"

Offline

#6 2011-07-08 16:18:41

txtmsg
Member
From: los angeles
Registered: 2010-08-30
Posts: 39

Re: Make Terminator use eLinks to open ctrl+click links

rebooted the machine this morning and the behavior has returned. now i am perplexed.

both of these commands open firefox:

$ xdg-open http://crunchbanglinux.org
$ x-www-browser

and this looks correct:

$ cat .local/share/xfce4/helpers/custom-WebBrowser.desktop
[Desktop Entry]
NoDisplay=true
Version=1.0
Encoding=UTF-8
Type=X-XFCE-Helper
X-XFCE-Category=WebBrowser
X-XFCE-CommandsWithParameter=~/bin/firefox/firefox "%s"
Icon=firefox
Name=firefox
X-XFCE-Commands=~/bin/firefox/firefox

yet "open link" in terminator still opens chromium!

Offline

#7 2011-07-08 20:37:55

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: Make Terminator use eLinks to open ctrl+click links

if you are using bash, you can append this line in .bashrc

export DE=xfce

Save it. Close terminator, open terminator. Terminator then calls bash, and this sets the right environment for the commands in bash. I guess smile

Last edited by machinebacon (2011-07-08 20:38:55)

Offline

#8 2011-07-08 21:05:55

txtmsg
Member
From: los angeles
Registered: 2010-08-30
Posts: 39

Re: Make Terminator use eLinks to open ctrl+click links

Offline

#9 2011-07-08 21:36:00

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: Make Terminator use eLinks to open ctrl+click links

xdg-settings set default-web-browser firefox

Offline

#10 2011-07-08 22:41:58

txtmsg
Member
From: los angeles
Registered: 2010-08-30
Posts: 39

Re: Make Terminator use eLinks to open ctrl+click links

$ env | grep DE
DE=xfce
DESKTOP_SESSION=wmii

$ xdg-settings get default-web-browser
firefox.desktop

Offline

#11 2011-07-08 22:47:40

txtmsg
Member
From: los angeles
Registered: 2010-08-30
Posts: 39

Re: Make Terminator use eLinks to open ctrl+click links

Also, dealing with the "alternatives" system, I created the following symlinks:

# ln -s /usr/bin/firefox /etc/alternatives/x-www-browser
# ln -s /usr/bin/firefox /etc/alternatives/gnome-www-browser

This didn't solve the problem either. o__O

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo