SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-09-17 14:39:49

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Graphical tearing

Hi,

Running BL Hydrogen RC1, I'm getting some very slight tearing when scrolling, and some much more noticeable tearing when playing videos (especially on YouTube) and when dragging windows. Occasionally opening new windows will result in the window appearing in a "wipe" motion from top to bottom.

Here is some hopefully relevant data:

thomas@hydroquark:~$ lspci

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)

compton.conf

# Shadow
shadow = true;
no-dnd-shadow = true;
no-dock-shadow = true;
#clear-shadow = true;
shadow-radius = 7;
shadow-offset-x = -7;
shadow-offset-y = -7;
shadow-opacity = 0.4;
# shadow-red = 0.0;
# shadow-green = 0.0;
# shadow-blue = 0.0;
#shadow-exclude = [ "n:e:xfce4-notifyd", "i:e:Conky" ];
shadow-exclude = [ "i:e:Conky" ];
#shadow-ignore-shaped = false;

# Opacity
menu-opacity = 0.9;
#inactive-opacity = 0.8;
frame-opacity = 0.7;
inactive-opacity-override = false;
alpha-step = 0.06;

# Fading
fading = false;
# fade-delta = 30;
fade-in-step = 0.03;
fade-out-step = 0.03;
# no-fading-openclose = true;

# Other
mark-wmwin-focused = true;
mark-ovredir-focused = true;
detect-rounded-corners = true;
detect-client-opacity = true;
#refresh-rate = 0;
#vsync = "none";
dbe = false;
paint-on-overlay = false;
sw-opti = false;

# Window type settings
#wintypes:
#{
#  tooltip = { fade = true; shadow = false; opacity = 0.85; };
#};

Is there a way to fix this? I've tried the steps suggested in this forum post, but they seem to make things, if anything, worse...


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

Be excellent to each other!

#2 2015-09-17 14:54:56

twoion
Emerald Caffeine
From: 星界
Registered: 2012-05-11
Posts: 1,648

Re: Graphical tearing

That's one old Intel graphics card.

Due to the insuffiencies of Linux graphics drivers it's impossible to find a non-tearing setting for all sorts of hardware/software.

You might want to have a look at the vsync option.

I am using a Intel HD4400 and have butter-soft scrolling in Firefox (not much scrolling going on anywhere else) with these settings:

backend = "glx";
vsync = "opengl-swc";
glx-no-stencil = true;
glx-no-rebind-pixmap = true;

Do not forget to remove/comment out

dbe = false;
paint-on-overlay = false;
sw-opti = false;

I have low rendering speeds and tearing in OpenGL-painted video though (not in the browser, by mpv and its opengl output) and extremely low performance on OpenGL games though, so I always disable compositing for that.


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#3 2015-09-17 15:20:26

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Re: Graphical tearing

Those settings resulted in most parts of the screen refusing to update when clicked on, and most windows would appear blank, just the titlebar and an empty grey rectangle. It seems my laptop doesn't like them very much!


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

#4 2015-09-17 15:28:44

twoion
Emerald Caffeine
From: 星界
Registered: 2012-05-11
Posts: 1,648

Re: Graphical tearing

^ It's the old Intel card…

Then you need to find a working configuration manually. Run compton --help, it'll output a list of all supported options. Try different backends, and backend-specific options. GLX is usually the best performing option, though also the most featureful/option-rich/buggy one.

I'm out of comments here.


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#5 2015-09-17 15:30:57

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Re: Graphical tearing

Thank you very much for your help smile

I'll try compton --help and see what I can do.


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

#6 2015-09-17 20:08:19

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: Graphical tearing

not sure if this is obvious, but have you tried disabling compositing completely?
it does eat precious cpu/gpu cycles, even if compton's supposed to be lightweight.

Offline

#7 2015-09-17 20:57:54

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Re: Graphical tearing

Yes, I have. It doesn't seem to make a difference, though  8.(


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo