SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-08-15 02:46:45

sexynsmartjenny
#! CrunchBanger
From: New York City
Registered: 2011-12-02
Posts: 138

Still having problem with East Asian languages

I cannot see East Asian languages in libreoffice, or any other text document program on my waldorf OS, even though I have ibus installed and I am able to type East Asian language.  I tried to set the settings for libreoffice to allow East Asian language, but to no avail.  Similarly, for other programs like abiword, wordpad, etc. 

Any suggestions?

Offline

Be excellent to each other!

#2 2015-08-15 03:15:55

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: Still having problem with East Asian languages

jenny, you can type East Asian languages - so you can see the results of your typing?


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
#! forum moderator    BunsenLabs

Offline

#3 2015-08-15 15:29:43

sexynsmartjenny
#! CrunchBanger
From: New York City
Registered: 2011-12-02
Posts: 138

Re: Still having problem with East Asian languages

no, I can't, it's all boxes.

OK, when I type east asian language into my wordpad, yes, I can see the characters, but then after I save the file and re-open it, it all become either boxes or some weird alien codes.

Last edited by sexynsmartjenny (2015-08-15 15:32:05)

Offline

#4 2015-08-15 16:54:13

twoion
Moderator
Registered: 2012-05-11
Posts: 1,648

Re: Still having problem with East Asian languages

What's your locale? Type 'locale' in a terminal and post the output. Have you fonts with CJK-Supported installed (depending on the language, different fonts might be necessary)?


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#5 2015-08-15 17:07:47

hhh
Cityspeak
Registered: 2010-08-04
Posts: 3,253

Re: Still having problem with East Asian languages

It's a large package, but a quicky workaround might be to install ttf-unifont...
https://packages.debian.org/stable/fonts/ttf-unifont

That should make LibreOffice usable while you troubleshoot this.


bunsenlabs     8)     forum mod squad

Offline

#6 2015-08-16 12:18:10

sexynsmartjenny
#! CrunchBanger
From: New York City
Registered: 2011-12-02
Posts: 138

Re: Still having problem with East Asian languages

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

This is my locale.

And in regard to CJK supported, do you have any package in mind?

Also I installed ttf-unifont and it's still all boxes in libreoffice, wordpad, etc.

Last edited by sexynsmartjenny (2015-08-16 12:37:00)

Offline

#7 2015-08-16 14:53:48

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: Still having problem with East Asian languages

I have fixed all Asian, Indian and many other Eastern languages by installing these fonts

Tested on Wikipedia that display completely all characters of any languages listened there. Also my desktop listen every character. Tested also on google translator.


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#8 2015-08-17 23:33:38

sexynsmartjenny
#! CrunchBanger
From: New York City
Registered: 2011-12-02
Posts: 138

Re: Still having problem with East Asian languages

Nili wrote:

I have fixed all Asian, Indian and many other Eastern languages by installing these fonts

Tested on Wikipedia that display completely all characters of any languages listened there. Also my desktop listen every character. Tested also on google translator.

So Ok, I did as what the previous poster said, and while indeed I am now able to see and type and use east asian language in libre office, the east asian language display on my browser has now changed into a font type that I do not like at all, and I tried to fix it using chrome's setting but there is no options available for east asian language and changing the western ones doesn't seem to effect east asian ones, so any suggestions on solving that.

But other than that, yes!  this issue is now resolved.  Thanks alot!!!  Really appreciated.  You guys are awesome!  And if you can help me with that browser issue so that I change my font on my display as well that would be even super-er!  smile

Offline

#9 2015-08-18 12:34:26

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: Still having problem with East Asian languages

I use Iceweasel backported.
With those fonts installed on my system everything seems apparent on the basis of language and alphabetic characters also on browser.

Haven't tested on Chrome sorry, please can you make a screenshots regarding the issue that you still have? just to see something concrete.

Can you check with any other browser?
I am faithful to FF/Iceweasel smile, my locale is same as yours. This is my browser font settings
Xtqhf9d.png
Perhaps must be used like
Fallback Text Encoding: Default for Current Locale

Whether Chrome has such options, (I believe there should be).

Last edited by Nili (2015-08-18 15:40:08)


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#10 2015-08-18 15:49:23

sexynsmartjenny
#! CrunchBanger
From: New York City
Registered: 2011-12-02
Posts: 138

Re: Still having problem with East Asian languages

Hi, Nili, my issue is a bit come dire than just the problem with chrome.  All the East Asian languages on my display have changed to a different font-type.  Everything from Firefox, chrome, to folder names, have changed to a very small and somewhat illegal font type.  Is there a way to solve this issue?

Is there perhaps a way to alter tint2 to change the fonts into a different type?  Perhaps add a line for East Asian language or something like that?

Last edited by sexynsmartjenny (2015-08-18 15:55:51)

Offline

#11 2015-08-18 17:07:34

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: Still having problem with East Asian languages

Hi again,

It depends, for file manager/gtk theme i set Droid Sans 9 via LXappearance. This font is sticked to stay always as my default font, unless i change back on theme settings. So have a look on your theme settings for file manager font render

# DO NOT EDIT! This file will be overwritten by LXAppearance.
# Any customization should be done in ~/.gtkrc-2.0.mine instead.

include "/home/nili/.gtkrc-2.0.mine"
gtk-theme-name="Mist"
gtk-icon-theme-name="Flamini"
gtk-font-name="Droid Sans 9"
gtk-cursor-theme-name="pixelfun3"
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_SMALL_TOOLBAR
gtk-button-images=1
gtk-menu-images=0
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintslight"
gtk-xft-rgba="rgb"

did you saved your font config?
root...

 $ dpkg-reconfigure fontconfig-config

on the three prompt required, i have chosed on my system as follows:

1. Native
2. Automatic
3. No

then run

$ dpkg-reconfigure fontconfig

exit root...
then run

$ sudo fc-cache -f -v

maybe a reboot needed to ensure...

Also have a look fonts on #debian everything is better explained officially.

Regarding tint2, yes ofcourse you can use different type of font for every settings , ie: tray, clock, battery etc... i don't know for setting asian on tint2 panel sorry, never used asian font on this panel, have a look on tint2 thread or you may ask help for tint2 settings here

in my opinion, first fix your system fonts to do as you want then start to work/fix for tint2.

Kindly regards,
Nili

Last edited by Nili (2015-08-18 19:55:05)


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo