SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-06-18 02:38:02

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

BunsenLabs & Steam = ?

Hey, I was trying to set up steam on BunsenLabs tonight. It's not really so important that it work because I plan on trying out the steamOS beta in a few days. Anyway, I was wanting to help BL out by working on this problem. I installed the steam package and everything seemed to workout. When I tried to launch steam I got a couple of errors:

jack@SyCog:~$ steam
Running Steam on bunsenlabs 8.1 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

I googled this and realized it is a common issue with various distros. I'm not sure exactly what to do about it. Any suggestions?

Offline

Be excellent to each other!

#2 2015-06-18 04:13:38

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: BunsenLabs & Steam = ?

Did you follow the steps in the Steam on #! HowTo? (Note the graphics dependencies)


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#3 2015-06-18 05:54:41

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: BunsenLabs & Steam = ?

damo wrote:

Did you follow the steps in the Steam on #! HowTo? (Note the graphics dependencies)

This guide is for wheezy and should not be used for Debian jessie (or BunsenLabs).

@OP: Have you enabled MultiArch?

Follow this guide:
https://wiki.debian.org/Steam

Offline

#4 2015-06-18 16:31:27

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: BunsenLabs & Steam = ?

Head_on_a_Stick wrote:
damo wrote:

Did you follow the steps in the Steam on #! HowTo? (Note the graphics dependencies)

This guide is for wheezy and should not be used for Debian jessie (or BunsenLabs).

@OP: Have you enabled MultiArch?

Follow this guide:
https://wiki.debian.org/Steam

Here is what I did:

#usermod -a -G video,audio second_user
dpkg --add-architecture amd64
aptitude install libgl1-fglrx-glx:amd64
Then this popped up:
This system has a graphics card which is no longer handled by the Fglrx   │  
 │ driver (package fglrx-driver). You may wish to keep the package           │  
 │ installed - for instance to drive some other card - but the card with     │  
 │ the following chipset won't be usable:                                    │  
 │                                                                           │  
 │ 01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc.    │  
 │ [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250] [1002:9712]               │  
 │                                                                           │  
 │ The above card requires either the non-free legacy Fglrx driver (package  │  
 │ fglrx-legacy-driver) or the free Radeon driver (package                   │  
 │ xserver-xorg-video-radeon).                                               │  
 │                                                                           │  
 │ Before the Radeon driver can be used you must remove Fglrx configuration  │  
 │ from xorg.conf (and xorg.conf.d/).           

Now I'm getting this error:

Error: You are missing the following 32-bit libraries, and Steam may not run:
libatiuki.so.1

I'm guessing that means this old laptop just ain't going to let me play?

Offline

#5 2015-06-18 16:35:40

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: BunsenLabs & Steam = ?

Colossal_Crunch wrote:

Here is what I did:

#usermod -a -G video,audio second_user
dpkg --add-architecture amd64
aptitude install libgl1-fglrx-glx:amd64
Then this popped up:
This system has a graphics card which is no longer handled by the Fglrx   │  
 │ driver (package fglrx-driver). You may wish to keep the package           │  
 │ installed - for instance to drive some other card - but the card with     │  
 │ the following chipset won't be usable:                                    │  
 │                                                                           │  
 │ 01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc.    │  
 │ [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250] [1002:9712]               │  
 │                                                                           │  
 │ The above card requires either the non-free legacy Fglrx driver (package  │  
 │ fglrx-legacy-driver) or the free Radeon driver (package                   │  
 │ xserver-xorg-video-radeon).                                               │  
 │                                                                           │  
 │ Before the Radeon driver can be used you must remove Fglrx configuration  │  
 │ from xorg.conf (and xorg.conf.d/).           

That's not what the Debian wiki page I linked advises you to do...

Go back and *read* the page I linked and then follow the instructions.

Just so you know, I have Steam working just fine in BunsenLabs on my amd64 system.

Last edited by Head_on_a_Stick (2015-06-18 16:36:13)

Offline

#6 2015-06-18 17:26:08

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: BunsenLabs & Steam = ?

Okay, I'm about to ask a really dumb question. Why would I install i386 if I have amd64? I went back and reinstalled everything the way it told me to and I think I broke it.

jack@SyCog:~$ steam
Running Steam on bunsenlabs 8.1 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1433441724)

# But it's just stuck here.... Nothing is happening...

Offline

#7 2015-06-18 17:35:15

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: BunsenLabs & Steam = ?

Colossal_Crunch wrote:

Why would I install i386 if I have amd64?

Because Steam uses a 32-bit architecture and libraries.

I don't know why you have that error.

Un-install everything you installed wrongly and try again.

Did you run that script damo's post linked you to?

When you have problems, post all the things you have done -- just saying you did "everything the way it told me to" is not at all helpful.

Read this:
http://www.catb.org/esr/faqs/smart-questions.html

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo