SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-06-10 15:34:56

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Tint2 does not appear after a reboot

Everytime I reboot my tint2 doesn't appear. I have to open the menu and manually turn it on. This started right after I updated my bunsenlab repo. I'm not sure if that has anything to do with it or not, but that is the only change I can think of that would of caused something like this to happen. Sorry if this question has already been addressed somewhere else.

Last edited by Colossal_Crunch (2015-06-10 15:35:56)

Offline

Help fund CrunchBang, donate to the project!

#2 2015-06-10 16:33:24

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: Tint2 does not appear after a reboot

Offline

#3 2015-06-10 17:51:51

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: Tint2 does not appear after a reboot

@CC: Use the "Report" button on your post and ask a mod to move it into it's own thread.

This thread was started by @ov specifically for feedback for his development version of tint2

Offline

#4 2015-06-10 23:31:46

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: Tint2 does not appear after a reboot

^ Good one, Hoas!  wink

Offline

#5 2015-06-11 05:52:06

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: Tint2 does not appear after a reboot

Offline

#6 2015-06-11 11:28:39

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Tint2 does not appear after a reboot

having a  bit of  technical  difficulty  this  manana...

jack@SyCog:~$ sudo cat ~/.config/openbox/autostart | pastebinit
Bad API request, invalid api_dev_key
jack@SyCog:~$ 

Offline

#7 2015-06-11 12:01:36

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: Tint2 does not appear after a reboot

jack@SyCog:~$ sudo cat ~/.config/openbox/autostart | pastebinit
Bad API request, invalid api_dev_key
jack@SyCog:~$ 

Offline

#8 2015-06-14 17:39:05

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Tint2 does not appear after a reboot

Sorry it took me so long to get back on here.

## Openbox autostart
## ====================
## When you login to your BunsenLabs Openbox session, this autostart script
## will be executed to set-up your environment and launch any applications
## you want to run at startup.
##
## Note*: some programs, such as 'nm-applet' are run via XDG autostart.
## Run
## /usr/lib/i386-linux-gnu/openbox-xdg-autostart --list
## or
## /usr/lib/x86_64-linux-gnu/openbox-xdg-autostart --list
## to list any XDG autostarted programs.
##
## More information about this can be found at:
## http://openbox.org/wiki/Help:Autostart
##
## If you do something cool with your autostart script and you think others
## could benefit from your hack, please consider sharing it at:
## http://bunsenlabs.org
##

## GNOME PolicyKit and Keyring
eval $(gnome-keyring-daemon -s --components=pkcs11,secrets,ssh,gpg) &

## for authentication
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &

## Set root window colour
hsetroot -solid "#2E3436" &

nitrogen --restore &

bl-compositor --start &

#(sleep 2; tint2) &
## To start a saved tint2 session,  comment out the line above, and uncomment:
(sleep 2s && bl-tint2-session --autostart) &

## Run the conky
#conky -q &
## To start a saved Conky session, comment out the line above, and uncomment:
(sleep 2s && bl-conky-session --autostart) &

## Volume control for systray
(sleep 2; volti) &

## Volume keys daemon
xfce4-volumed &

## Start Clipboard manager
(sleep 3; clipit) &

## Start Thunar Daemon
thunar --daemon &

## Enable power management
xfce4-power-manager &

## Start xscreensaver
xscreensaver -no-splash &

## Detect and configure touchpad. See 'man synclient' for more info.
if egrep -iq 'touchpad' /proc/bus/input/devices; then
    synclient VertEdgeScroll=1 &
    synclient TapButton1=1 &
fi

## Set keyboard settings - 250 ms delay and 25 cps (characters per second) repeat rate.
## Adjust the values according to your preferances.
xset r rate 250 25 &

## Turn on/off system beep
xset b off &

## The following command runs hacks and fixes for #! LiveCD sessions.
## Safe to delete after installation.
#bl-cowpowers &

## bl-welcome - post-installation script, will not run in a live session and
## only runs once. Safe to remove.
(sleep 10; bl-welcome --firstrun) &

## bl-fortune - have the system come up with a little adage (not yet enabled)
#(sleep 120; bl-fortune) &

Offline

#9 2015-06-14 17:42:13

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Tint2 does not appear after a reboot

I still have to manually turn it on every time I reboot. Just to recap the problem.

Offline

#10 2015-06-14 18:01:54

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: Tint2 does not appear after a reboot

sudo find / -name bl-tint2-session

Offline

#11 2015-06-14 18:20:23

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Tint2 does not appear after a reboot

(sleep 2; tint2) &
## To start a saved tint2 session,  comment out the line above, and uncomment:
#(sleep 2s && bl-tint2-session --autostart) &

Offline

#12 2015-06-14 18:37:11

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: Tint2 does not appear after a reboot

Offline

#13 2015-06-14 18:44:28

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Tint2 does not appear after a reboot

grep tint /var/log/Xorg.0.log

Offline

#14 2015-06-14 18:59:04

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: Tint2 does not appear after a reboot

Run the autostart command in a terminal, see what errors show up

bl-tint2session --autostart

(NB The most recent version no longer uses the --autostart option)

Offline

#15 2015-06-14 18:59:38

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: Tint2 does not appear after a reboot

killall tint2
bl-tint2-session --autostart

Last edited by Head_on_a_Stick (2015-06-14 19:00:08)

Offline

#16 2015-06-14 22:58:30

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Tint2 does not appear after a reboot

killall tint2
bl-tint2-session --autostart

Offline

#17 2015-06-14 23:21:06

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: Tint2 does not appear after a reboot

Offline

#18 2015-06-15 13:05:05

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Tint2 does not appear after a reboot

sudo apt-get update
sudo apt-get upgrade
cd ~/bunsen-netinstall-master
./upgrade-bunsen-pkgs -u

Last edited by Colossal_Crunch (2015-06-15 13:05:21)

Offline

#19 2015-06-15 14:01:56

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: Tint2 does not appear after a reboot

Offline

#20 2015-06-26 06:18:21

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: Tint2 does not appear after a reboot

If you haven't got any special personal modifications in your config files (it's just a test system after all) you can set everything to the current defaults in /usr/share/bunsen/skel by removing ~/.config/bunsen/bl-setup and logging out and in again.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo