SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-06-02 02:23:24

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

[SOLVED] Netinstall: geany plugin failure and install log empty

damo wrote:

You don't need to use github - unless you want to read the README for instructions on how to install BL of course wink

from the README wrote:

HOW TO USE

Boot into your Debian Netinstall cli system,
log in and run these commands, as a normal user:
(A fresh copy of this bunsen-netinstall package will be downloaded.)

wget https://github.com/bunsenlabs/bunsen-ne … ter.tar.gz
tar -xpf master.tar.gz
cd bunsen-netinstall-master
./install

The installation process will start.
Follow any prompts that appear on the screen.

There is also a script: upgrade-bunsen-packages
which can be run to upgrade the BunsenLabs packages
without having to reinstall the system.

I just spent a couple of hours or so attempting to install under VMware Player 7.1.0.  There was an issue installing one of the geany plugins and then I believe the bunsen configure script failed.  There's nothing in the install.log under the bunsen install directory (I forget the exact name), and I'm now unable to access the internet at all in the VM.

My apologies...I probably should have posted this in a different forum.

OK moved. (johnraff)

Last edited by KrunchTime (2015-06-04 06:35:00)


Linux User #586672
Come and Die -- Kyle Idleman

Offline

Be excellent to each other!

#2 2015-06-02 05:34:01

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

Krunchtime - first, the install log is in ~/.bunsen-netinstall-logs.
The original install directory only contains empty folder templates. ( I think I should rewrite that part of the script to create the directories and logfiles rather than copy them. It might cause less confusion. )

Is there anything helpful in ~/.bunsen-netinstall-logs/install.log?


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
#! forum moderator    BunsenLabs

Offline

#3 2015-06-02 23:59:04

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

@johnraff:  First, thank you for moving my post.  Second, thank you for pointing out the correct directory.  I might never have found it because I'm currently limited to traversing my filesystem via the command line since I have no internet connection in the BL Hydrogen VM.

Now, here's the first error I encountered (info from install.log):

Err [url]http://httpredir.debian.org/[/url] jessie/main geany-plugin-gendoc amd64 1.24+dfsg-5  Error reading from server. Remote end closed connection [IP: 128.31.0.66 80] 

.  Just for info, I was performing the BL install using my VPN service.

Second error encountered:

E: Failed to fetch [url]http://httpredir.debian.org/debian/pool/main/g/geany-pluginsver[/url]. Remote end closed connection [IP: 128.31.0.66 80]

E: Unable tofetch some archives, maybe run apt-get update or try with --fix-missing?
######## WARNING ########
'apt-get -o APT::Install-Recommends=true --quiet install' returned an error

I opted to ignore the errors and continue.

Third error encountered:

dpkg-deb: building package 'bunsen-welcome-build-deps' in '../bunsen-welcome-build-deps_0.07-1_all.deb'.

The package has been created.
Attention, the package has been created in the current directory, not in ".." as indicated by the message above!

This error occurred a number of other times later during the install process.  I'm thinking this error isn't an issue, so I'm not repeating.

Fourth error encountered...looks like script was creating debian/rules build...number of lines beginning with dh_:

dpkg-gencontrol: warning: File::FcntlLock not available; using flock which is not NFS-safe

This error occurred a number of other times later during the install process.

Fifth error encountered:

1 not fully installed or removed.

after the installation of config-package-dev.

Sixth error encountered:

Errors were encountered while processing:
bunsen-configs
E: Sub-process /usr/bin/dpkg returned an error code (1)
######## WARNING ########
apt-get returned an error installing bunsen packages

There was a problem installing the local .deb files.

I chose to continue at this point.

Installation completed, but when I boot into my BL VM, there is no tint2 panel and the openbox menu is generic.  I'm assuming there should be a tint2 panel and more fully populated openbox menu.  sudo aptitude update shows errors about repo addresses not being able to be resolved.  I'm assuming this means that there is no network connectivity under BL.

Last edited by KrunchTime (2015-06-03 10:32:38)


Linux User #586672
Come and Die -- Kyle Idleman

Offline

#4 2015-06-03 02:57:24

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

OK thanks for this. Most of the error messages can be ignored:

KrunchTime wrote:

the first error I encountered (info from install.log): Err http://httpredir.debian.org/ jessie/main geany-plugin-gendoc amd64 1.24+dfsg-5  Error reading from server. Remote end closed connection [IP: 128.31.0.66 80] .  Just for info, I was performing the BL install using my VPN service.

Second error encountered: E: Failde to fetch http://httpredir.debian.org/debian/pool … pluginsver. Remote end closed connection [IP: 128.31.0.66 80]

E: Unable tofetch some archives, maybe run apt-get update or try with --fix-missing?
######## WARNING ########
'apt-get -o APT::Install-Recommends=true --quiet install' returned an error

That sounds like maybe a problem with your VPN? Anyway since the error seemed only to be about one geany plugin you were probably right to continue.

Third error encountered: dpkg-deb: building package 'bunsen-welcome-build-deps' in '../bunsen-welcome-build-deps_0.07-1_all.deb'.

The package has been created.
Attention, the package has been created in the current directory, not in ".." as indicated by the message above!

That message always appears. It's a quirk with one of the Debian utilities, nothing to worry about - it still works.

Fourth error encountered...looks like script was creating debian/rules build...number of lines beginning with dh_: dpkg-gencontrol: warning: File::FcntlLock not available; using flock which is not NFS-safe

That message also nearly always appears - I googled it and it's a known bug. No problem.

Fifth error encountered: 1 not fully installed or removed. after the installation of config-package-dev.

Again - always appears after using config-package-dev (in bunsen-configs), but doesn't seem to cause any problems.

Sixth error encountered: Errors were encountered while processing:
bunsen-configs
E: Sub-process /usr/bin/dpkg returned an error code (1)
######## WARNING ########
apt-get returned an error installing bunsen packages

There was a problem installing the local .deb files.

That does seem to be a problem with bunsen-configs. Perhaps, first you could try to install the package again using this command:

~/.bunsen-netinstall-logs/upgrade-bunsen-pkgs --add bunsen-configs
sudo apt-get purge bunsen-configs
sudo apt-get install bunsen-configs

Maybe there was a bug in bunsen-configs which might have been fixed in the latest version (0.3.20)?

I chose to continue at this point.

Installation completed, but when I boot into my BL VM, there is no tint2 panel and the openbox menu is generic.  I'm assuming there should be a tint2 panel and more fully populated openbox menu.

If bunsen-configs failed to install that's what you would get.

sudo aptitude update shows errors about repo addresses not being able to be resolved.  I'm assuming this means that there is no network connectivity under BL.

That's a different issue. Can you, for example,

ping google.com

?


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
#! forum moderator    BunsenLabs

Offline

#5 2015-06-03 05:07:33

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

johnraff wrote:

OK thanks for this. Most of the error messages can be ignored:

I thought so, but included them to be on the safe side.

johnraff wrote:

That does seem to be a problem with bunsen-configs. Perhaps, first you could try to install the package again using this command:

~/.bunsen-netinstall-logs/upgrade-bunsen-pkgs --add bunsen-configs

Returns message to the effect that a network connection could not be found and then exits.

johnraff wrote:

sudo apt-get purge bunsen-configs
sudo apt-get install bunsen-configs

I thought everything was supposed to be ran as normal user?

johnraff wrote:

Maybe there was a bug in bunsen-configs which might have been fixed in the latest version (0.3.20)?

I assume the ~/.bunsen-netinstall-logs/upgrade-bunsen-pkgs --add bunsen-configs would take care of upgrading?

johnraff wrote:

Can you, for example,

ping google.com

?

I get Unknown host error.

Last edited by KrunchTime (2015-06-03 05:40:21)


Linux User #586672
Come and Die -- Kyle Idleman

Offline

#6 2015-06-03 05:36:05

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

It certainly sounds as if your network is down. Are you trying to use wireless or wired? Can you post the content of /etc/network/interfaces?

(The --add bunsen-configs was assuming that bunsen-configs had failed to install. The latest version is now 0.4-1 btw.)


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
#! forum moderator    BunsenLabs

Offline

#7 2015-06-03 05:45:21

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

VM is using NAT.  Host is CrunchBang11 using wired connection.  I've not configured anything regarding networking under the BL install.  I had network connectivity until the BL install script completed and rebooted the VM.

Content of /etc/network/interfaces:

auto lo
iface lo inet loopback

Last edited by KrunchTime (2015-06-03 10:33:20)


Linux User #586672
Come and Die -- Kyle Idleman

Offline

#8 2015-06-03 06:06:15

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

Post the output of:

ip l
sudo ifconfig

Please use code tags when posting terminal output wink

Offline

#9 2015-06-03 07:53:46

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

KrunchTime wrote:

Content of /etc/network/interfaces:
auto lo
iface lo inet loopback

This is the setup for after network-manager is installed. For now, you could try appending this to /etc/network/interfaces

    auto eth0
    allow-hotplug eth0
    iface eth0 inet dhcp

then run

sudo ifup eth0

If that gets the network going you can try the previous command to install bunsen-configs, or just run the install script again, ignoring the warnings about having X installed. (There might be a backup copy of interfaces in /etc/network, or in /backup/bunsen-alpha-netinstall/install/etc/network.)

Last edited by johnraff (2015-06-03 07:58:56)


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
#! forum moderator    BunsenLabs

Offline

#10 2015-06-03 10:21:18

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

@johnraff:  Okay, that worked.  I have internet connectivity in BL again.  I ran the command to install bunsen-configs and received the following error:

update-alternatives: error: alternative path /usr/bin/thunar doesn't exist
dpkg: error processing package bunsen-configs (--configure):
  subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
  bunsen-configs
E: Sub-process /usr/bin/dpkg returned an error code (1)
######## ERROR ########
Failed to install packaging tools.

The script then exited.

Edit:  I attempted to run the BL install script again and received the following error:

dpkg: error processing package bunsen-configs (--configure):
  subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
  bunsen-configs
E: Sub-process /usr/bin/dpkg returned an error code (1)
######## ERROR ########
There was a problem with 'apt-get dist-upgrade'

Last edited by KrunchTime (2015-06-03 10:42:42)


Linux User #586672
Come and Die -- Kyle Idleman

Offline

#11 2015-06-03 10:34:03

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

Head_on_a_Stick wrote:

Please use code tags when posting terminal output wink

I cleaned everything up.  Are you proud of me Daddy? ]:D

Last edited by KrunchTime (2015-06-03 10:44:18)


Linux User #586672
Come and Die -- Kyle Idleman

Offline

#12 2015-06-03 16:27:03

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

^ That'll do pig, that'll do  8o

Offline

#13 2015-06-03 18:56:42

userx-bw
#! Die Hard
From: stuck in an unknown reality
Registered: 2013-11-19
Posts: 735

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

Yeah I ran the NetInstall script today too and got that same thing --

E: Sub-process /usr/bin/dpkg returned an error code (1)
######## ERROR ########
There was a problem with 'apt-get dist-upgrade'

I didn't think much of it because I was running a hacked script, but not in that part of the code, Just using it for a custom install job. So I didn't report it until now after I seen his error too.

Last edited by userx-bw (2015-06-03 19:32:51)


"How can you learn how to fix it, if you don't break it first? :8
"the only way to get away with murder is - by killing time" swp 1997  8o
"A computer is only as smart as the person using it"
"Just plug it in and see if it blows up, if not then take it apart and figure out how it works."

Offline

#14 2015-06-03 22:29:07

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

Head_on_a_Stick wrote:

^ That'll do pig, that'll do  8o

lol  lol


Linux User #586672
Come and Die -- Kyle Idleman

Offline

#15 2015-06-04 00:42:19

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

@KrunchTime bunsen-configs has had some changes recently - maybe there are some config files left around from an earlier version that are clashing (though I thought I had taken care of that  roll ). Check its status with

dpkg-query -s bunsen-configs

Then try purging it:

sudo apt-get purge bunsen-configs
dpkg-query -s bunsen-configs

If dpkg now reports it's completely gone, try installing again:

~/.bunsen-netinstall-logs/upgrade-bunsen-pkgs --add bunsen-configs
sudo apt-get install bunsen-configs

Run the commands separately and stop if you get any errors.

I have installed the latest bunsen-configs on a VM with no errors, but I'll try doing the whole netinstall over again and see if anything comes up...


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
#! forum moderator    BunsenLabs

Offline

#16 2015-06-04 00:47:35

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

johnraff wrote:

....
I have installed the latest bunsen-configs on a VM with no errors, but I'll try doing the whole netinstall over again and see if anything comes up...

I've done a complete install in a VM a few hours ago, with no problems

Last edited by damo (2015-06-04 00:48:02)


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#17 2015-06-04 05:42:04

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

johnraff wrote:

@KrunchTime bunsen-configs has had some changes recently - maybe there are some config files left around from an earlier version that are clashing (though I thought I had taken care of that  roll ). Check its status with

dpkg-query -s bunsen-configs

Result of command: 

Status: install ok half-configured
johnraff wrote:

Then try purging it:

sudo apt-get purge bunsen-configs
dpkg-query -s bunsen-configs

If dpkg now reports it's completely gone,

I did and dpkg reported completely gone.

johnraff wrote:

try installing again:

~/.bunsen-netinstall-logs/upgrade-bunsen-pkgs --add bunsen-configs
sudo apt-get install bunsen-configs

Run the commands separately and stop if you get any errors.

The first command ran without any errors.  The second command ran, but ended with the following error:

Setting up bunsen-configs (0.4-1) ...
update-alternatives: error: alternative path /usr/bin/thunar doesn't exist
dpkg: error processing package bunsen-configs (--configure):
  subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
  bunsen-configs
E: Sub-process /usr/bin/dpkg returned an error code (1)

Perhaps I should start all over again.  This seems to be going nowhere.

damo wrote:

I've done a complete install in a VM a few hours ago, with no problems

Which virtualization program are you using?

Edit:  On a hunch, I manually added /usr/bin/thunar, purged bunsen-configs, added bunsen-configs, and then attempted an installation.  This time similar error returned but referenced /usr/bin/mirage as not existing.  So, I'm thinking the original install really got hosed and I'm not going down a bunch of rabbit holes in an attempt to remedy the situation.  I'll create a new VM, do a Debian Netinstall, and then try again.  If I encounter more errors, I'll hang it up and wait awhile longer.

Last edited by KrunchTime (2015-06-04 05:54:22)


Linux User #586672
Come and Die -- Kyle Idleman

Offline

#18 2015-06-04 05:47:25

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

KrunchTime wrote:
damo wrote:

I've done a complete install in a VM a few hours ago, with no problems

Which virtualization program are you using?

Virtualbox


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#19 2015-06-04 06:34:22

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

Scream!!  Scream!!  Starting from scratch resulted in a successful install of BL Hydrogen and she's a beaut.

2015_06_04_1433398812_802x676_scrot.jpg

Now I need to go through the package list and determine things that were installed that I don't want and then attempt an install on my desktop, overwriting Crunchbang 11 (sigh...such fond memories).


Linux User #586672
Come and Die -- Kyle Idleman

Offline

#20 2015-06-04 07:37:21

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

KrunchTime wrote:

Now I need to go through the package list and determine things that were installed that I don't want

Check out the files in the original installer: pkgs-recs and pkgs-norecs. You can open them in nano and comment out what you don't want before running the installer.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
#! forum moderator    BunsenLabs

Offline

#21 2015-06-04 08:35:50

KrunchTime
#! Die Hard
From: not where I belong
Registered: 2012-03-02
Posts: 3,264

Re: [SOLVED] Netinstall: geany plugin failure and install log empty

^ Thanks for the tip.  I've already went through the package list and marked pkgs I will uninstall and pkgs I need to check further for possible uninstall.  I'm ready to say goodbye to CrunchBang 11 on my desktop and say hello to BL Hydrogen.  big_smile

Edit:  Are you sure about that?  For example, I plan to purge Thunar and if I chose instead to prevent installation via the script, then the bunsen-configs script may not run correctly.  I'm basing this on the experience of my first installation attempt.

Last edited by KrunchTime (2015-06-04 09:04:36)


Linux User #586672
Come and Die -- Kyle Idleman

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo