SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-10-18 08:51:40

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

debian sid mpd

After a recent update I am having a problem with mpd setup on a per user basis.

I had disabled the service with;

sudo update-rc.d mpd disable 

and all used to work fine...mpd would start on boot and start playing...

However, now on boot mpd will not start and I get the error message that the port 6600 is already in use.
I then have to enter;

sudo service mpd stop

in order to start mpd...

Is there some other way to disable the mpd service from starting on boot?

Offline

Help fund CrunchBang, donate to the project!

#2 2014-10-18 09:14:08

woodape
#! CrunchBanger
From: Cape Town, South Africa
Registered: 2014-03-27
Posts: 113

Re: debian sid mpd

Would putting

service mpd stop

in rc.local not work for you? The service may start on boot but then be stopped as soon as that part of the script is reached.

Offline

#3 2014-10-18 09:34:13

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

Re: debian sid mpd

@woodape
Thanks for the idea but that did not work in rc.local...however adding this to ~/.xinitrc does work;

sudo service mpd stop

However, I am still intrigued at to why this has happened to the same mpd config I have been using for years.
Sid bug maybe?

Offline

#4 2014-10-18 21:01:22

woodape
#! CrunchBanger
From: Cape Town, South Africa
Registered: 2014-03-27
Posts: 113

Re: debian sid mpd

Eish man, I'm really not sure, I've only had a sid box for about a month and to be honest I don't even know what an mpd service is. Maybe the developer has filed a bug report? But if your problem is solved maybe you should mark the thread as solved.

Offline

#5 2014-10-19 02:58:25

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

Re: debian sid mpd

Hmm...I am not sure that it is solved as such...more of a 'work around' in my opinion. I think I will leave the thread open a bit longer in case anyone comes up with some ideas as to why I now need to stop the mpd service each boot.

Offline

#6 2014-10-19 11:47:20

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: debian sid mpd

# chkconfig mpd stop

Last edited by Head_on_a_Stick (2014-10-19 11:52:11)

Offline

#7 2014-10-19 11:52:57

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

Re: debian sid mpd

@Head_on_a_Stick
Thanks for the tip...I will give it a try when I am back with my linux boxes...
Keep you posted  wink

EDIT:Yes this problem is specific to my Debian Sid install.
Sid was OK with my mpd config until an update a few days ago...
Identical mpd config on Debian Wheezy and no mpd service issues.

Last edited by chameleon (2014-10-19 12:00:27)

Offline

#8 2014-10-19 14:56:37

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

Re: debian sid mpd

I think we are on the right track with systemd...but still no luck...

live@dwmX-ninja:~$ systemctl status mpd
● mpd.service - Music Player Daemon
   Loaded: loaded (/lib/systemd/system/mpd.service; disabled)
   Active: active (running) since Sun 2014-10-19 16:49:58 CEST; 3min 38s ago
 Main PID: 1424 (mpd)
   CGroup: /system.slice/mpd.service
           └─1424 /usr/bin/mpd --no-daemon
live@dwmX-ninja:~$ su
Password: 
root@dwmX-ninja:/home/live# systemctl disable mpd.service
Synchronizing state for mpd.service with sysvinit using update-rc.d...
Executing /usr/sbin/update-rc.d mpd defaults
insserv: warning: current start runlevel(s) (empty) of script `mpd' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `mpd' overrides LSB defaults (0 1 6).
Executing /usr/sbin/update-rc.d mpd disable
insserv: warning: current start runlevel(s) (empty) of script `mpd' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `mpd' overrides LSB defaults (0 1 6).
root@dwmX-ninja:/home/live# su - live
live@dwmX-ninja:~$ mpd
Oct 19 16:54 : socket: Failed to bind to '127.0.0.1:6600': Address already in use

Offline

#9 2014-10-19 15:17:44

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: debian sid mpd

sudo aptitude purge sysvinit-core

Last edited by Head_on_a_Stick (2014-10-19 15:19:40)

Offline

#10 2014-10-19 15:24:44

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

Re: debian sid mpd

Last edited by chameleon (2014-10-19 15:28:28)

Offline

#11 2014-10-19 15:29:03

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: debian sid mpd

sudo aptitude purge -s sysvinit

Offline

#12 2014-10-19 15:30:44

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: debian sid mpd

Last edited by Head_on_a_Stick (2014-10-19 15:31:31)

Offline

#13 2014-10-19 15:35:15

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

Re: debian sid mpd

live@dwmX-ninja:~$ sudo aptitude purge -s sysvinit
The following packages will be REMOVED:
  sysvinit{p} 
0 packages upgraded, 0 newly installed, 1 to remove and 13 not upgraded.
Need to get 0 B of archives. After unpacking 122 kB will be freed.
Do you want to continue? [Y/n/?] 

Offline

#14 2014-10-19 15:37:23

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: debian sid mpd

^ Looks fine.
I presume the "13 not upgraded" are being held back?
I don't use listbugs so I'm not up to date with all the "bug" reports...

If it was me, I would remove it -- but it's your system wink

Offline

#15 2014-10-19 15:44:01

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

Re: debian sid mpd

Offline

#16 2014-10-19 16:01:16

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: debian sid mpd

From an entry dated 18th October:

Start-Date: 2014-10-18  13:37:03
Commandline: apt-get --no-install-recommends dist-upgrade
Install: libirs-export91:i386 (9.9.5.dfsg-4.3, automatic), libdns-export100:i386 (9.9.5.dfsg-4.3, automatic), libisc-export95:i386 (9.9.5.dfsg-4.3, automatic), libisccfg-export90:i386 (9.9.5.dfsg-4.3, automatic)
Upgrade: libsasl2-2:i386 (2.1.26.dfsg1-11, 2.1.26.dfsg1-12), libxnvctrl0:i386 (340.46-1, 340.46-2), bsdmainutils:i386 (9.0.5, 9.0.6), libnss3:i386 (3.17.1-1, 3.17.2-1), libhunspell-1.3-0:i386 (1.3.3-2, 1.3.3-3), libwebkitgtk-3.0-0:i386 (2.4.6-1+b1, 2.4.6-2), libsasl2-modules-db:i386 (2.1.26.dfsg1-11, 2.1.26.dfsg1-12), isc-dhcp-client:i386 (4.3.1-4, 4.3.1-5), notification-daemon:i386 (0.7.6-1, 0.7.6-2), libwebkitgtk-3.0-common:i386 (2.4.6-1, 2.4.6-2), libwxbase3.0-0:i386 (3.0.2-1, 3.0.2-1+b1), libsasl2-modules:i386 (2.1.26.dfsg1-11, 2.1.26.dfsg1-12), libwxgtk3.0-0:i386 (3.0.2-1, 3.0.2-1+b1), libjavascriptcoregtk-3.0-0:i386 (2.4.6-1+b1, 2.4.6-2), libvdpau1:i386 (0.8-1, 0.8-2), libsqlite3-0:i386 (3.8.6-1, 3.8.7-1), isc-dhcp-common:i386 (4.3.1-4, 4.3.1-5), iceweasel:i386 (31.2.0esr-1, 31.2.0esr-2)
***Error: Sub-process /usr/bin/dpkg returned an error code (1)***
End-Date: 2014-10-18  13:37:17

*** What's this about?

Otherwise, like I say I don't use the .service (& you know more about it than I do), so I'm not sure what else to suggest... hmm

Offline

#17 2014-10-19 16:37:20

chameleon
UK #! Guy
From: Luxembourg
Registered: 2009-01-13
Posts: 719
Website

Re: debian sid mpd

@Head_on_a_Stick
Thanks for all your help so far.
I don't know much about this topic and appreciate your patience.

I am going to 'sleep' on this one and consider the sysvinit removal tomorrow.
I am in the middle of my shift work so cannot risk hosing Sid at this time....

I will update the thread shortly... wink

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo