SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-05-08 02:59:41

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

[SOLVED] "Not authorized to preform operation."

sudo apt-get update && sudo apt-get dist-upgrade --no-install-recommends

Offline

Be excellent to each other!

#2 2014-06-04 12:48:02

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

 04 Jun 14 | 09:25:01 ~
    $ s11bk
Syncing /home     to '/media/sector11/disk/S11-Jun/'
rsync: mkdir "/media/sector11/disk/S11-Jun" failed: No such file or directory (2)
rsync error: error in file IO (code 11) at main.c(674) [Receiver=3.1.0]
Syncing /media/5/ to /media/sector11/disk/M5/
rsync: mkdir "/media/sector11/disk/M5" failed: No such file or directory (2)
rsync error: error in file IO (code 11) at main.c(674) [Receiver=3.1.0]

Syncing complete - Close Terminal
 
 04 Jun 14 | 09:25:25 ~
    $ 

Offline

#3 2014-06-04 17:51:16

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] "Not authorized to preform operation."

polkit.addRule(function(action) {
    if (action.id == "org.freedesktop.udisks2.filesystem-mount-system") {
        return polkit.Result.YES;
    }
});

Offline

#4 2014-06-04 18:26:17

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: [SOLVED] "Not authorized to preform operation."

^ Should work... the polkit syntax changed in some version, so the old .pkla files no longer work.

Offline

#5 2014-06-04 22:29:23

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

Offline

#6 2014-06-05 03:27:00

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: [SOLVED] "Not authorized to preform operation."

This stuff is hard, reminds of Windows. hmm

- Do you have gvfs installed?

apt-cache policy gvfs

- What does your .xinitrc look like?

- Do you have policykit-1-gnome installed

apt-cache policy policykit-1-gnome

and set in autostart:

/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &

Last edited by Alad (2014-06-05 03:36:35)

Offline

#7 2014-06-05 06:21:54

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] "Not authorized to preform operation."

I think polkit may be a .service started by sytemd --- it depends which version of systemd Debian Sid is running (the Arch version deprecated this function as of yesterday...) hmm
What is the output of:

systemctl status polkit.service

And while we're at it, might as well see the output of:

systemctl --all

Are we having fun yet? tongue

Offline

#8 2014-06-05 12:38:08

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

 05 Jun 14 | 09:17:07 ~
    $ acpol gvfs
gvfs:
  Installed: 1.20.2-1
  Candidate: 1.20.2-1
  Version table:
 *** 1.20.2-1 0
        990 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
 
 05 Jun 14 | 09:17:09 ~
    $ acpol policykit-1-gnome
policykit-1-gnome:
  Installed: 0.105-2
  Candidate: 0.105-2
  Version table:
 *** 0.105-2 0
        990 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
 
 05 Jun 14 | 09:17:48 ~
    $ 

Offline

#9 2014-06-05 12:46:31

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

systemctl status polkit.service

Offline

#10 2014-06-05 17:06:45

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: [SOLVED] "Not authorized to preform operation."

systemctl --state=failed

Last edited by Alad (2014-06-05 17:07:14)

Offline

#11 2014-06-05 18:02:47

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

polkit.service - Authorization Manager
   Loaded: loaded (/usr/lib/systemd/system/polkit.service; static)
   Active: inactive (dead)
     Docs: man:polkit(8)

Offline

#12 2014-06-05 18:39:44

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] "Not authorized to preform operation."

sudo systemctl stop polkitd.service

Last edited by Head_on_a_Stick (2014-06-05 19:01:09)

Offline

#13 2014-06-05 19:39:24

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: [SOLVED] "Not authorized to preform operation."

Last edited by Alad (2014-06-05 19:42:08)

Offline

#14 2014-06-06 16:58:49

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

sudo systemctl stop polkitd.service

Offline

#15 2014-06-08 15:30:01

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

Offline

#16 2014-06-08 15:56:05

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: [SOLVED] "Not authorized to preform operation."

Logging in after months because it breaks my heart that S11 can't watch his DVD smile

Let's do it a bit more extreme:

sudo nano /usr/share/polkit-1/actions/org.freedesktop.udisks.policy
sudo nano /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy

We should edit both files, I am not sure which you have. In the section that reads " <description>Mount a filesystem</description>" find the line that contains:

<allow_any>auth_admin</allow_any>

or so. Change it to read

<allow_any>yes</allow_any>

Do this in both files. It should work at once.

Edit: by the way, "Identity=unix-group:plugdev" in the pkla file means that your user should be in the plugdev group. Probably your user is in the cdrom group, that's why the DVD doesn't get the policy.

Last edited by machinebacon (2014-06-08 15:57:45)

Offline

#17 2014-06-08 18:05:26

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

  <action id="org.freedesktop.udisks2.filesystem-mount">
    <description>Mount a filesystem</description>
... {snip extra language stuff}
    <message>Authentication is required to mount the filesystem</message>
... {snip extra language stuff}
    <defaults>
      <allow_any>yes</allow_any>
      <allow_inactive>auth_admin</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>

Offline

#18 2014-06-08 18:11:39

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: [SOLVED] "Not authorized to preform operation."

Sector, let's just create another pkla file, like /etc/polkit-1/localauthority/50-local.d/auto-mount2.pkla

[udisks] 
Identity=unix-user:*
Action=org.freedesktop.udisks* 
ResultAny=yes

We would give permissions to all users, and to both udisks versions.

Another question, is there a /dev/sr0 entry in fstab? Just asking smile

Offline

#19 2014-06-08 18:14:21

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] "Not authorized to preform operation."

Offline

#20 2014-06-08 18:19:09

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: [SOLVED] "Not authorized to preform operation."

^ I think so too.

/dev/sr0 /mnt/cdrom auto noauto,ro 0 0

should already do the trick, independently from thunar and the whole freedesktop crap.

Offline

#21 2014-06-08 19:24:34

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc    /proc   proc    defaults        0       0
/dev/sda6       /       ext4    relatime,errors=remount-ro      0       1
/dev/sda5       /media/5        ext4    defaults        0       0
/dev/sda8       /media/8        ext4    defaults        0       0
/dev/sda1       /media/sda1     ext4    defaults        0       0
/dev/sda2       /media/sda2     ext4    defaults        0       0
/dev/sda9       /media/9        ext4    defaults        0       0
/dev/sda7       /home   ext4    relatime        0       0
/dev/sda3       none    swap    sw      0       0
/dev/cdrom      /media/cdrom    udf,iso9660     user,noauto,exec,utf8   0       0


/etc/fstab (END)

Offline

#22 2014-06-08 19:30:38

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] "Not authorized to preform operation."

UUID=<big long string found using "lsblk -f">     /media/disk     ext4     user    0     0

Offline

#23 2014-06-08 19:49:16

linuxreign
#! Junkie
From: Panama
Registered: 2011-09-05
Posts: 254

Re: [SOLVED] "Not authorized to preform operation."

Last edited by linuxreign (2014-06-08 20:02:32)

Offline

#24 2014-06-08 20:45:34

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] "Not authorized to preform operation."

UUID=<big long string found using "lsblk -f">     /media/disk     ext4     user    0     0

Offline

Help fund CrunchBang, donate to the project!

#25 2014-06-14 01:07:38

antsunrise
#! CrunchBanger
Registered: 2014-06-11
Posts: 153

Re: [SOLVED] "Not authorized to preform operation."

I had or have same issue after upgrading to jessie.

I think udisks may have fixed it .

made sure gvfs was installed wen't to /home/user/.config/openbox/autostart


## Start Gnome Policy Kit
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &

sorry if doesn't help. it seemed to work right after I did it and rebooted it. unless it was something else.

Last edited by antsunrise (2014-06-14 02:00:42)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo