SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-11-11 03:21:11

thredith
Member
From: Bogotá - Colombia
Registered: 2013-10-22
Posts: 10
Website

Enjoy Netflix in #! natively

I've been wanting to enjoy Netflix in #! ever since I installed it, but thanks to Microsoft's Silverlight restrictions, such a simple task became a total headache. However, I've found an interesting way to make Netflix work natively, without using Wine (at least not manually) or the Netflix Desktop app.

I'm using Crunchbang Waldorf 64 bit (nonetheless, it should work under 32 bit systems as well), and I've successfully tested this method using both Iceweasel and Chrome browsers.

All you need to do is to install Pipelight in your system, plus a User Agent plugin for your web browser.

Ok, so let's get started!

First of all, if you're working under a 64 bit system, open your Terminal, and run the following line:

sudo dpkg --add-architecture i386 

This will allow you to install Pipelight in your 64 bit system. If you have a 32 bit system, then don't worry. Pipelight will run just fine.
Now, you must proceed to get the key for the Pipelight repository:

wget http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0/Release.key
sudo apt-key add Release.key 

Good. Now let's add the Pipelight repo to your sources.list. Open a new Terminal window, and run:

sudo geany /etc/apt/sources.list 

Add the following line to your sources.list:

deb http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0/ ./ 

Save and exit. Then, go back to your Terminal, and perform an update:

apt-get update 

Excellent! Now, you may finally proceed to install Pipelight:

apt-get install pipelight

So far, so good? Great! Here comes the "tricky" part of the setup... well, it's actually not tricky at all, but make sure you don't skip it! If you do, you'll get an error every time you try to run Netflix from your web browser.

If you have Iceweasel/Firefox do as follows:
1- Download and install this extension: User Agent Overrider
2- Restart your web browser. Once it loads, search for the extension's icon, click on it, and from its drop-down menu, select "Firefox 24/Windows".
4n6aO4is.png

If you have Google Chrome do as follows:
1- Download and install this extension: User Agent Switcher
2- You don't need to restart your web browser. Just wait until the extension loads, and search for its icon. Proceed to click on it, and from its drop-down menu, select "Firefox", and then "Windows Firefox 4".
LoCNlNBs.png

Aaaaand.... that's it! You may now enjoy Netflix natively! big_smile

pL3VYr7s.png

Last edited by thredith (2013-11-11 03:28:21)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-11-19 22:42:42

bootlinux
New Member
From: AZ
Registered: 2009-07-30
Posts: 8
Website

Re: Enjoy Netflix in #! natively

Very Nice. I just gave your instructions a try and it worked perfect.
I tried the other methods over the months using the PPA but they never worked. Yours did. Good job.
I never liked the run in fullscreen default anyway.....

Offline

#3 2013-11-20 17:46:29

buttonmasher
Member
Registered: 2013-10-25
Posts: 14

Re: Enjoy Netflix in #! natively

Many thanks, thredith. Works like a charm on my 64bit #! laptop. I'll see how it does on my old desktop here in a little while.

Good stuff.

Offline

#4 2013-11-21 01:34:59

thredith
Member
From: Bogotá - Colombia
Registered: 2013-10-22
Posts: 10
Website

Re: Enjoy Netflix in #! natively

You're welcome bootlinux and buttonmasher! I'm glad to know it worked for you as well big_smile

Offline

#5 2013-11-21 19:36:34

mbemboom
#! CrunchBanger
Registered: 2013-03-30
Posts: 104

Re: Enjoy Netflix in #! natively

As discussed here I've been having some issues getting this working right for me and I'm not sure what exactly is wrong. By following the instructions here I have been able to get it working great in Linux Mint 15 KDE. I have tried several different times in Crunchbang but am running into the same issue every time which is this error:
1.png
Just now I did a

sudo apt-get purge pipelight

and then followed your instructions exactly. I am still getting the error in the image.
I am open to any and all suggestions.


"Yeah, well, you know, that’s just, like, your opinion, man. "  - The Dude

Offline

#6 2013-11-21 21:03:15

buttonmasher
Member
Registered: 2013-10-25
Posts: 14

Re: Enjoy Netflix in #! natively

Maybe it's the browser you're using? Try a fresh install of Firefox/Chrome without any addons and give it another shot? I'm just tossing ideas around, man. I'm sure thredith will pop in sooner or later and help you out.

Offline

#7 2013-11-21 23:13:57

mbemboom
#! CrunchBanger
Registered: 2013-03-30
Posts: 104

Re: Enjoy Netflix in #! natively

I just tried Firefox and get the same error with the UA spoofer installed and Firefox 24/Windows selected


"Yeah, well, you know, that’s just, like, your opinion, man. "  - The Dude

Offline

#8 2013-12-31 04:27:47

bhosshunt
New Member
Registered: 2013-12-21
Posts: 2

Re: Enjoy Netflix in #! natively

Thanks for these instructions, very helpful.

Offline

#9 2014-01-18 17:59:12

tty-tourist
#! CrunchBangian
From: within the swirl
Registered: 2013-05-26
Posts: 281

Re: Enjoy Netflix in #! natively

thredith wrote:
wget http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0/Release.key

This address seems to no longer exist. Browsed my way to this but that does seem very useful. Any idea where else I can find the key?

EDIT: works now. Guess the site was down yesterday ...

Last edited by tty-tourist (2014-01-19 20:33:41)


"You're just a tourist with a typewriter." - Charlie Meadows, Barton Fink

Offline

#10 2014-01-19 10:44:59

vic
#! by Default
From: /grill
Registered: 2009-02-13
Posts: 3,361

Re: Enjoy Netflix in #! natively

Did not work out with Iceweasel. Installed Chromium and it works, thanks a  {)


Time to move on!#

Offline

#11 2014-01-20 01:57:48

sleepyguy
Member
From: Toronto, Ontario
Registered: 2014-01-02
Posts: 13

Re: Enjoy Netflix in #! natively

wicked!  got this working perfectly fine!  Only issue i can see is there is some tearing on fast moving scenes... not sure if it's the display driver or some setting I'm missing.  I tried on the same laptop (dual boot Win7-64) and netflix runs those same scenes perfectly.

Hmmm... still awesome though!  Tks!


...zzz...zzz...zzz...

Offline

#12 2014-01-20 21:37:28

Grumpy
Member
From: Scotland
Registered: 2013-10-26
Posts: 13

Re: Enjoy Netflix in #! natively

Worked just fine on #! 64 Lenovo. Thanks for taking the time. Cheers.


We don't do 'blame' in our house . . . especially when it's my fault

Offline

#13 2014-01-21 23:18:49

ElderV.LaCoste
#! Die Hard
From: Equarico
Registered: 2010-07-15
Posts: 817

Re: Enjoy Netflix in #! natively

Thanks for posting this.  It works perfectly.  Has anyone been able to get it to stream to Chromecast?


Things are not as they seem, nor are they otherwise.
- Lankavatara Sutra

Offline

#14 2014-01-30 04:42:32

zazen23
#! Member
Registered: 2011-07-10
Posts: 79

Re: Enjoy Netflix in #! natively

Works for me in the latest Mozilla Firefox 26.0! cool Tested the plugin at Bubblemark.com wink .

Offline

#15 2014-02-01 23:52:11

Grumpy
Member
From: Scotland
Registered: 2013-10-26
Posts: 13

Re: Enjoy Netflix in #! natively

And works just fine on old Dell 32bit Inspiron. Cheers.


We don't do 'blame' in our house . . . especially when it's my fault

Offline

#16 2014-02-06 14:34:25

reundo
New Member
Registered: 2014-01-29
Posts: 6

Re: Enjoy Netflix in #! natively

Just got it working on my 64bit install.  Thanks!

Offline

#17 2014-02-12 21:35:41

bootlinux
New Member
From: AZ
Registered: 2009-07-30
Posts: 8
Website

Re: Enjoy Netflix in #! natively

I just installed Crunchbang on a second laptop today and setup Netflix per the instructions and all went well, except....
The User Agent Override now lists Windows / Firefox 26 which does not seem to work with Iceweasel 20.

The last time I installed Crunchbang and setup the system to run Netflix the User Agent Override showed Windows / Firefox 24 which did work.

I got this one to work by adding the following line to User Agent Override list:
Windows / Firefox 24: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Then closed Iceweasel, opened Iceweasel and now Netflix works just fine when I select the Windows / Firefox 24 entry.

Offline

#18 2014-03-05 21:40:15

benhee
Member
From: North West UK.
Registered: 2009-10-28
Posts: 41

Re: Enjoy Netflix in #! natively

This works great for watching Sky Go in the UK, on 32bit lenovo, in iceweasel.

Thanks thredith

Offline

#19 2014-03-06 18:21:44

Geeman265
New Member
Registered: 2014-03-06
Posts: 2

Re: Enjoy Netflix in #! natively

I seem to be going around in circles with this. I've tried following the other guides with no success.

Thought I'd give this one a go. When I get down to installing pipelight, I get the following:

$ sudo apt-get install pipelight
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pipelight : Depends: pipelight-multi but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When trying to install the pipelight-multi, I get the "Depends: wine-compholio" issue like the common problem with the other threads.

What am I doing wrong??

Offline

#20 2014-04-08 13:30:58

cloverskull
#! Junkie
Registered: 2013-10-26
Posts: 377

Re: Enjoy Netflix in #! natively

Anyone care to try 64 bit / no user agent switching / new sexy features edition? http://www.webupd8.org/2014/04/pipeligh … -with.html

Offline

#21 2014-07-09 16:46:31

ntovik
New Member
Registered: 2014-07-09
Posts: 1

Re: Enjoy Netflix in #! natively

Do I need to use the Crunchbag distribution, or will this solution work on any Linux distribution like Ubuntu 14.04 (Thrusty)?

Offline

#22 2014-07-09 19:38:52

vic
#! by Default
From: /grill
Registered: 2009-02-13
Posts: 3,361

Re: Enjoy Netflix in #! natively

@ntovik, just google ubuntu netflix, lot of stuff about it.


Time to move on!#

Offline

#23 2014-08-04 20:21:29

XLII
Member
Registered: 2014-07-31
Posts: 26

Re: Enjoy Netflix in #! natively

Hey thanks, works like a charm!

Btw, if you get DRM errors (such as N8156-6003, N8156-6013, N8156-6023) this worked for me.

Offline

#24 2014-08-20 01:59:17

nomad
Member
Registered: 2012-08-16
Posts: 10
Website

Re: Enjoy Netflix in #! natively

Gah Damn. I love results.


Happy Birthday and Spraypaint an Angel on Your Trailer.

Offline

Help fund CrunchBang, donate to the project!

#25 2014-08-21 18:16:08

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: Enjoy Netflix in #! natively

Any advice on getting this to work with BT Sport, just get offered the Install Silverlight button. This in Chromium. ??

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo