SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-06-27 20:48:51

837183
Member
Registered: 2013-04-19
Posts: 35

Can't explore pictures on the digital camera

Hey

So I got this Fujifilm Finepix z70 gg camera..

On Windows XP, I can explore it's photos.

On #! it is seen by lsbus. someone suggested to mount it manually..

but it isn't listed in sudo fdisk -l ..

any chance of getting it to work on #!?

Offline

Be excellent to each other!

#2 2013-06-27 23:11:26

iann
#! Die Hard
Registered: 2010-09-10
Posts: 720

Re: Can't explore pictures on the digital camera

You're in luck.  There is a whole thread devoted to this, with a variety of solutions and workarounds:
http://crunchbang.org/forums/viewtopic.php?id=20571

A good start would be to install gphoto2 and see what the following command says: gphoto2 --auto-detect

Also you probably have gvfs, so see what gvfs-mount -li says also.

Last edited by iann (2013-06-27 23:16:09)

Offline

#3 2013-06-27 23:32:32

837183
Member
Registered: 2013-04-19
Posts: 35

Re: Can't explore pictures on the digital camera

Oh..sorry, should've mentioned I did look at thread 20571.

I did download gphoto2..

the parameter --auto-detect gives nothing..

Model                          Port                                            
----------------------------------------------------------

gvfs gives

Drive(0): CD/DVD Drive
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  ids:
   unix-device: '/dev/sr0'
  themed icons:  [drive-optical]  [drive]
  is_media_removable=1
  has_media=0
  is_media_check_automatic=1
  can_poll_for_media=1
  can_eject=0
  can_start=0
  can_stop=0
  start_stop_type=unknown

Last edited by 837183 (2013-06-27 23:33:28)

Offline

#4 2013-06-28 01:37:58

disfarmer
#! Member
From: Youngsville, New York
Registered: 2010-01-07
Posts: 55

Re: Can't explore pictures on the digital camera

I have a Fujifilm F30 and struggled awhile before successfully exploring the photos on the camera using Thunar. I don't know if the same is true for your camera but in the case of the F30, the problem has to do with Fuji using the PTP protocol rather than an easier USB Mass Storage class.  In addition to gphoto2, I installed gphotofs:

apt-get install gphotofs

I then created a mountpoint:

mkdir /mnt/fuji

Then changed ownership to me:

chown my_name /mnt/fuji

After that I could mount the camera and explore the contents using:

gphotofs /mnt/fuji

I added that code to Thunar's volume management preferences to run automatically when I connected the camera. To unmount the camera:

fusermount -u /mnt/fuji

In the end, I found gtkam was a much faster way to manage the contents of the camera than Thunar so that's what I use instead.


"Ten thousand people shouting the same thing makes it false--even if it happens to be true." - Søren Kierkegaard

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo