SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#51 2013-10-29 15:27:27

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

rezin wrote:

I followed the tutorial, have libgl1-mesa-glx:i386 installed (Intel HD 3000 graphics) and it keeps saying it is missing libGL.so.1 after running steam-debian.
Any solutions?

Are you on a 32 bit or 64 bit system?

Offline

Be excellent to each other!

#52 2013-10-29 16:30:49

rezin
Member
Registered: 2013-10-21
Posts: 15

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

cup_of_squirrel wrote:
rezin wrote:

I followed the tutorial, have libgl1-mesa-glx:i386 installed (Intel HD 3000 graphics) and it keeps saying it is missing libGL.so.1 after running steam-debian.
Any solutions?

Are you on a 32 bit or 64 bit system?

64 bit Waldorf, Thinkpad X220.

Offline

#53 2013-11-04 20:30:41

rezin
Member
Registered: 2013-10-21
Posts: 15

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Anyone?

Offline

#54 2013-11-06 19:47:57

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

rezin wrote:

Anyone?

No idea. You could try making a symbolic link from the mesa folder.

Check that it's even there:

ls /usr/lib/i386-linux-gnu/mesa/libGL.so.1

If it is, make the sym link:

sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib

I don't have an intel card so it's pretty much a blind guess.

Also, I'd try launching steam from the terminal with steam-debian because that gives you better debug messages.

Offline

#55 2013-11-07 11:42:50

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Hi all, I'm trying to get Steam up and running on my 32bit box with little success.  I downloaded and installed the deb with no issues.  I ran Steam without installing:

sudo apt-get install libgl1-nvidia-glx

just to see if it would run.  Steam fired up without an issue.  I downloaded one of the free games as a test, (what it was, God only knows).  When I ran it, it kicked up the error that I needed to install ST3C Support.  After searching to find out what that was.  I was pointed back towards the Nvidia-glx.  Installed this as described in the original post and ran Steam again.  This time Steam wouldn't start.  I checked my graphic card:

andy@andy-crunchbang:~$ glxinfo | grep -i vendor 
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
andy@andy-crunchbang:~$ 

I next purged nvidia-glx and autoremoved.  I then checked my graphic card again and get this error;

andy@andy-crunchbang:~$ glxinfo | grep -i vendor 
Error: couldn't find RGB GLX visual or fbconfig
andy@andy-crunchbang:~$ 

If I try to run Steam I get the error message:

OpenGL GLX extension not supported by display

So I've got to the point where I'm chasing my own tail.  Could anyone help me get this up and running.  Many thanks.

Last edited by AndyinMokum (2013-11-07 12:01:30)


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#56 2013-11-07 16:00:30

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@AndyinMokum

Install glx again with

sudo apt-get install libgl1-nvidia-glx

Then configure X with:

sudo nvidia-xconfig

The above command should set up you xorg.conf automatically. If this doesn't help, go into your /etc/X11/xorg.conf and make sure that it has this line at the bottom of "Screen" section:

Option "AddARGBGLXVisuals" "True"

Also, might need to have this line in "Module" section:

Load "glx"

Although I'm not sure that last thing is completely necessary.

Offline

#57 2013-11-07 19:06:07

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Thanks for getting back to me.  I thought of being clever when I saw Nvidia and I made a CloneZilla backup before installing Steam. I knew that there were likely to be problems which, there were.  Flashed the CloneZilla image back on the HDD, now knowing what to expect.  Installed steam-debian again and then installed:

sudo apt-get install libgl1-nvidia-glx

I then invoked steam-debian and I receive the following error:

OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_art … -EYZB-7457.

I then tried the command:

sudo nvidia-xconfig

and receive this output:

sudo: nvidia-xconfig: command not found
andy@andy-crunchbang:~$ 

I then try to edit:

/etc/X11/xorg.conf

and the file doesn't exist.

So I'm now scratching my head, wondering what now to do.

Last edited by AndyinMokum (2013-11-07 19:14:29)


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#58 2013-11-07 19:47:19

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@AndyinMokum

sudo apt-get install nvidia-xconfig nvidia-settings
sudo nvidia-xconfig

nvidia-xconfig will create a xorg.conf file if there is none. Then run nvidia-settings and look under OpenGL/GLX Information to make sure direct rendering is enabled. If it's not, do the xorg.conf edits I mentioned in my previous post.

Last edited by cup_of_squirrel (2013-11-07 19:47:50)

Offline

#59 2013-11-07 20:38:40

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Hi and thanks again.  I just tried what you suggested and it made no difference.  Steam-debian opens but I get the error message:

OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_art … -EYZB-7457.

I then I try to open the test game and receive another error, Can't find required OpenGL entry point..............

Sorry, I failed to post my graphics card info:

andy@andy-crunchbang:~$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
andy@andy-crunchbang:~$ 
andy@andy-crunchbang:~$ glxinfo | grep -i vendor 
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: Tungsten Graphics, Inc
andy@andy-crunchbang:~$ 

After the installation:

andy@andy-crunchbang:~$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
andy@andy-crunchbang:~$ glxinfo | grep -i vendor
Xlib:  extension "NV-GLX" missing on display ":0.0".
server glx vendor string: SGI
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: Tungsten Graphics, Inc
andy@andy-crunchbang:~$ 

Last edited by AndyinMokum (2013-11-07 20:51:15)


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#60 2013-11-07 20:46:18

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@AndyinMokum

Well, if steam client is launching now we're getting somewhere.

What does nvidia-settings > OpenGl/GLX say?
What does your xorg.conf look like? (Use pastebin.com to link it here)

Offline

#61 2013-11-07 21:00:38

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Hi again, yes we do seem to be getting there - slow but sure  lol .  This is the warning message I get when I open: nvidia-settings

You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

I don't have the option OpenGL/GLX, only:

Enable ToolTips
Display Status Bar
Slider Text Entries
Include X Display Names in the Config FileInclude X Display Names in the Config File
Show "Really Quit?" Dialog

Only "Include X Display Names in the Config File" is unchecked.

Last edited by AndyinMokum (2013-11-07 21:01:11)


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#62 2013-11-07 21:07:55

rezin
Member
Registered: 2013-10-21
Posts: 15

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

cup_of_squirrel wrote:

No idea. You could try making a symbolic link from the mesa folder.

Check that it's even there:

ls /usr/lib/i386-linux-gnu/mesa/libGL.so.1

Also, I'd try launching steam from the terminal with steam-debian because that gives you better debug messages.

It is not even there. The folder i386-liux-gnu does not exist  hmm

Offline

#63 2013-11-07 21:19:43

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@AndyinMokum

Restart your x server (Ctrl + Alt + Backspace or just reboot if that doesn't work). Test if steam games work.

If it still doesn't work paste your xorg.conf into pastebin.com and give me a link.

---
EDIT

Also, what method you used to install the proprietary nvidia driver?

Last edited by cup_of_squirrel (2013-11-07 21:24:58)

Offline

#64 2013-11-07 21:32:00

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Sorry my eyes are getting tired, I missed that you needed the contents of xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.48  (buildd@murphy)  Wed Sep 12 11:32:28 UTC 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Option         "AddARGBGLXVisuals" "True"
    EndSubSection
EndSection

Last edited by AndyinMokum (2013-11-07 21:40:56)


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#65 2013-11-07 22:29:47

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Hi again, just did a reboot and the new config killed X.  I'm flashing the old image back to my hard drive at the moment.  I not sure if this is worth the aggravation.  I will wait until the laptop is back up and running and then decide if it worth continuing  sad .


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#66 2013-11-07 22:59:09

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

I'm back up and running.  I think I'll leave Steam for the moment.  It is too much aggravation to get it up and running.  I'm not a gamer I just wanted to see if I could get it up and running as a project.  I'm just glad I backed up.  Anyway, thanks for the help.


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#67 2013-11-08 18:18:15

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@AndyinMokum

Didn't have to reinstall. All you had to do is to login to the tty console with you normal credentials and restore xrog.conf from backup:

cd /etc/X11
sudo mv xorg.conf xorg.conf.broken
sudo mv xorg.conf.backup xorg.conf
sudo reboot

You could also just remove xorg.conf and X would start again.

You probably installed your proprietary drivers wrong or something. Which method did you use? Use either this method or smxi.

Offline

#68 2013-11-08 18:36:51

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Hi again, the method I used was the one suggested with the first post.

sudo apt-get install libgl1-nvidia-glx

"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#69 2013-11-08 18:50:16

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@rezin

According to libgl1-mesa-glx description, you might also need libgl1-mesa-dri. Once again, this is just a guess, I don't have an Intel card. Couldn't hurt to try though:

sudo apt-get install libgl1-mesa-dri:i386

Offline

#70 2013-11-08 19:00:24

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@AndyinMokum

You mean 1st post of this thread? Well, there's your problem, because that command does not install the driver. libgl1-nvidia-glx is just a library to enable direct rendering for nvidia driver. If you don't have the driver, there's nothing to enable.

To install the actual driver use this tutorial. Then follow parkerlreed's tutorial in the 1st post of this thread to get steam-debian working.

Last edited by cup_of_squirrel (2013-11-08 19:09:54)

Offline

#71 2013-11-08 21:13:02

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Hi again. I installed the driver using the method described in, http://crunchbang.org/forums/viewtopic.php?id=19332.  I ran into problems when I reached:

sudo apt-get install nvidia-glx

I was warned that nvidia needed to be manually configured.  Then I couldn't backup:

 sudo cp -p /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

I then received an error message that:

sudo nvidia-xconfig

couldn't be found.  I then rebooted and followed the instructions as described in the original post.  Steam installs but won't open because it doesn't recognize the OpenGL version.  The libgl1-mesa-dri:i386 is up to date and current. Rebooted and I again lost x.  I couldn't recover because there was no backup xorg,conf.bak.  Had to reinstall because I know no other way to recover from this situation.  All I can say about installing Steam on this laptop is, that it is a royal pain in the backside.


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#72 2013-11-09 22:00:37

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Oh well, I can't get this up and running.  It just doesn't want to play nice. The only thing that happens is I loose x server.  I concede defeat  sad


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

#73 2013-11-11 17:18:13

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@AndyinMokum

Oh well.

The step you got stumped at says "Backup xorg.conf if you have one". Since you didn't have one, you're safe to skip it.

When you get a message that a command couldn't be found all you have to do usually is sudo apt-get install it. So:

sudo apt-get install nvidia-xconfig
sudo nvidia-xconfig

This step is crucial, it configures X server to use your driver, which you already have installed if you followed that tutorial.

Last edited by cup_of_squirrel (2013-11-11 17:18:38)

Offline

#74 2013-11-12 09:32:15

AndyinMokum
#! Junkie
From: Amsterdam
Registered: 2013-09-01
Posts: 274

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Hi again, I thought that I had better give this one more go, seeing you have been kind enough to provide more possibilities   smile.  Unfortunately, I fell at the first hurdle this time.  It appears that the steam-debian installer site has been bauked:

andy@andy-crunchbang:~$ wget https://github.com/GhostSquad57/Steam-Installer-for-Wheezy/raw/master/steam-debian_1.0.0.43-2_all.deb
--2013-11-12 10:14:09--  https://github.com/GhostSquad57/Steam-Installer-for-Wheezy/raw/master/steam-debian_1.0.0.43-2_all.deb
Resolving github.com (github.com)... 192.30.252.130
Connecting to github.com (github.com)|192.30.252.130|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://raw.github.com/GhostSquad57/Steam-Installer-for-Wheezy/master/steam-debian_1.0.0.43-2_all.deb [following]
--2013-11-12 10:14:11--  https://raw.github.com/GhostSquad57/Steam-Installer-for-Wheezy/master/steam-debian_1.0.0.43-2_all.deb
Resolving raw.github.com (raw.github.com)... 185.31.16.133
Connecting to raw.github.com (raw.github.com)|185.31.16.133|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-11-12 10:14:13 ERROR 404: Not Found.

I've tried to access this several times over an 8 hr time period, all with the same result. This is the nearest I have ever come to believing in something being cursed  sad !

Last edited by AndyinMokum (2013-11-12 09:35:53)


"If you can't blind 'em with science, baffle 'em with bullshit".

Distros: Crunchbang 11 ""Waldorf" 64bit & Peppermint Five 64bit, Machine: Fujitsu-Siemens AMILO Notebook Li 3710, CPU: 2x Intel Pentium Dual CPU T3400 @ 2.16GHz, RAM: 4GB

Offline

Be excellent to each other!

#75 2013-11-12 21:21:41

cup_of_squirrel
#! CrunchBanger
From: New York City
Registered: 2013-08-29
Posts: 141

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

@AndyinMokum

They have a new version out: 1.0.0.43-3_all.deb. So you should use:

wget https://github.com/GhostSquad57/Steam-Installer-for-Wheezy/raw/master/steam-debian_1.0.0.43-3_all.deb

After you install it, all later updates should be automatic, so you'll never deal with github again.

Last edited by cup_of_squirrel (2013-11-12 21:22:26)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo