SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2013-03-27 01:10:30

mosesgunn
#! CrunchBanger
Registered: 2012-10-20
Posts: 133

Re: Working Netflix in #!

Thank you!  I will have to try it out later this week!  I am swamped with work!

Offline

Be excellent to each other!

#27 2013-03-27 03:52:24

JLloyd13
#! Member
Registered: 2012-08-08
Posts: 83

Re: Working Netflix in #!

shawn789 wrote:

@mosesgunn

I was having the same issue. I think that after you do the 'dpkg --add-architecture i386', you have to go into /etc/apt/sources and add "[arch=amd64,i386]" between 'deb' and the source url on each line that says 'deb <url> waldorf main'.

I also added the line:

deb http://http.us.debian.org/debian wheezy main

at the bottom and that seemed to have done the trick. I'm not sure which of these did the trick but doing them both worked for me.

I don't have the i386 part entered so possibly the latter? you should have that line anyway though.

Offline

#28 2013-03-27 12:44:11

mosesgunn
#! CrunchBanger
Registered: 2012-10-20
Posts: 133

Re: Working Netflix in #!

@shawn789 I recently spent the weekend doing a little distro hopping and I of course returned to #!.  I did a fresh and install and netflix works great!

Offline

#29 2013-04-01 02:29:22

mbemboom
#! CrunchBanger
Registered: 2013-03-30
Posts: 104

Re: Working Netflix in #!

This works great.  I had recently started looking for a way to do this in Linux.  Thanks for sharing.   smile   Now if I could get it to work on my Mepis desktop I'll be set.


"Yeah, well, you know, that’s just, like, your opinion, man. "  - The Dude

Offline

#30 2013-04-05 00:10:57

Captn#
Member
Registered: 2013-03-20
Posts: 10

Re: Working Netflix in #!

I got this error while trying to run netflix-desktop
Compositing is disabled in the X11 configuration file, please enable compositing support and relaunch Netflix Desktop.

solution?

Offline

#31 2013-04-06 02:35:12

RitterSport
#! Member
Registered: 2013-02-18
Posts: 58

Re: Working Netflix in #!

Just posting to say that I followed the various instructions in this thread and Netflix is working for me.  Thanks, everyone, for getting this working.  I just have one more thing I need to figure out and I can use #! exclusively on one of my laptops.

Offline

#32 2013-04-07 03:06:44

sillysocks
New Member
From: Chicago
Registered: 2013-04-05
Posts: 2
Website

Re: Working Netflix in #!

Great guide! Everything worked for me on the install, but I think my specs might be too low to play video. I started playing a movie, but only got sound with a black screen. I'm on a netbook, so I wouldn't be shocked if I couldn't stream video. Disappointed, but not shocked.  neutral

Offline

#33 2013-04-10 03:07:39

oizo
New Member
Registered: 2013-04-10
Posts: 1

Re: Working Netflix in #!

sillysocks wrote:

Great guide! Everything worked for me on the install, but I think my specs might be too low to play video. I started playing a movie, but only got sound with a black screen. I'm on a netbook, so I wouldn't be shocked if I couldn't stream video. Disappointed, but not shocked.  neutral

Yes same thing for me and i am on an i5 with a good graphics card.  Something isn't working right.  I just get a black screen.  Not really sure where to start either.

Offline

#34 2013-04-10 03:55:09

th3pun15h3r
#! Die Hard
Registered: 2011-11-22
Posts: 571

Re: Working Netflix in #!

Just have to adjust the size of the screen by double click on the window bar or minimize/maximize

Offline

#35 2013-04-20 16:10:22

th3pr0ph3t
Member
Registered: 2011-03-02
Posts: 28

Re: Working Netflix in #!

I have the black screen problem too. However, netflix worked for me before. After an "update to silverlight" all I get is a black screen.
I hope netflix stops using Silverlight soon or provide a way to have access from linux as shared on this blog post:

http://www.theverge.com/2013/4/15/42282 … tml5-video

PD: I am using AMD drivers.

Offline

#36 2013-05-01 20:42:10

nanomagnetic
Member
From: cascadia
Registered: 2009-10-26
Posts: 17

Re: Working Netflix in #!

i'm working on my mother's laptop at the moment. she's far from a poweruser so it's up to me to muck around with the command line and get crunchbang up to a user-friendly level. i'm far from a guru, so a huge thanks to everyone who contributed to this thread! the step-by-step plus the 64bit workarounds made my job here very easy.  big_smile

Offline

#37 2013-05-01 23:28:53

th3pr0ph3t
Member
Registered: 2011-03-02
Posts: 28

Re: Working Netflix in #!

th3pr0ph3t wrote:

I have the black screen problem too.

I have to quote myself to add the fact that I point the finger to the AMD drivers.
netflix-desktop works great with the open source drivers. The open source drivers work better as well when it comes to choosing the right resolution for my TV, which is connected through the HDMI port.

The only problem are the games but everywhere else, the open source drivers included with #! work a lot better.

Offline

#38 2013-05-06 23:07:12

gychang
#! Junkie
From: Phoenix, AZ
Registered: 2009-04-01
Posts: 274

Re: Working Netflix in #!

schwim wrote:

Heya guys and gals!

Install Netflix app:

sudo apt-get install netflix-desktop

Enjoy!

when I get to this step I have the error.
--
apa@HDTV:~$ sudo apt-get install netflix-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
netflix-desktop : Depends: wine-browser-installer but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
apa@HDTV:~$
--

how can I correct this?

thanks,

Offline

#39 2013-05-17 04:19:21

matthias2223
New Member
Registered: 2013-05-17
Posts: 2

Re: Working Netflix in #!

Great job on this tutorial. I had no problem at all getting Netflix running on Waldorf 32-bit. Thanks!

Offline

#40 2013-05-25 01:03:58

gychang
#! Junkie
From: Phoenix, AZ
Registered: 2009-04-01
Posts: 274

Re: Working Netflix in #!

schwim wrote:

Heya guys and gals!

Install Netflix app:

sudo apt-get install netflix-desktop

Enjoy!

I am having difficulty at this step, what now?  On Waldorf 64bit...

---
apa@GX620:~$ sudo apt-get install netflix-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
netflix-desktop : Depends: wine-browser-installer but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
apa@GX620:~$
---

apologize for double posting, having same problem on 2 different machines....

apologiz

Last edited by gychang (2013-05-25 01:05:35)

Offline

#41 2013-05-25 01:07:56

gychang
#! Junkie
From: Phoenix, AZ
Registered: 2009-04-01
Posts: 274

Re: Working Netflix in #!

mosesgunn wrote:

I have installed i386 architecture, but I am still getting this error.  I am running Walforf 64.  I have done everything, added the repo, updated, etc.  What's up?

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 netflix-desktop : Depends: wine-browser-installer but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Oh, I'm also getting a gpg signing error for the compholio ppa.  What's up?

maybe a common problem on Waldorf 64bit, someone on this thread got it working but like u, I am stuck with the same issue.

Offline

#42 2013-05-26 13:09:45

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

Re: Working Netflix in #!

th3pr0ph3t wrote:
th3pr0ph3t wrote:

I have the black screen problem too.

I have to quote myself to add the fact that I point the finger to the AMD drivers.

Well I have the proprietary nvidia drivers and netflix-desktop is now dead for me sad Just getting a black screen with audio like the others.

I am pretty sure it is the latest version of silverlight that has ballsed this up. I would roll back to an earlier version but netflix has the newest one as a requirement.

Anyone have any ideas?

Offline

#43 2013-05-26 19:53:25

mosesgunn
#! CrunchBanger
Registered: 2012-10-20
Posts: 133

Re: Working Netflix in #!

Do we know if this will work with the Jessie repos?

Offline

#44 2013-05-28 13:04:26

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

Re: Working Netflix in #!

cchhrriiss121212 wrote:
th3pr0ph3t wrote:
th3pr0ph3t wrote:

I have the black screen problem too.

I have to quote myself to add the fact that I point the finger to the AMD drivers.

Well I have the proprietary nvidia drivers and netflix-desktop is now dead for me sad Just getting a black screen with audio like the others.

I am pretty sure it is the latest version of silverlight that has ballsed this up. I would roll back to an earlier version but netflix has the newest one as a requirement.

Anyone have any ideas?

Fixed this, just need to delete this directory:
~/.wine-browser

Offline

#45 2013-05-31 12:48:28

FupaLove
New Member
Registered: 2013-05-29
Posts: 1

Re: Working Netflix in #!

Thanks for the post, worked like a charm. Now I have background noise while I fiddle with #!

Offline

#46 2013-06-03 22:24:44

kraete
New Member
Registered: 2013-06-03
Posts: 1

Re: Working Netflix in #!

JLloyd13 wrote:

no problem. I was stuck on this for some time myself. for those wondering how exactly to add an arch to dpkg just type this in a terminal

su -c 'dpkg --add-architecture i386'

multi arch is probably something good to have anyway, although be mindful that it will download a lot of 32-bit libs on first run (if you want to fetch these libs for a different reason the ia32-libs package should pull most needed ones in) 

also farther above in this thread there was someone who said he used the oneiric repos because 64-bit wasn't in the latest ones, that could also work for some people although it didn't for me (I still had to enable i386)


Hey man I just created an account on this forum solely to say thank you.

Offline

#47 2013-06-07 01:28:16

rcardamone
Member
Registered: 2013-01-14
Posts: 10

Re: Working Netflix in #!

nice job op

Offline

#48 2013-06-16 20:06:37

r0n d0n
New Member
From: 'mericuh
Registered: 2012-11-19
Posts: 8

Re: Working Netflix in #!

Thank you so much for this awesome guide! I now have netflix on my laptop, and wouldn't have been able to do it without this thread.

The only thing I had to do that was not mentioned here was add

Section "Extensions"
#       Option      "Composite" "enable"

to my /etc/X11/xorg.conf and it was movie streaming time!


>lurk moar

Offline

#49 2013-06-17 11:34:38

stonix
New Member
Registered: 2013-06-17
Posts: 1

Re: Working Netflix in #!

Thanks so much for this guide, works flawlessly. Loving Crunchang so far!

Offline

Help fund CrunchBang, donate to the project!

#50 2013-06-22 23:19:41

irvc666
New Member
From: San Francisco/Guadalajara
Registered: 2013-01-07
Posts: 4

Re: Working Netflix in #!

To everyone having that "you have held broken packages" error that made me want to throw my laptop, I think I have found a solution!
I remember that this worked on a previous #! installation where I had installed wine long beforehand.
SO I went ahead and installed wine then I ran wine in terminal. A dialog box popped up that told me to run "sudo dpkg --add-architecture i386" then "# apt-get update" followed by "# apt-get install wine-bin:i386". I did all of that and waited for it to install. Then I tried running "# apt-get install netflix-desktop" AND IT WORKS!!!!! big_smile

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo