SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-07-13 02:57:59

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Wireless card not recognized

I have a brand new Dell Latitude E6430 with a Dell Wireless 1540 802.11a/n Dual Band, High Speed Wi-Fi Half Mini-card.  I don't have the option to connect to a wireless network.  It does not appear if the OS recognizes that a wireless card is present.  There appears to be a switch on the side for turning wireless on and off, but switching it back and forth does not seem to do anything.

How do I begin debugging this?

Offline

Be excellent to each other!

#2 2012-07-13 03:20:38

pidsley
Window Mangler
Registered: 2012-05-23
Posts: 1,752

Re: Wireless card not recognized

What version of #! are you using? Make sure the card is turned "on" and reboot, then please post the output of:

uname -r
lspci -knn

Offline

#3 2012-07-13 03:27:39

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Re: Wireless card not recognized

Not sure the version - I just downloaded the most recent 64 bit yesterday.

uname -r
2.6.32-5-amd64

lspci -knn

00:00.0 Host bridge [0600]: Intel Corporation Device [8086:0154] (rev 09)
    Subsystem: Dell Device [1028:0534]
00:01.0 PCI bridge [0604]: Intel Corporation Device [8086:0151] (rev 09)
    Kernel driver in use: pcieport
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:0166] (rev 09)
    Subsystem: Dell Device [1028:0534]
00:14.0 USB Controller [0c03]: Intel Corporation Device [8086:1e31] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: xhci_hcd
00:16.0 Communication controller [0780]: Intel Corporation Device [8086:1e3a] (rev 04)
    Subsystem: Dell Device [1028:0534]
00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: e1000e
00:1a.0 USB Controller [0c03]: Intel Corporation Device [8086:1e2d] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: ehci_hcd
00:1b.0 Audio device [0403]: Intel Corporation Device [8086:1e20] (rev 04)
    Subsystem: Dell Device [1028:0534]
00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:1e10] (rev c4)
    Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation Device [8086:1e12] (rev c4)
    Kernel driver in use: pcieport
00:1c.2 PCI bridge [0604]: Intel Corporation Device [8086:1e14] (rev c4)
    Kernel driver in use: pcieport
00:1c.3 PCI bridge [0604]: Intel Corporation Device [8086:1e16] (rev c4)
    Kernel driver in use: pcieport
00:1c.5 PCI bridge [0604]: Intel Corporation Device [8086:1e1a] (rev c4)
    Kernel driver in use: pcieport
00:1d.0 USB Controller [0c03]: Intel Corporation Device [8086:1e26] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: ehci_hcd
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:1e55] (rev 04)
    Subsystem: Dell Device [1028:0534]
00:1f.2 RAID bus controller [0104]: Intel Corporation Mobile 82801 SATA RAID Controller [8086:282a] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: ahci
00:1f.3 SMBus [0c05]: Intel Corporation Device [8086:1e22] (rev 04)
    Subsystem: Dell Device [1028:0534]
01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0dfc] (rev a1)
    Subsystem: Dell Device [1028:1534]
01:00.1 Audio device [0403]: nVidia Corporation Device [10de:0bea] (rev a1)
    Subsystem: Dell Device [1028:1534]
03:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4359]
    Subsystem: Dell Device [1028:0014]
0c:00.0 SD Host controller [0805]: O2 Micro, Inc. Device [1217:8221] (rev 05)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: sdhci-pci

Last edited by jrenaut (2012-07-13 10:25:13)

Offline

#4 2012-07-13 03:48:14

pidsley
Window Mangler
Registered: 2012-05-23
Posts: 1,752

Re: Wireless card not recognized

Last edited by pidsley (2012-07-13 03:51:46)

Offline

#5 2012-07-13 05:36:55

Ozitraveller
#! Junkie
From: Less is More!
Registered: 2011-04-26
Posts: 289
Website

Re: Wireless card not recognized

03:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4359]
    Subsystem: Dell Device [1028:0014]

PCI: 14E4:4359 Broadcom Corporation BCM43228 802.11a/b/g/n

Offline

#6 2012-07-13 10:43:13

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Re: Wireless card not recognized

Offline

#7 2012-07-13 10:48:57

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless card not recognized

Install kernel headers and everything necessary to compile a kernel module with:

sudo m-a prepare

Offline

#8 2012-07-13 10:57:10

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless card not recognized

You will have to upgrade to wheezy for your wireless card - or install #! Waldorf, which is based on Wheezy.. See the referred to wiki page and search for 4359.

Offline

#9 2012-07-13 18:32:07

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Re: Wireless card not recognized

Offline

#10 2012-07-13 18:43:15

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless card not recognized

That is probably not sufficient.
I suspect you will have to migrate to wheezy (dist-upgrade), or install #! Waldorf.

Offline

#11 2012-07-18 00:39:05

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Re: Wireless card not recognized

Offline

#12 2012-07-18 02:13:30

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Re: Wireless card not recognized

Sorry, I'm a liar.  I can't wait.  I booted back into Windows 7 so I have working wireless and it just makes me sad. 

So, I ran a live session of Waldorf.  I went into the package manager and searched for "broadcom" and installed every package that seemed relevant, then restarted the wireless manager.  The first time I tried it didn't do anything.  The second time the wireless manager never came back up.

Offline

#13 2012-07-18 11:49:51

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless card not recognized

Offline

#14 2012-07-19 00:38:25

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Re: Wireless card not recognized

Kernel is updated.  I installed all the Broadcom drivers I could find.

uname -r
3.2.0-0.bpo.2-amd64
lspci -knn
00:00.0 Host bridge [0600]: Intel Corporation Device [8086:0154] (rev 09)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: agpgart-intel
00:01.0 PCI bridge [0604]: Intel Corporation Device [8086:0151] (rev 09)
    Kernel driver in use: pcieport
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:0166] (rev 09)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: i915
00:14.0 USB Controller [0c03]: Intel Corporation Device [8086:1e31] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: xhci_hcd
00:16.0 Communication controller [0780]: Intel Corporation Device [8086:1e3a] (rev 04)
    Subsystem: Dell Device [1028:0534]
00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: e1000e
00:1a.0 USB Controller [0c03]: Intel Corporation Device [8086:1e2d] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: ehci_hcd
00:1b.0 Audio device [0403]: Intel Corporation Device [8086:1e20] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:1e10] (rev c4)
    Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation Device [8086:1e12] (rev c4)
    Kernel driver in use: pcieport
00:1c.2 PCI bridge [0604]: Intel Corporation Device [8086:1e14] (rev c4)
    Kernel driver in use: pcieport
00:1c.3 PCI bridge [0604]: Intel Corporation Device [8086:1e16] (rev c4)
    Kernel driver in use: pcieport
00:1c.5 PCI bridge [0604]: Intel Corporation Device [8086:1e1a] (rev c4)
    Kernel driver in use: pcieport
00:1d.0 USB Controller [0c03]: Intel Corporation Device [8086:1e26] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: ehci_hcd
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:1e55] (rev 04)
    Subsystem: Dell Device [1028:0534]
00:1f.2 RAID bus controller [0104]: Intel Corporation Mobile 82801 SATA RAID Controller [8086:282a] (rev 04)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: ahci
00:1f.3 SMBus [0c05]: Intel Corporation Device [8086:1e22] (rev 04)
    Subsystem: Dell Device [1028:0534]
01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0dfc] (rev a1)
    Subsystem: Dell Device [1028:1534]
    Kernel driver in use: nouveau
01:00.1 Audio device [0403]: nVidia Corporation Device [10de:0bea] (rev a1)
    Subsystem: Dell Device [1028:1534]
    Kernel driver in use: snd_hda_intel
03:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4359]
    Subsystem: Dell Device [1028:0014]
0c:00.0 SD Host controller [0805]: O2 Micro, Inc. Device [1217:8221] (rev 05)
    Subsystem: Dell Device [1028:0534]
    Kernel driver in use: sdhci-pci

Offline

#15 2012-07-19 00:51:03

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Re: Wireless card not recognized

Looking at the README for the Broadcom 5.100.82.1XX wireless driver, it seems to support Dell cards through 1530.  Mine is 1540.  Am I stuck waiting for an update to the driver?

Offline

#16 2012-07-19 19:59:31

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Wireless card not recognized

Offline

#17 2012-07-19 20:41:59

jrenaut
Member
From: Washington DC
Registered: 2011-02-23
Posts: 15
Website

Re: Wireless card not recognized

I think I'm going to try a clean Waldorf install.  I'm having some partition issues that I haven't tried to troubleshoot yet, so it might not happen until next week.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo