SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2012-03-09 05:04:09

johnraff
nullglob
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 4,148
Website

Re: Black Ivan's Font Task Force

ivanovnegro wrote:

^ Why should fonts have an impact on system performance?

Not system performance, but when you're choosing a font in eg LibreOffice you might have a huge list to scroll through, each of which gets a bit of sample text generated, so having a lot of fonts might slow down your user experience in some cases.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
#! forum moderator    BunsenLabs

Offline

Be excellent to each other!

#27 2012-03-09 13:39:21

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Black Ivan's Font Task Force

^ Ok, also when you use antialiased fonts and smoothing and whatnot it could be a sec slower than without all this stuff. E.g. the menus in Xfce are faster without antialiasing and all the extras.

Offline

#28 2012-03-09 16:55:20

m5
#! CrunchBanger
From: 200 years ago.
Registered: 2011-12-08
Posts: 221

Re: Black Ivan's Font Task Force

thanks.great how-to.
I use proggy font for terminal,
beteckna for desktop use,it`s in squeeze repo.

edit: I forgot droid sans.

Last edited by m5 (2012-03-09 17:05:31)


Keep digging.
Linux beginner.

Offline

#29 2012-03-09 18:42:50

chromium
#! CrunchBanger
Registered: 2009-08-05
Posts: 111

Re: Black Ivan's Font Task Force

Unbelievable, I can really see a difference.

Thank you for the guide ivanovnegro

Offline

#30 2012-03-09 19:58:12

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Black Ivan's Font Task Force

^ You are welcome. Enjoy!

Offline

#31 2012-03-21 19:56:49

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Black Ivan's Font Task Force

Made an edit again. If your Chrome/ium browser looks really odd, take a look.

Offline

#32 2012-03-22 00:59:12

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,207

Re: Black Ivan's Font Task Force

WTF?! ... there's a thread on font configs?
Where were you when I needed this years ago?!! mad tongue

Just thought you should know, Ivan;
Your bold yellow headers will go almost invisible for those who prefer the forum's bright colour scheme.


Point & Squirt

Offline

#33 2012-03-22 15:19:52

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Black Ivan's Font Task Force

@Slobby: Ok, I will change then from yellow to..., I will find a replacement. smile

Offline

#34 2012-04-03 16:11:14

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Black Ivan's Font Task Force

Black Ivan, great guru of the darkest fonts, can I ask you some help?
I already use all the settings that you suggest, but there is one small piece of my system where fonts does not look good...I'm talking about openbox.
Both the menu and the titlebar doesn't seem to respect my settings...Take a look:

tZDh4ZQ

Look at the difference between thunar with good fonts and openbox menu with bad fonts...

Have you a recipe to sort this out?

Thank you very much!

Offline

#35 2012-04-03 16:49:21

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Black Ivan's Font Task Force

^ I can see the difference. The thing is, I do not use Openbox. Not sure what the issue is. I assume you use normal #!?

What settings did you exactly apply, could you post them. Maybe we can troubleshoot it. Seems Openbox does not respect the same setting applied to Thunar. Maybe we have to change something here.

Also let me see what setting we might need specifically for Openbox if at all.

Offline

#36 2012-04-03 20:02:40

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Black Ivan's Font Task Force

First of all thank you very much my friend.

Yes, this is #! with backports activated.
I use the exact same settings that you suggest in the first post, except the part about the bitmap fonts and as far as I know there are not specific settings for Openbox...

Thank you anyway Ivano!!

Offline

#37 2012-04-03 20:26:54

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: Black Ivan's Font Task Force

Miloš, Alt + F2,

obconf

, find it in the Appearance tab

Offline

#38 2012-04-03 20:31:05

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Black Ivan's Font Task Force

mmm after sime searching, it seem that I can find my answers here http://crunchbanglinux.org/forums/topic … ther-apps/ and here http://crunchbanglinux.org/forums/topic … rovements/

Offline

#39 2012-04-03 20:34:04

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Black Ivan's Font Task Force

el_koraco wrote:

Miloš, Alt + F2,

obconf

, find it in the Appearance tab

Hi Korako and thanks for your reply...BTW, with obconf I can set the font but not antialias, etc...

Offline

#40 2012-04-03 20:40:21

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Black Ivan's Font Task Force

@Miloš: The first link is what I meant with Openbox, I wanted to search for it but you were faster.

Seems I have to integrate that workaround into the how-to? Openbox renders fonts differently, hm. hmm

Offline

#41 2012-05-01 19:25:58

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,634
Website

Re: Black Ivan's Font Task Force

Ivan, can you help me on getting my bitmapped fonts to work in Debian? For reasons I will discuss elsewhere if wanted, I have switched to Debian Wheezy. I do want to use the ohsnap font I used in Arch (find it in AUR) but I can not seem to get this going. I have tried lots of things (deleting 70-no-bitmaps.conf for example) and have also added the path to the font to my xorg.conf - but nothing has worked.

I believe I did get terminus to work, but still ohsnap doesn't. I was thinking it might be related to the filetype: all Debian fonts are .pcf.gz, whilst ohsnap is just .pcf.

Can you help me? big_smile


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

I am a #! forum moderator. Feel free to send me a PM with any question you have!

Offline

#42 2012-05-01 20:38:23

gychang
#! Junkie
From: Phoenix, AZ
Registered: 2009-04-01
Posts: 274

Re: Black Ivan's Font Task Force

ivanovnegro wrote:

Edit: Added alternative Chinese fonts.
Edit2: Added source for sharp Windows fonts.
Edit3: (March 8 2012) Link with many fonts in Debian Squeeze.
Edit4: (March 8 2012) Added unifont to the collection
Edit5: (March 9 2012) Added more fonts
Edit6: (March 21 2012) Make it more blurry

We have that covered thousands of times but I will do that again because of the high demand and for all newcomers to the Debian/CrunchBang world.

First of all, how fonts look like for every person differ very strong, some prefer it Ubuntu like, other sharper etc.

This how-to is for people that want to improve the default font rendering without needs of any patches or extra packages.

Of course you can play with many settings and change them to what you like most.
I will only report about what I use personally and what should be common on laptops.


Have fun!

thanks for a nice thread and your effort.  I use CB on 32" LCD, and want to try most of your suggestions, what obvious changes will it be needed since you seemed to have optimized for a laptop.

thanks

gychang

Offline

#43 2012-05-01 20:55:40

2Karl
#! CrunchBanger
Registered: 2012-03-25
Posts: 216
Website

Re: Black Ivan's Font Task Force

Might be worth adding, for those with a CRT monitor,  it's worth setting

Xft.rgba: none
Xft.lcdfilter: lcdnone

In your .Xdefaults, to get some nice rendering.


"It's a pity she won't live... But then who does?" - Gaff.

Offline

#44 2012-05-01 21:02:38

2Karl
#! CrunchBanger
Registered: 2012-03-25
Posts: 216
Website

Re: Black Ivan's Font Task Force

also check this out (It was written for Ubuntu, but it's not distro-specific) http://www.kilobitspersecond.com/2009/0 … nary-tale/


"It's a pity she won't live... But then who does?" - Gaff.

Offline

#45 2012-05-01 21:50:00

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,207

Re: Black Ivan's Font Task Force

Unia wrote:

Ivan, can you help me on getting my bitmapped fonts to work in Debian? For reasons I will discuss elsewhere if wanted, I have switched to Debian Wheezy. I do want to use the ohsnap font I used in Arch (find it in AUR) but I can not seem to get this going. I have tried lots of things (deleting 70-no-bitmaps.conf for example) and have also added the path to the font to my xorg.conf - but nothing has worked.

I believe I did get terminus to work, but still ohsnap doesn't. I was thinking it might be related to the filetype: all Debian fonts are .pcf.gz, whilst ohsnap is just .pcf.

Can you help me? big_smile

I just installed this on my netbook (my only remaining Debian system). Here's what I did:

1. Downloaded font and extracted to ~/.fonts/misc

2. Make sure the same path is listen in my xorg.conf

3. As user, run "mkfontdir .fonts/misc". Then I check with "cat .fonts/misc/fonts.dir" to see if ohsnap is listed.

4. As root (su/sudo), run "dpkg-reconfigure fontconfig"

5. As user, run "fc-cache -fv" Then I repeat the same command as root. Make sure the related folder gets listed.

6. Rehash or restart X.

I now have ohsnap listed (xfontsel) and can also select for GTK apps.

** Steps 4 & 5 are probably unnecessary, but I do them anyway out of habit. Cos Debian's fucked up like that.

*** On thing about Debian (for some incomprehensible reason) when you remove a certain font or change its installed location, make sure you remove it first, refresh the font cache and do dpkg-reconfigure and mkfondir (on all affected directories/folders) first and rehash or restart X. Then put the font in its new location and repeat all the steps.

Also, can I ask why you've moved from Arch to Wheezy? Just point me to a relevant thread/discussion if you can't be bothered to explain.

Last edited by gutterslob (2012-05-01 21:51:45)


Point & Squirt

Offline

#46 2012-05-01 22:01:33

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: Black Ivan's Font Task Force

Small additions:

gutterslob wrote:

3. As user, run "mkfontdir .fonts/misc". Then I check with "cat .fonts/misc/fonts.dir" to see if ohsnap is listed.

4. As root (su/sudo), run "dpkg-reconfigure fontconfig"

3. run mkfontscale in the directory as well. Just to be safe.
4.. I this doesn't work, run dpkg-reconfigure fontconfig-config, and answer Yes to the third question. Then dpkg-reconfigure fontconfig.

Offline

#47 2012-05-01 22:37:45

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,634
Website

Re: Black Ivan's Font Task Force

Thanks both, I can now at least use the font in my terminals. However, it won't work when I put it in the DWM statusbar - DWM won't start. What am I doing wrong? As for the font dir, I used the one suggested by the Debian wiki: /usr/local/share/fonts


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

I am a #! forum moderator. Feel free to send me a PM with any question you have!

Offline

#48 2012-05-01 22:46:00

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: Black Ivan's Font Task Force

What's the line in config.h for the font and does it match xfontsel's properties (maybe you just put the wrong resolution).

Offline

#49 2012-05-01 22:47:32

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,207

Re: Black Ivan's Font Task Force

@Unia
Hmm ... can you get the iso codes from xfonsel?
If so, then you should be able to use em. Just double-check to see if you added them right. Maybe you missed a * or something.

If that doesn't work and you're out of options, do what I mentioned in "***". Meaning you remove the fonts from your /usr/local/share/fonts, do dpkg-reconfigure fontconfig, refresh your fc-cache and then restart X. Then once you've confirmed that no traces of ohsnap are in your system (xfontsel, lxappearance etc), re-add them and follow the steps I listed. For what it's worth, I extracted and copied the fonts themselves, not the ohsnap folder ....meaning to ~/.fonts/misc, not ~./fonts/misc/ohsnap-1.7.xx.

I suppose you could do the same to whatever location listed on your system's font directory list. Check under the <!--- Font directory list ---> in your /etc/fonts/fonts.conf

Sorry, but that's all I know.

Last edited by gutterslob (2012-05-01 22:49:28)


Point & Squirt

Offline

Help fund CrunchBang, donate to the project!

#50 2012-05-01 22:54:18

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,634
Website

Re: Black Ivan's Font Task Force

Yep to both, I double checked by removing the line and copying a new one from xfontsel. I will look into it more tomorrow, going to bed now. Thanks for the help guys!


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

I am a #! forum moderator. Feel free to send me a PM with any question you have!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo