SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-07-31 02:25:03

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Pulseaudio static with line-in? (and other pulseaudio issues)

Hey guys!
First: please don't flame me for using PulseAudio tongue
Next: I've been having random recording issues with PulseAudio for a while now.  Playback is perfectly fine.  When I record from my built-in mic, I have a lot of hiss.  Apparently this can be solved by lowering the recording volume (which I did), but is there another way? (Using the previous method, stuff is way too soft to actually use...).  When I tried recording from line-in, I get a lot of static whenever the mic input is greater than 0 (i.e. whenever something is coming through the mic).  This is coming through a mixer, but we've hooked the mixer up to a set of speakers as well, and that had no static at all.  Any ideas?

Thanks in advance!

- Chaanakya


Check out Musik - an easy-to-use text-to-music converter!
Join SpiderOak using this link and get an extra 1 GB free: https://spideroak.com/download/referral … 660e787ff1

Offline

Be excellent to each other!

#2 2011-07-31 02:51:36

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

Hi Chiraag,

you can try this: in Pulseaudio mixer, for the microphone (Capture), pull up the right slider (little microphone icon), but leave the left slider (little loudspeaker) low.


Sweaty lads picking up the soap | I love the new "Ignore user" button

Offline

#3 2011-08-01 01:30:50

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

Wait...you mean in pavucontrol?


Check out Musik - an easy-to-use text-to-music converter!
Join SpiderOak using this link and get an extra 1 GB free: https://spideroak.com/download/referral … 660e787ff1

Offline

#4 2011-08-01 01:57:08

machinebacon
#! unstable
From: China
Registered: 2009-07-02
Posts: 6,826
Website

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

Oh, I forgot to mention, that's xfce4-mixer. "Sound Card: Capture: Internal Audio Analog Stereo (PulseAudio Mixer)" is the device, the sliders can be unlocked and pushed up and down individually. In pavucontrol they are horizontal, in xfce4-mixer vertical.

It's just an idea/guess. What is the lspci of your card?


Sweaty lads picking up the soap | I love the new "Ignore user" button

Offline

#5 2011-08-01 19:33:16

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

Nope...that didn't do anything.

lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

I'm using the Intel one (the nVidia one is for the HDMI output - not necessary in this case)


Check out Musik - an easy-to-use text-to-music converter!
Join SpiderOak using this link and get an extra 1 GB free: https://spideroak.com/download/referral … 660e787ff1

Offline

#6 2011-08-01 19:46:20

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

When I record with my in-laptop mic, I get a constant hiss...not sure why...


Check out Musik - an easy-to-use text-to-music converter!
Join SpiderOak using this link and get an extra 1 GB free: https://spideroak.com/download/referral … 660e787ff1

Offline

#7 2011-08-12 17:38:26

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

Anyone have any ideas?


Check out Musik - an easy-to-use text-to-music converter!
Join SpiderOak using this link and get an extra 1 GB free: https://spideroak.com/download/referral … 660e787ff1

Offline

#8 2011-08-12 18:20:02

mynis01
#! Die Hard
From: 127.0.0.1
Registered: 2010-07-02
Posts: 2,005

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

chaanakya wrote:

Anyone have any ideas?

Hiss from a mic is generally caused by some kind of issue with the input gain on a hardware device or audio server. I know this isn't exactly the kind of solution you're looking for, but whenever I have a pulse audio related issue, my solution is to uninstall pulse audio and use alsa/jack instead. If I try and use pulse, I'll have issues ranging from pops, clicks, hiss, and lowered bit rates, to audio just not working entirely with certain devices. While an alsa/jack configuration might be a pain for people who just want to watch movies and listen to mp3s, I think you'll find the majority of people using rosegarden/ardour/audacity and doing recording work don't use pulse. Just spend some time in #jack on freenode and you'll hear people raging about how annoying pulse is in no time. What linux really needs is just a gui tool that will properly configure alsa to use certain input/output devices as the defualt and restart the daemon. jack is a godsend for low latency audio recording, and probably the best thing linux has going for it as far as pro audio is concerned. If you are doing recordings on a regular basis, I highly suggest you set it up. There are ways to set up jack to play nice with pulse, but I personally cringe at the idea of having two audio servers running.

Offline

#9 2011-08-12 18:56:48

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

Hmmm...so should I replace Pulse with Jack?  I'll see what I can do lol  Anyone know of a GTK+ front-end for jack?  I know there's qjacktl, but that's QT... sad

Last edited by chaanakya (2011-08-12 18:58:02)


Check out Musik - an easy-to-use text-to-music converter!
Join SpiderOak using this link and get an extra 1 GB free: https://spideroak.com/download/referral … 660e787ff1

Offline

#10 2011-08-12 20:36:01

mynis01
#! Die Hard
From: 127.0.0.1
Registered: 2010-07-02
Posts: 2,005

Re: Pulseaudio static with line-in? (and other pulseaudio issues)

I think you're stuck with qt or terminal. I'm not sure that jack will be the solution to your hiss problem either. Before you make any changes, I would temporarily disable pulse and try just using ALSA and see if that fixes your problem. There's several ways to temporarily disable pulse for trouble shooting, for example, to stop wine from connecting to pulse, you could issue

pasuspender

Killing pulse won't work, since it will just automatically restart. You have to use the command "pulseaudio" with some kind of switch. I don't have pulse installed on any of my machines atm (thank god) so I can't look it up for you but if you just type "pulseaudio --help" it should tell you. I know "pulseaudio -k" restarts the server.

Keep in mind too, jack isn't exactly a drop in replacement for all of the features that pulse audio provides. Not everything that can connect to alsa or pulse can connect to the jack server, usually that requires some kind of plugin. There is a project called libflashsupport-jack that makes the flash plugin route audio to the jack server, so for me, that means I have direct jack connection in my browser, my media player, and all of my DAW software and soft synths, which is more than enough for my usage. jack with it's default configuration has a lot of cpu overhead, since it is made to have as low latency and as high of a sound quality as is possible. IMO this is a good thing, since I don't make a habit of running rtorrent or boinc while I record audio. It can be rough on older laptops running jack and playing 1080p flash video and sending the audio to a jack server.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo