SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-01-02 16:16:29

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

How to: Plymouth with a proprietary graphics driver

So now that Statler installs plymouth by default, people using proprietary drivers will need to do a bit of editing to see the new splash (it is worth it in my opinion).
First find out what resolution your card supports, so reboot and press c when you get the GRUB menu and type vbeinfo to see your available choices.
Now log in and sudo gedit /etc/default/grub. Line 16 should be uncommented and edited with your preferred resolution. Here is mine for example:
GRUB_GFXMODE=1920x1200x32

Now sudo gedit /etc/grub.d/00_header, and under the line "set gfxmode=${GRUB_GFXMODE}", paste this:
set gfxpayload=keep

Then just sudo update-grub and reboot.

Offline

Help fund CrunchBang, donate to the project!

#2 2011-01-02 20:14:49

corenominal
WRONG
From: Lincoln, UK
Registered: 2008-11-20
Posts: 5,131
Website

Re: How to: Plymouth with a proprietary graphics driver

Nice tip, thank you for sharing! smile

Offline

#3 2011-01-03 01:33:47

AwesomeFist
#! Die Hard
Registered: 2011-01-02
Posts: 670
Website

Re: How to: Plymouth with a proprietary graphics driver

Thanks, I was wondering why I didn't see a fading #!.

Offline

#4 2011-01-03 02:35:48

jpope
#! Junkie
From: USA
Registered: 2009-09-20
Posts: 282
Website

Re: How to: Plymouth with a proprietary graphics driver

Thanks for this. Couldn't see the #! on my desktop until I ran through these steps. wink

Offline

#5 2011-01-03 14:54:27

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

Re: How to: Plymouth with a proprietary graphics driver

Glad to hear it is working out. I only tested it on one Nvidia machine so I was not sure whether fglrx would be any different.

Offline

#6 2011-01-03 16:02:05

iann
#! Die Hard
Registered: 2010-09-10
Posts: 720

Re: How to: Plymouth with a proprietary graphics driver

usplash was a real fat dog.  Is Plymouth any better?  Or just as fat, but does more?

Offline

#7 2011-01-04 09:35:38

gutterslob
#! Resident Bum
Registered: 2009-11-03
Posts: 3,207

Re: How to: Plymouth with a proprietary graphics driver

Thanks for this, Chris. smile
I'd already performed the first step, but didn't know I had to edit /etc/grub.d/00_header as well.


Point & Squirt

Offline

#8 2011-01-04 22:55:50

Dave W.
#! CrunchBanger
From: Pennsylvania, USA
Registered: 2010-04-11
Posts: 198

Re: How to: Plymouth with a proprietary graphics driver

Hello everyone,

There is an alternate way of doing this GUI style.  Download "startup manager" from Synaptic. It will allow you to set up boot options like time-out in seconds, default operating system if you multi-boot, resolution, color depth and boot-loader resolution.  I think you will have to reboot once you install it. Then type startupmanager as one long word in the terminal.  It will then ask you for your root password.  After that you can set your options.  BTW I also have a NVIDIA dirver.

Linux Mint had an issue with their Plymouth and this is what one of the Mint Mods recommended.

I must admit though, while this is one way of solving the plymouth thing,  I admire Chris for coming up with his solution. 

Dave


Compaq SR5610F, NVidia 6150SE
HP dv5-2077cl, ATI Radeon HD 4250

Offline

#9 2011-01-05 20:21:10

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

Re: How to: Plymouth with a proprietary graphics driver

^ Yes startup manager is a nice program, but it does not display all the available resolutions. For instance the highest I can select is 1600x1200. Also, the last time I tried to adjust the resolution with it disaster ensued and I had to re-install grub from a live cd. Did you test it with statler?

Startup manager was specifically designed for grub1 and it was great back then. Since grub 2 the developers are still working on getting all the features working again. I hope they get it back up to speed some day.

Offline

#10 2011-01-05 21:28:53

Dave W.
#! CrunchBanger
From: Pennsylvania, USA
Registered: 2010-04-11
Posts: 198

Re: How to: Plymouth with a proprietary graphics driver

Chris,
Yes, I have been using it with Statler, infact I put it in place after the new plymouth, not realizing we had one and it miraculously appeared.   smile  I later found the posts about it.

Yes, the highest I can select is 1600x1200 also.  That happens to work okay for me.  The color depth will only go to 24 bits in start-up manager, while my card is capable of 32.  I guess that I'm missing out on some depth.

I have bookmarked your procedure and next time I update one of my OSs, which will probably be in the next few weeks or so, I will most certainly use it.  I'm slowly learning lots of new things between Statler and antiX.  Thanks once again for your post.

Dave


Compaq SR5610F, NVidia 6150SE
HP dv5-2077cl, ATI Radeon HD 4250

Offline

#11 2011-01-05 22:39:04

Kuno
#! Die Hard
From: Osnabrück - DE
Registered: 2009-01-09
Posts: 674

Re: How to: Plymouth with a proprietary graphics driver

Offline

#12 2011-01-05 23:57:21

aiBo
#! CrunchBanger
Registered: 2010-11-08
Posts: 243

Re: How to: Plymouth with a proprietary graphics driver

Offline

#13 2011-01-06 00:03:34

Dave W.
#! CrunchBanger
From: Pennsylvania, USA
Registered: 2010-04-11
Posts: 198

Re: How to: Plymouth with a proprietary graphics driver

"Groove is in the Heart"


Compaq SR5610F, NVidia 6150SE
HP dv5-2077cl, ATI Radeon HD 4250

Offline

#14 2011-01-06 02:47:18

AwesomeFist
#! Die Hard
Registered: 2011-01-02
Posts: 670
Website

Re: How to: Plymouth with a proprietary graphics driver

Offline

#15 2011-01-06 23:26:51

sagesparrow
#! CrunchBanger
Registered: 2009-08-22
Posts: 145

Re: How to: Plymouth with a proprietary graphics driver

I went with the lowest resolution possible that would still show the fading #!.  At the default 640x480 I got that sliding grayscale thing.  At the higher end of possible resolutions, grub as too small for comfortable reading.  A bit of experimenting and 800x600 gave the right balance of maximum readability and still the fading #!.

Offline

#16 2011-01-10 19:18:22

iniurb
New Member
Registered: 2011-01-10
Posts: 1

Re: How to: Plymouth with a proprietary graphics driver

sad It didn’t work for me on an Asus 1201N . System Bangs and was unable to boot until GRUB repair.

CrunchBang Statler AMD64

Offline

#17 2011-01-31 22:27:08

olembe
#! Junkie
From: Salisbury, England
Registered: 2009-04-29
Posts: 263

Re: How to: Plymouth with a proprietary graphics driver

I have an HP Pavilion DM3 which only really works with the fglrx driver. I tried the steps above and there' s no change to the bootup process at all. I tried using the highest resolution offered (1366x768) and, when that didn't work, I tried 640x480 in case the problem was pushing things too much, but there's just no change at all. The boot process is just text.

Having said that, I've just checked the updated grub.cfg and there's nothing in it about the resolution. For example, cat /boot/grub/grub.cfg | grep 640 returns nothing, but the file's modification time is recent. Is this a sign of a problem? Surely something about the resolution should end up in the grub.cfg file after following these steps?

Offline

#18 2011-01-31 22:45:19

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

Re: How to: Plymouth with a proprietary graphics driver

Offline

#19 2011-01-31 22:58:34

olembe
#! Junkie
From: Salisbury, England
Registered: 2009-04-29
Posts: 263

Re: How to: Plymouth with a proprietary graphics driver

Thanks for the quick reply. Interesting that yours is different. the line GRUB_GFXMODE=640x480 is definitely not commented in my /etc/default/grub and when I run update-grub it definitely recreates grub.cfg. It's very weird, and I'm a bit puzzled!

Offline

#20 2011-02-01 12:26:10

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

Re: How to: Plymouth with a proprietary graphics driver

My grub.cfg shows this on line 39 :

if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=1920x1200x32
  set gfxpayload=keep
  load_video
  insmod gfxterm
fi

Do you have anything like that?

Offline

#21 2011-02-01 12:33:58

olembe
#! Junkie
From: Salisbury, England
Registered: 2009-04-29
Posts: 263

Re: How to: Plymouth with a proprietary graphics driver

No, I don't. It's really weird. Okay, this is DEFINITELY in /etc/defaults/grub

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=640x480

and is, as you can see, uncommented. This is definitely in /etc/grub.d/00_header:

if loadfont `make_system_path_relative_to_its_root "${GRUB_FONT_PATH}"` ; then
  set gfxmode=${GRUB_GFXMODE}
  set gfxpayload=keep
  load_video
  insmod gfxterm
fi

I run sudo update-grub, and here's my complete grub.cfg - you can see the set gfxmode stuff doesn't get in.

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="11"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
}

set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=light-gray/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'CrunchBang Linux, with Linux 2.6.32-5-amd64' --class debian --class gnu-linux --class gnu --class os {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos8)'
    search --no-floppy --fs-uuid --set e109d576-84f1-4c83-996e-e22cb09d164b
    echo    'Loading Linux 2.6.32-5-amd64 ...'
    linux    /boot/vmlinuz-2.6.32-5-amd64 root=UUID=e109d576-84f1-4c83-996e-e22cb09d164b ro  quiet nomodeset radeon.modeset=0 splash
    echo    'Loading initial ramdisk ...'
    initrd    /boot/initrd.img-2.6.32-5-amd64
}
menuentry 'CrunchBang Linux, with Linux 2.6.32-5-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos8)'
    search --no-floppy --fs-uuid --set e109d576-84f1-4c83-996e-e22cb09d164b
    echo    'Loading Linux 2.6.32-5-amd64 ...'
    linux    /boot/vmlinuz-2.6.32-5-amd64 root=UUID=e109d576-84f1-4c83-996e-e22cb09d164b ro single 
    echo    'Loading initial ramdisk ...'
    initrd    /boot/initrd.img-2.6.32-5-amd64
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda1)" {
    insmod part_msdos
    insmod ntfs
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 94da7a03da79e242
    chainloader +1
}
menuentry "Windows Recovery Environment (loader) (on /dev/sda2)" {
    insmod part_msdos
    insmod ntfs
    set root='(hd0,msdos2)'
    search --no-floppy --fs-uuid --set c670d58c70d58419
    drivemap -s (hd0) ${root}
    chainloader +1
}
menuentry "Windows Recovery Environment (loader) (on /dev/sda3)" {
    insmod part_msdos
    insmod ntfs
    set root='(hd0,msdos3)'
    search --no-floppy --fs-uuid --set a6203f96203f6d05
    drivemap -s (hd0) ${root}
    chainloader +1
}
menuentry "Ubuntu, with Linux 2.6.35-24-generic (on /dev/sda5)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set f1df03f7-cbc0-43a7-934d-61933a47d933
    linux /boot/vmlinuz-2.6.35-24-generic root=UUID=f1df03f7-cbc0-43a7-934d-61933a47d933 ro quiet splash
    initrd /boot/initrd.img-2.6.35-24-generic
}
menuentry "Ubuntu, with Linux 2.6.35-24-generic (recovery mode) (on /dev/sda5)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set f1df03f7-cbc0-43a7-934d-61933a47d933
    linux /boot/vmlinuz-2.6.35-24-generic root=UUID=f1df03f7-cbc0-43a7-934d-61933a47d933 ro single
    initrd /boot/initrd.img-2.6.35-24-generic
}
menuentry "Ubuntu, with Linux 2.6.35-23-generic (on /dev/sda5)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set f1df03f7-cbc0-43a7-934d-61933a47d933
    linux /boot/vmlinuz-2.6.35-23-generic root=UUID=f1df03f7-cbc0-43a7-934d-61933a47d933 ro quiet splash
    initrd /boot/initrd.img-2.6.35-23-generic
}
menuentry "Ubuntu, with Linux 2.6.35-23-generic (recovery mode) (on /dev/sda5)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set f1df03f7-cbc0-43a7-934d-61933a47d933
    linux /boot/vmlinuz-2.6.35-23-generic root=UUID=f1df03f7-cbc0-43a7-934d-61933a47d933 ro single
    initrd /boot/initrd.img-2.6.35-23-generic
}
menuentry "Ubuntu, with Linux 2.6.35-22-generic (on /dev/sda5)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set f1df03f7-cbc0-43a7-934d-61933a47d933
    linux /boot/vmlinuz-2.6.35-22-generic root=UUID=f1df03f7-cbc0-43a7-934d-61933a47d933 ro quiet splash
    initrd /boot/initrd.img-2.6.35-22-generic
}
menuentry "Ubuntu, with Linux 2.6.35-22-generic (recovery mode) (on /dev/sda5)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set f1df03f7-cbc0-43a7-934d-61933a47d933
    linux /boot/vmlinuz-2.6.35-22-generic root=UUID=f1df03f7-cbc0-43a7-934d-61933a47d933 ro single
    initrd /boot/initrd.img-2.6.35-22-generic
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Is there something weird going on with my update-grub? I wonder if the problem might be the line:

if loadfont `make_system_path_relative_to_its_root "${GRUB_FONT_PATH}"` ; then

in 00_header - I wonder if that IF statement is returning false for some reason?

Offline

#22 2011-02-01 17:56:24

olembe
#! Junkie
From: Salisbury, England
Registered: 2009-04-29
Posts: 263

Re: How to: Plymouth with a proprietary graphics driver

Okay, so I think I've solved it. Today I booted into my Ubuntu partition and, whilst I was there, did an update. This pulled down a new kernel and, of course, updated grub. When I rebooted into #!, there was Plymouth! So I think the problem lies with sudo update-grub within Crunchbang. For some reason it's not updating grub.

EDIT: I think I've been very stupid. Presumably, as this computer had Ubuntu on it before #!, there is more than one grub.cfg, and the important one is on the Ubuntu partition?

Last edited by olembe (2011-02-01 18:03:52)

Offline

#23 2011-02-01 18:01:20

cchhrriiss121212
#! Junkie
Registered: 2010-03-26
Posts: 357

Re: How to: Plymouth with a proprietary graphics driver

I have a large chunk of text between "function load_video" and "set timeout" that I don't see in your grub.cfg:

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos7)'
search --no-floppy --fs-uuid --set 77fb4506-c1a8-4007-a4ec-7eaa3a56fc7a
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=1920x1200x32
  set gfxpayload=keep
  load_video
  insmod gfxterm
fi
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='(hd0,msdos7)'
search --no-floppy --fs-uuid --set 77fb4506-c1a8-4007-a4ec-7eaa3a56fc7a
set locale_dir=($root)/boot/grub/locale
set lang=en
insmod gettext
set timeout=3

Hopefully that is some help to you, as I don't know what to suggest in order to append this, other than editing grub.cfg.

Edit: glad to see it is working, I think it is because you had GRUB installed to the Ubuntu partition. When running a multiboot Linux system, only one OS has GRUB control, usually this is the one that has been installed most recently.

Last edited by cchhrriiss121212 (2011-02-01 18:04:34)

Offline

#24 2011-04-27 22:42:54

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Re: How to: Plymouth with a proprietary graphics driver

Thank you!  I used to have this without adding the gfxpayload, but after a few updates (I'm running wheezy/sid), it suddenly stopped working, so I had to add it...

Offline

Help fund CrunchBang, donate to the project!

#25 2011-05-19 00:50:48

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: How to: Plymouth with a proprietary graphics driver

I wanted to add my experience to this today...

I followed the original instructions and still had a text load with four images of Tux at the top

I then installed startupmanager and switched from Show Text During Boot to Show Boot Splash and Plymouth worked perfectly...

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo