SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 Re: CrunchBang Talk » How to install GLIBC 2.14 on Crunchbang? » 2015-02-10 07:07:50

I added these sources to my sources.list file to enable testing repos:

# Testing repository - main, contrib and non-free branches
deb http://http.us.debian.org/debian testing main non-free contrib
deb-src http://http.us.debian.org/debian testing main non-free contrib


# Testing security updates repository
deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

I also updated pinning settings:

Package: *
Pin: release a=waldorf
Pin-Priority: 1001

Package: *
Pin: release a=wheezy
Pin-Priority: 500

Package: *
Pin: release a=testing
Pin-Priority: 250

Then I updated apt.

I then installed libc6:

$ apt-cache policy libc6
libc6:
  Installed: 2.19-13
  Candidate: 2.19-13
  Version table:
 *** 2.19-13 0
        250 http://http.us.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
     2.13-38+deb7u7 0
        500 http://security.debian.org/ wheezy/updates/main amd64 Packages
     2.13-38+deb7u6 0
        500 http://http.debian.net/debian/ wheezy/main amd64 Packages
        500 http://http.us.debian.org/debian/ wheezy/main amd64 Packages

$ sudo apt-get install libc6=2.19-13

Unfortunately libc didn't get upgraded properly:

 $ ldd --version
ldd (Debian EGLIBC 2.13-38+deb7u7) 2.13
Copyright (C) 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

Then I tried installing libc6-dev:

$ sudo apt-get install -f libc6-dev=2.19-13
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Depends: libc-dev-bin (= 2.19-13) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I fixed this by installing libc-dev-bin first:

sudo apt-get install -f libc-dev-bin=2.19-13
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  libc-dev-bin
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
Need to get 236 kB of archives.
After this operation, 347 kB of additional disk space will be used.
Get:1 http://http.us.debian.org/debian/ testing/main libc-dev-bin amd64 2.19-13 [236 kB]
Fetched 236 kB in 2s (113 kB/s)        
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "en_AU:en",
	LC_ALL = (unset),
	LANG = "en_AU.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously unselected package libc-dev-bin.
(Reading database ... 103386 files and directories currently installed.)
Unpacking libc-dev-bin (from .../libc-dev-bin_2.19-13_amd64.deb) ...
Processing triggers for man-db ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up libc-dev-bin (2.19-13) ...

And then reinstalling libc6-dev:

$ sudo apt-get install -f libc6-dev=2.19-13
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  linux-libc-dev
Suggested packages:
  glibc-doc
The following NEW packages will be installed:
  libc6-dev linux-libc-dev
0 upgraded, 2 newly installed, 0 to remove and 4 not upgraded.
Need to get 1998 kB/2834 kB of archives.
After this operation, 15.0 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://http.us.debian.org/debian/ testing/main libc6-dev amd64 2.19-13 [1998 kB]
Fetched 1998 kB in 9s (212 kB/s)                                                                                                                        
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "en_AU:en",
	LC_ALL = (unset),
	LANG = "en_AU.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously unselected package linux-libc-dev:amd64.
(Reading database ... 103399 files and directories currently installed.)
Unpacking linux-libc-dev:amd64 (from .../linux-libc-dev_3.2.65-1+deb7u1_amd64.deb) ...
Selecting previously unselected package libc6-dev:amd64.
Unpacking libc6-dev:amd64 (from .../libc6-dev_2.19-13_amd64.deb) ...
Setting up linux-libc-dev:amd64 (3.2.65-1+deb7u1) ...
Setting up libc6-dev:amd64 (2.19-13) ...

But glibc seems to be still the old version:

$ ldd --version
ldd (Debian EGLIBC 2.13-38+deb7u7) 2.13
Copyright (C) 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

I also get this error message now:

manpath: can't set the locale; make sure $LC_* and $LANG are correct

Am I missing something here? Any way to rectify these problems?

Thanks,
Behrang

#2 CrunchBang Talk » How to install GLIBC 2.14 on Crunchbang? » 2015-02-10 06:03:57

behrangsa
Replies: 2

Hi,

I have an app that fails with this message when ran on Crunchbang:

/the/app/name: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /app/dispatcher/bin/httpd)

Is there a way I can install glibc 2.14 to fix this problem?

Thanks.

#3 Re: News & Announcements » The end. » 2015-02-07 05:34:57

So sad sad(

I just switched to CrunchBang a couple of weeks ago at work and can't put into words how happy and satisfied I was with it.

Anyway, best of luck with your future endeavours core nominal smile

#4 Re: CrunchBang Talk » Is there a way to install jq using apt-get? » 2015-02-02 23:56:38

Jesus! Rather than replying to you I reported your comment  :8

Here's my reply:

It is not available on the repositories enabled by default:

sudo apt-get install jq
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package jq

It is available in wheezy-backports, but if I enable that and then run apt-get upgrade in the future, wouldn't it bring possibly non-stable versions of other packages too? (I am an Ubuntu refugee and I have started using Crunchbang/Openbox in hopes of a more stable user experience.)

Thanks,
Behrang

#5 CrunchBang Talk » Is there a way to install jq using apt-get? » 2015-02-02 23:16:11

behrangsa
Replies: 10

Hi,

Is there a way to install jq via apt in CrunchBang?

Thanks in advance.

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo