SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 Feedback & Suggestions » Bunsen Labs » 2015-09-07 07:00:19

Probe34
Replies: 3

I ran the live-cd today and it looks great. It has the same look and ,above all, feel of Crunchbang Linux. Great work, guys. smile

#4 Re: News & Announcements » The end. » 2015-02-15 11:06:52

I realize that I have been a little bit too emotional in this thread. I want to thank you, corenominal, for your hard work and dedication. It was a real pleasure using Crunchbang Linux all this time. I wish you the best.

#5 Re: News & Announcements » The end. » 2015-02-07 13:08:23

No value????????? Every time I wake up each morning I start the computer and bless the universe that Crunchbang runs on my computer. And I get that wonderful feeling of efficiency every time I close my computer with the Windows+X combination. Smooth, silky, and above all, the system is MINE.
I have tried several distros as live-cd on my computer. Slitaz, Manjaro, Xubuntu, Fedora, Arch, Elementary etc. and I stuck to Crunchbang Linux.
My computer is a 486. Yes, that is right. A 486 with 2Gig of memory. And if I had the money, I would definitely buy a better one, but I haven't. But the things that I have been able to do because Crunchbang Linux runs so efficiently on my computer! I have edited SVG-files with Inkscape. I am able to run Blender with it. On a 486!
NO VALUE????????? I consider Crunchbang Linux my distribution and I am pissed!

#7 Help & Support (Crunchbang 11 "Waldorf") » setting wallpaper with terminal » 2014-08-25 12:54:20

Probe34
Replies: 5

The official line is:"  By default backgrounds are handled by Nitrogen, accessed through the menu under Settings –> Choose Wallpaper. Bundled wallpapers are stored in ~/images/wallpapers/shared/backgrounds although you can add your own to ~/images/wallpapers/shared and they will automatically show up in the Nitrogen selection menu."

But can I set my wallpaper with the terminal instead of the Nitrogen-gui? If so, how?

#8 CrunchBang Talk » WattOS compared to Crunchbang Linux » 2014-06-23 06:15:48

Probe34
Replies: 5

I have taken a look at WattOS and my reaction was: WTF! I thought it was Ubuntu-based but then I read:"
The wattOS team is pleased to announce the release of the new version of wattOS - Release 8 - (also known as R8). After 5 years being an Ubuntu based distro, we have made the change to Debian. Specifically Debian Wheezy as the base, with some backports thrown in (for example a newer Kernel), and in a couple of small places a little Jessie where warranted. But for the most part, its Debian Wheezy as a base to build from. "
Can somebody see any difference between the two operating systems apart from the fact that they use slightly different softwarepackages?

#9 Re: CrunchBang Talk » What media player do you use? » 2014-05-24 10:27:09

Mocp for audio
Vlc for video

You have no idea how long I searched in vain for the right audio-player!!!!!!!!!! Fortunately I have moc now.

#10 Re: Tips, Tricks & Scripts » [Retired] HOWTO: Bluetooth » 2014-05-15 08:05:19

I installed blueman and then run blueman-browse seperately. Works like a breeze now.

#13 CrunchBang Talk » Mum tries out CrunchBang Linux 11 (2013) (youtube video) » 2013-06-21 09:42:36

Probe34
Replies: 1

Interesting youtube-video on Crunchbang Linux. Mum is trying out Crunchbang Linux for the first time:

www.youtube.com/watch?v=9SEc3wnO60o

#14 Re: Help & Support (Crunchbang 11 "Waldorf") » Have no internet connectivity » 2013-06-16 08:24:26

More information please. Post the output of:

dmesg | grep eth 
ifconfig -a 

Is the ethernetcard attached? Is your ISP down? Firewall blocking your traffic?

#15 Re: Help & Support (Crunchbang 11 "Waldorf") » SOLVED...error when apt-get upgrade with chrome upgrade » 2013-05-31 14:36:33

Maybe not relevant for this discussion, but i received the message in the browser that google-chrome was not supported for the OS-version that I was using (statler). When the new Debian was released, google apparently stopped supporting google-chrome for the older versions of Debian.

#16 Re: Help & Support (Crunchbang 11 "Waldorf") » [Solved] Close all windows in Thunar doesn't work » 2013-05-31 14:31:34

Something went wrong with the installment, I think. I installed Crunchbang Linux for older PC's (waldorf). That one function didn't work.

Next day, Xorg didn't start. Rebooted again, and it didn't start. I decided to reinstall with Crunchbang Linux for Modern PC's. Now everything works as it should be.

Thanks for your reply.

#17 Help & Support (Crunchbang 11 "Waldorf") » [Solved] Close all windows in Thunar doesn't work » 2013-05-27 16:15:56

Probe34
Replies: 3

The title says it.  "File/Close all windows" doens't work. Neither does the shortcut: SHIFT+CTRL+W.

Btw, I just installed Waldorf.

I tried to find anything about it on the internet but I came back empty.

#18 Help & Support (Crunchbang 11 "Waldorf") » Crunchbang Linux 10 still supported? » 2013-05-20 08:58:05

Probe34
Replies: 3

Is Crunchbang Linux 10 still supported? If so, till when?

#19 Re: Help & Support (Crunchbang 11 "Waldorf") » Installing perlbrew » 2013-04-10 16:25:03

Have done some thinking of myself.  big_smile  Of course it is a bash script.

~/perl5/perlbrew/bin/perlbrew works in the terminal

A soft link to /usr/bin/ should do the trick. But if anyone could find out why the instructions of the program itself doesn't work, I would be much obliged.

#20 Re: Help & Support (Crunchbang 11 "Waldorf") » Installing perlbrew » 2013-04-10 13:25:35

Is the file a bash-script? So,  #!/bin/bash at the beginning? and sudo chmod +x [file] in the terminal afterwards?

#21 Re: Help & Support (Crunchbang 11 "Waldorf") » Installing perlbrew » 2013-04-10 12:52:22

Done: ALT+PRNTSCREEN+K. Opened a terminal. Run perlbrew. None.

#22 Re: Help & Support (Crunchbang 11 "Waldorf") » Installing perlbrew » 2013-04-10 12:37:05

export PERLBREW_BASHRC_VERSION=0.62


__perlbrew_reinit() {
    if [[ ! -d "$PERLBREW_HOME" ]]; then
        mkdir -p "$PERLBREW_HOME"
    fi

    echo '# DO NOT EDIT THIS FILE' > "$PERLBREW_HOME/init"
    command perlbrew env $1 | \grep PERLBREW_ >> "$PERLBREW_HOME/init"
    . "$PERLBREW_HOME/init"
    __perlbrew_set_path
}

__perlbrew_set_path () {
    MANPATH_WITHOUT_PERLBREW=`perl -e 'print join ":", grep { index($_, $ENV{PERLBREW_HOME}) < 0 } grep { index($_, $ENV{PERLBREW_ROOT}) < 0 } split/:/,qx(manpath 2> /dev/null);'`
    if [ -n "$PERLBREW_MANPATH" ]; then
        export MANPATH="$PERLBREW_MANPATH:$MANPATH_WITHOUT_PERLBREW"
    else
        export MANPATH="$MANPATH_WITHOUT_PERLBREW"
    fi
    unset MANPATH_WITHOUT_PERLBREW

    PATH_WITHOUT_PERLBREW=$(eval $perlbrew_command display-pristine-path)
    if [ -n "$PERLBREW_PATH" ]; then
        export PATH=${PERLBREW_PATH}:${PATH_WITHOUT_PERLBREW}
    else
        export PATH=${PERLBREW_ROOT}/bin:${PATH_WITHOUT_PERLBREW}
    fi
    unset PATH_WITHOUT_PERLBREW

    hash -r
}

__perlbrew_set_env() {
    local code="$($perlbrew_command env $@)"
    local exit_status="$?"
    if [[ $exit_status -eq 0 ]] ; then
        eval "$code"
    else
        return $exit_status
    fi
}

__perlbrew_activate() {
    [[ -n $(alias perl 2>/dev/null) ]] && unalias perl 2>/dev/null

    if [[ -n "$PERLBREW_PERL" ]]; then
        if [[ -z "$PERLBREW_LIB" ]]; then
            __perlbrew_set_env $PERLBREW_PERL
        else
            __perlbrew_set_env $PERLBREW_PERL@$PERLBREW_LIB
        fi
    fi

    __perlbrew_set_path
}

__perlbrew_deactivate() {
    __perlbrew_set_env
    unset PERLBREW_PERL
    unset PERLBREW_LIB
    __perlbrew_set_path
}

perlbrew () {
    local exit_status
    local short_option
    export SHELL

    if [[ $1 == -* ]]; then
        short_option=$1
        shift
    else
        short_option=""
    fi

    case $1 in
        (use)
            if [[ -z "$2" ]] ; then
                if [[ -z "$PERLBREW_PERL" ]] ; then
                    echo "Currently using system perl"
                else
                    echo "Currently using $PERLBREW_PERL"
                fi
            else
                __perlbrew_set_env "$2"
                exit_status="$?"
                if [[ $exit_status -eq 0 ]]
                then
                    __perlbrew_set_path
                fi
            fi
            ;;

        (switch)
              if [[ -z "$2" ]] ; then
                  command perlbrew switch
              else
                  perlbrew use $2
                  exit_status=$?
                  if [[ ${exit_status} -eq 0 ]]; then
                      __perlbrew_reinit $2
                  fi
              fi
              ;;

        (off)
            __perlbrew_deactivate
            echo "perlbrew is turned off."
            ;;

        (switch-off)
            __perlbrew_deactivate
            __perlbrew_reinit
            echo "perlbrew is switched off."
            ;;

        (*)
            command perlbrew $short_option "$@"
            exit_status=$?
            ;;
    esac
    hash -r
    return ${exit_status:-0}
}

[[ -z "$PERLBREW_ROOT" ]] && export PERLBREW_ROOT="$HOME/perl5/perlbrew"
[[ -z "$PERLBREW_HOME" ]] && export PERLBREW_HOME="$HOME/.perlbrew"

if [[ ! -n "$PERLBREW_SKIP_INIT" ]]; then
    if [[ -f "$PERLBREW_HOME/init" ]]; then
        . "$PERLBREW_HOME/init"
    fi
fi

perlbrew_bin_path="${PERLBREW_ROOT}/bin"
if [[ -f $perlbrew_bin_path/perlbrew ]]; then
    perlbrew_command="$perlbrew_bin_path/perlbrew"
else
    perlbrew_command="command perlbrew"
fi
unset perlbrew_bin_path

__perlbrew_activate

#23 Re: Help & Support (Crunchbang 11 "Waldorf") » Installing perlbrew » 2013-04-10 12:24:52

I logged out and logged in. Opened terminal:

ecmporter@peek:~$ perlbrew
bash: perlbrew: command not found

#24 Re: Help & Support (Crunchbang 11 "Waldorf") » Installing perlbrew » 2013-04-10 12:12:18

I did. Added:
source ~/perl5/perlbrew/etc/bashrc to it.
Then I ran perlbrew.

ecmporter@peek:~$ perlbrew
bash: perlbrew: command not found

And it failed.

#25 Help & Support (Crunchbang 11 "Waldorf") » Installing perlbrew » 2013-04-10 11:58:22

Probe34
Replies: 10

Trying to gain some insight in Perl, I installed perlbrew. That worked but look at the message during installation:

## Download the latest perlbrew

## Installing perlbrew
perlbrew is installed: ~/perl5/perlbrew/bin/perlbrew

perlbrew root (~/perl5/perlbrew) is initialized.

Append the following piece of code to the end of your ~/.bash_profile and start a
new shell, perlbrew should be up and fully functional from there:

    source ~/perl5/perlbrew/etc/bashrc

Simply run `perlbrew` for usage details.

Happy brewing!

## Installing patchperl

## Done.

So, I open thunar/hidden files, but the file ~/.bash_profile isn't there. Should it be there? Must I make a new file?

The only bash_profile that can be found on my system is:
/usr/share/doc/adduser/examples/adduser.local.conf.examples/skel/dot.bash_profile

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo