SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 Re: Off Topic / General Chat » Vsido Linux Registration » 2013-12-29 18:18:43

@fairoaks: The answer to that one requires a word (for example: 2 + 3 = five), instead of a number.  Please give it another shot.  Promise you won't regret the effort.   8o

#2 Re: Feedback & Suggestions » firefox mobile » 2013-12-27 05:09:31

You can use the Mobile Firefox extension named Phony to set your user agent to "Android mobile", then this site should work fine.

There was some discussion of the issue in this thread.

#4 Re: Help & Support (Crunchbang 11 "Waldorf") » [SOLVED]Fsarchiver trouble » 2013-12-03 02:44:22

Sounds like "/dev/sda1" is your live running system.  It further appears that you are running fsarchiver on the live system "/dev/sda1" to backup the live system "/dev/sda1".  The result, if you use the "-A" option, will be a "dirty" backup.  In other words, the data will be changing as you are backing it up.

If that does not trouble you, then usage of the "-A" option would be like this:

sudo fsarchiver savefs -A '/media/New Volume/crunchbang-rootfs.fsa' /dev/sda1

A much safer way to accomplish your backup would be to use a live cd and run fsarchiver from the live session, thus leaving "/dev/sda1" in read-only status.  I believe SystemRescueCd currently includes fsarchiver, so that would be one possible choice for the task.

Ultimately it is your system and your choice.  If you don't have anything else running while fsarchiver is running, then chances are you will do no harm. 

*The usual disclaimers apply.  If you bork your system, it's all on you.   ]:D

#5 Re: Off Topic / General Chat » Hw do u extract a string or a whole line from a webpage from terminal? » 2013-11-30 06:32:17

Or...

If you don't already have lynx installed, install it by your preferred method and execute the following.

[tlinsley@localhost ~]$ lynx -dump liquorix.net | grep "apt-get install"
apt-get install '^liquorix-([^-]+-)?keyring.?'
[tlinsley@localhost ~]$ 

Profit!!!

#7 Re: Feedback & Suggestions » [Req Desktop Sitely-solved]Website not opening in Firefox for Android » 2013-11-20 03:55:08

@ anonymous: I believe the issue is that the Crunchbang website is parsing for an obsolete user agent string format.  Apparently Mozilla changed the format a few releases ago.

Here are some links to support my supposition:

Bug #1179596

Bug 729348

Bug 595669

Upcoming UA String Change

Final User Agent String for Firefox 4

#8 Re: Feedback & Suggestions » [Req Desktop Sitely-solved]Website not opening in Firefox for Android » 2013-11-12 03:48:13

Firefox on my SGS3 started doing this a few days ago.   Looks like the issue is related to user agent string. Installed a Firefox mobile extension named Phony, set user agent to Android mobile, and the site now works perfectly.

#10 Re: Off Topic / General Chat » There Is a Way to Have a Stable System and Have Up-to-Date Apps » 2013-11-10 05:04:19

The "static portable" builds seem nice at first glance.  But once you start down that road, you soon end up with multiple versions of the same libraries installed in multiple places.  And before long, some programs start accessing the wrong version of their intended libraries with unpredictable results.  At that point, you have to slap an M$ label on and call it Windows!

#11 Re: Off Topic / General Chat » Thank You tlinsley » 2013-10-31 17:59:51

@KrunchTime - Glad you found it useful.  And I agree that it is not an optimal solution, but did seem to meet some of the criteria sought by OP in that other thread.

@machinebacon - Yeah it does have a few more dependencies than some folks desire.  I use it anyway (mostly for passwords) because there is no way I could ever keep up with all my server passwords otherwise (170+ servers all with conflicting password requirements).  And the auto-type appeals to my lazy side.  8o

#12 Re: Off Topic / General Chat » Solved: Migrate password manager » 2013-10-24 04:11:27

+1 for KeepassX

If Gorilla can export to xml, then you should be able to import into KeepassX.

#13 Re: News & Announcements » DDoS Attack 2013-10-17 (resolved) » 2013-10-21 03:21:49

I have theory as to whom has perpetrated this chronic DDoS attack...

I believe it is the revenge of someone who has suffered the horrible agony of Slim eating their music.   ]:D

#14 Re: Help & Support (Crunchbang 11 "Waldorf") » Geany settings not saving after moving installation to new machine. » 2013-10-19 04:15:50

You mentioned earlier that you re-installed Geany, but did you "sudo apt-get remove –purge geany"?  Or just "apt-get remove geany"?

If the latter, you are still using the same config files, which may be experiencing permission/uid issues.  To rule out those issues, try the following:

mv ~/.config/geany/ /.config/geany_original/
sudo apt-get update
sudo apt-get remove –purge geany
sudo apt-get install geany

Now open Geany, go to "Edit > Preferences > General > Startup", and ensure that "Load files from the last session" is checked.  Now open two or three files.  Shut down Geany, then restart Geany.  If Geany opened the previously opened files, then your immediate issue is solved.  But it also means you may have other permission/uid issues lurking around.

From what I understand, jerking a hard drive from one system and plugging it into unlike hardware can result in driver issues.  Often if it goes wrong, you won't be able to boot due to fstab/grub issues.  Sounds like you were able to boot, but are experiencing harder to diagnose owner/permission/guid/uid type issues.  But without laying hands on the system, I may be entirely off base and full of it.  Wish I could help more.

Good luck with it.  smile

#15 Re: Off Topic / General Chat » rsync not working » 2013-10-05 04:51:06

@rmcellig - Don't know if you're still watching this thread.  Took a few days off, so just now catching up.

Assuming you made the requested permissions changes, then only other thing that would prevent password-less authentication is configuration options.  Specifically we need to ensure you have "RSAAuthentication" and "PubkeyAuthentication" set to "yes" in "/etc/ssh/sshd_config" on the target machine (randy@192.168.2.16).

Login to "randy@192.168.2.16" and run the following command to check the relevant options.

sudo egrep "(RSAAuthentication|PubkeyAuthentication)" /etc/ssh/sshd_config 

If the "RSAAuthentication" and/or "PubkeyAuthentication" options are commented, i.e. preceded by "#", then run the following command to un-comment them.  This command takes a backup of the file before altering it.

sudo sed -i\.bak "s/^\(^[#]*\)\(#\)\( \{0,\}\(RSAAuthentication\|PubkeyAuthentication\) \{0,\}yes.*\)$/\1 \3/" /etc/ssh/sshd_config 

Now login to the source machine "randy@crunchbang" and ensure the proper option is enabled there also.  Note since this is the client configuration file, the name is slightly different and there is no "PubkeyAuthentication" option to check.

sudo egrep "RSAAuthentication" /etc/ssh/ssh_config 

If the "RSAAuthentication" option is commented, i.e. preceded by "#", then run the following command to un-comment it.  This command takes a backup of the file before altering it.

sudo sed -i\.bak "s/^\(^[#]*\)\(#\)\( \{0,\}\(RSAAuthentication\|PubkeyAuthentication\) \{0,\}yes.*\)$/\1 \3/" /etc/ssh/ssh_config 

Now that the relevant options are set correctly, make a test connection.  Login to the source machine "randy@crunchbang" and run the following command.

ssh -v randy@192.168.2.16

If the above command connects to the target machine without asking for password, congratulate yourself on a job well done.  cool

Otherwise post the command output and we can troubleshoot it further.



Recovery commands

Should you need to restore the original sshd configuration file on target machine, simply login to "randy@192.168.2.16" and run the following command.

sudo mv /etc/ssh/sshd_config.bak /etc/ssh/sshd_config

Should you need to restore the original ssh client configuration file on the source machine, simply login to "randy@crunchbang" and run the following command.

sudo mv /etc/ssh/ssh_config.bak /etc/ssh/ssh_config

#16 Re: CrunchBang Talk » Quality Linux / Debian blogs? » 2013-10-01 05:08:39

@bkerensa - Thanks for the links in your blog post.  Will definitely check them out.

#17 Re: Off Topic / General Chat » rsync not working » 2013-10-01 05:05:13

Lol.  petabyte sized thumb drive + usb 3.0 = very loooong coffee break

Sounds like you're making progress.  That's good news!

Most likely cause of the continued password requests is permissions.

Try the following on the source machine (randy@crunchbang):

chmod go-w ~/
chmod 700 ~/.ssh
chmod 644 ~/.ssh/authorized_keys
chmod 600 ~/.ssh/identity
chmod 644 ~/.ssh/identity.pub
chmod 600 ~/.ssh/known_hosts

Then execute the same set of commands on the target machine (randy@192.168.2.16).

Afterwards, go back to the source machine (randy@crunchbang) and execute:

ssh -vv randy@192.168.2.16

If the above command connects without requesting password, then you are good to go.
Otherwise, post the output and we should be able to see what is going awry.

Good luck...

#18 Re: Off Topic / General Chat » rsync not working » 2013-09-30 04:58:13

rmcellig wrote:

I have well over 5000 LP's to digitize ...

Wow.  You actually have a bigger music collection than my son-in-law.  Lol.  Certainly rules out the thumb drive option. wink

The "authenticity of host can't be established" message is normal upon first time connection to a new host.  Answering yes tells ssh you trust that host and it is added to your known hosts file.  After that one time, you should not get that message again for that host.

Are you receiving any error messages when running the rsync command?  If not, change the "-avz" to "-avvz".  That will crank up the verbosity and give us more clue.  Hmm and just to simplify testing, lose that "--delete". 

So to summarize, try this command:

rsync --progress -avvz -e ssh /home/randy/test/ randy@192.168.2.16:/home/randy/test2

I'll try to check for your response before leaving the office tomorrow and see what you got back.

For now, it's off to slumberland and hopefully the "bat phone" does not wake me up.  8o

#19 Re: Off Topic / General Chat » Comic Strip » 2013-09-29 04:30:19

Whew!  I was sure it was gonna be a pony...  You know what those do to codingman.  8.(

And to stay on topic, here's a comic....Userfriendly

#20 Re: Off Topic / General Chat » rsync not working » 2013-09-29 03:22:54

Ahh, I see.  Sounds like a fun project.  And you are very wise to take backup.  One of the first Sr. Systems Engineers I worked under drilled into me the old "You can never have too many backups." adage.  Saved my bacon many times.

You didn't mention details, but if your collection won't be too large it would be simpler to backup on thumb drive and do the sneaker net thing.  Or backup to an external drive.

But if you want to rsync to that other machine, it is pretty easy to setup ssh.  Hit google with "debian install ssh" and you will find hundreds of tutorials.

Or for the "nutshell version":

  • On the target machine, start a terminal and execute the following:

apt-get install openssh-server
  • The above installs and configures sshd for you.  The default configuration should be fine for your stated purpose, as long as both machines are within your home network.  Can't remember if it starts sshd for you that first time, if not just reboot.

  • Then on your source machine, you need ssh client.  If not already installed, execute the following via terminal:

apt-get install openssh-client
  • The above installs and configures ssh client for you.  The default configuration should be fine for your stated purpose, as long as both machines are within your home network.  Can't remember if it starts ssh client for you that first time, if not just reboot.

  • Now all you need to do is generate your ssh key pair on the source machine.  Do that with the following command:

ssh-keygen -t rsa
  • The above generates a pair of private/public keys in the directory ~/.ssh. The program first asks for the destination files for the keys, by default located in ~/.ssh (press enter for the default location). Afterwards a passphrase is requested.  For your stated purpose, I reccommend leaving the passphrase empty.

  • Now we copy your brand spanking new public key to your target machine.  Execute following from your source machine:

ssh-copy-id -i ~/.ssh/id_rsa.pub randy@192.168.2.16
  • The above will copy the public key to your target machine and set the proper file permissions.   It will ask for your "randy@192.168.2.16" password this first time.  On future connections it will authenticate via the key pair without needing the password.


Now you are all set and the rsync command I gave you should work.  Or if you don't like cli, you can follow the other poster's suggestion and use one of the gui rsync tools now that ssh is set up.

Hope that helps and have fun digitizing...

#21 Re: Off Topic / General Chat » rsync not working » 2013-09-28 15:35:42

Rsh is the other choice.  But that is not very (if at all) secure.  I wouldn't recommend using using rsh unless you are really not concerned about the data.  Should you choose to use it, just change the "-e ssh" to "-e rsh".  And it will require a properly configured rshd running on the target machine.

#22 Re: CrunchBang Talk » Quality Linux / Debian blogs? » 2013-09-28 03:53:25

@mbemboom - You are very welcome!  Glad you found them interesting/useful.

@joek - Thank you for that one.  I seem to recall arriving there a few times via long forgotten googling, but apparently neglected to bookmark.  Chronic CRS syndrome I guess.  roll

#23 Re: Off Topic / General Chat » rsync not working » 2013-09-28 03:42:21

Your non-working example looks syntactically correct.  The destination syntax in your non-working example implies ssh usage, since you did not specify "-e rsh".  For it to work, there must be a properly configured sshd running at the destination.  Lack of said sshd is the only thing I see that would break it, assuming the ip address is correct as you stated.

I would typically code it as follows:

rsync --progress --delete -avz -e ssh /home/randy/test/ randy@192.168.2.16:/home/randy/test2

Notes:

  • The "-e ssh" explicitly tells rsync to use ssh for remote connections intead of the insecure rsh.  Implies a properly configured sshd is running at the destination.

  • I added the "-z" option to tell rsync to use compression during transfer.  Speeds things up, especially for large files.

  • I used "-a" (archive mode) instead of your "-r -t -p -o -g -s".  Per man page, "-a = -rlptgoD".  Saves you some typing right? wink

Hope this helps!

#25 Re: Off Topic / General Chat » Very basic question about scrolling through a terminal » 2013-09-16 03:02:45

Or....

du | less

...then use "!" sub-command for your rm'ing.  Woohoo new verb!

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo