SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2010-09-26 17:50:02

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

[Resolved. Mostly.] Horizontal scrolling will not auto start.

I cannot get horizontal scrolling to remain enabled after a shutdown/reboot. I have to run

synclient HorizEdgeScroll=1

every time I log in. I've added it to my autostart.sh but no dice.

## Detect and configure touchpad. See 'man synclient' for more info.
if egrep -iq 'touchpad' /proc/bus/input/devices; then
    synclient VertEdgeScroll=1 &
    [b]synclient HorizEdgeScroll=1 &[/b]
    synclient TapButton1=1 &
fi

I've also tried synclient HorizEdgeScroll=1 --restore & and a few other variations that I don't recall off hand. Any thoughts?

Last edited by warfacegod (2010-10-11 00:10:01)


Destroying the Earth one electron at a time.

Offline

Be excellent to each other!

#2 2010-09-27 23:17:43

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

Bump?


Destroying the Earth one electron at a time.

Offline

#3 2010-09-30 17:37:13

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

Upsidaisy.


Destroying the Earth one electron at a time.

Offline

#4 2010-10-04 00:43:59

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

I'm talking to the wind.


Destroying the Earth one electron at a time.

Offline

#5 2010-10-04 01:25:41

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,371

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

Have you tried without putting it in an if statement? What if you run it using a terminal like

terminator -x "synclient HorizEdgeScroll=1" &

Offline

#6 2010-10-04 10:37:20

nogg321
Member
From: Birmingham UK
Registered: 2009-09-06
Posts: 35

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

Many thanks for this info.
My trusty old HP NC6000 with Statler2 had vertical scrolling enabled out the box with the synaptics driver.
I tried using horizontal scrolling and it didn't work, so I assumed the mousepad wouldn't cope with it.
I thought I would give the command  "synclient HorizEdgeScroll=1" from above a try and lo and behold, it works!
So I have stuck it in my .bashrc now and am a happy bunny.

Just goes to show - there is more to discover when you think you have found it all.

(P.S. I put Statler2 on a newer HP DV2500 and the mousepad was atrocious)

regards Nigel


Linux - It's not rocket surgery, after all!
web - nigelhoward.site90.com
skype - nogg321

Offline

#7 2010-10-04 23:14:39

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

anonymous wrote:

Have you tried without putting it in an if statement? What if you run it using a terminal like

terminator -x "synclient HorizEdgeScroll=1" &

Command not found.



Nigel, have you rebooted and had Horizontal Scrolling remain on? If so, what exactly did you do?


Destroying the Earth one electron at a time.

Offline

#8 2010-10-07 12:03:52

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

Bra BUMP bump bump


Destroying the Earth one electron at a time.

Offline

#9 2010-10-07 14:49:24

nogg321
Member
From: Birmingham UK
Registered: 2009-09-06
Posts: 35

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

warfacegod(!?)
I always open a terminal when I log on so I put the line in .bashrc.
If you don't use a terminal very often, you could try putting it in /etc/profile or
in /etc/rc.local (before last line)

as long as it is run before you start firefox, or whatever needs it it will work.
(providing your hardware has the capability)

regards Nigel


Linux - It's not rocket surgery, after all!
web - nigelhoward.site90.com
skype - nogg321

Offline

#10 2010-10-08 00:47:50

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

Thanks for replying. What line exactly do I need to put in my bashrc? I assume that's bash.bashrc that I found with catfish. Sorry, utter noob when it comes to things like modifying text files like this.

Last edited by warfacegod (2010-10-08 00:48:17)


Destroying the Earth one electron at a time.

Offline

#11 2010-10-11 00:08:29

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

I fixed it. Sort of. Okay, so it's more of a work around than a fix but at this point, I don't care. I got sick of having to start a Terminal and enter:

synclient HorizEdgeScroll=1

every time I started my laptop. I had the idea (finally) of making a switch for it in my Openbox menu. Like this:

terminator --command="synclient HorizEdgeScroll=1"

I was fulling expecting to need to close the terminal afterward but, as it turns out, it closes itself immediately. Well the switch worked so I figured, what the hell, I should put it in my autostart.sh and see what happens. It works that way too. The Terminal flashes for a split second but I can deal with that. I may try setting the terminal --geometry to 1X1 and see if that works.


Destroying the Earth one electron at a time.

Offline

#12 2010-10-11 08:41:50

nogg321
Member
From: Birmingham UK
Registered: 2009-09-06
Posts: 35

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

Glad you fixed it (most solutions are little 'fixes' that suit you at the time).
It also helps you learn stuff along the way!

regards


Linux - It's not rocket surgery, after all!
web - nigelhoward.site90.com
skype - nogg321

Offline

#13 2010-10-11 15:05:22

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

Thanks.



Setting the --geometry 1x1 works to get rid of the quick flash of terminal on startup.


Destroying the Earth one electron at a time.

Offline

#14 2010-12-05 16:51:03

warfacegod
Member
Registered: 2010-09-24
Posts: 38
Website

Re: [Resolved. Mostly.] Horizontal scrolling will not auto start.

I'll give that a try once I own a working laptop again. Thanks.


Destroying the Earth one electron at a time.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo