SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2008-12-04 03:51:09

NWAdawg
Bob Da Dawg!
From: Arkansas US
Registered: 2008-11-27
Posts: 192
Website

Menu applet problem

I installed the menu applet. When I tried to logout and a get a "Failed to execute child process "lxsession-logout" (No such file or directory)" error. The rest of the menus works fine. Where did look and how do I fix this?


-Bob- 
Ubuntu User #24005, Linux User #480025
identi.ca  friendfeed  facebook

Offline

Help fund CrunchBang, donate to the project!

#2 2008-12-04 04:27:32

corenominal
WRONG
From: Lincoln, UK
Registered: 2008-11-20
Posts: 5,037
Website

Re: Menu applet problem

Hi NWAdawg

lxsession is not installed by default, so I have been thinking about the most elegant way to overcome this. If I was facing this issue myself, I am not, but I can imagine, I would create a new symbolic link in my personal bin directory named "lxsession-logout" and have it pointed to the existing openbox-logout script/command.

A personal bin directory should have been created by default, if you have deleted it, you will need to recreate it and restart your session. Next, enter the following command to create the symbolic link:

ln -s /usr/bin/openbox-logout ~/bin/lxsession-logout

Any call to lxsession-logout should now invoke the default openbox-logout script/command.

Hope this helps smile

Note: If you do not want a personal bin directory, you could always create the link directly in the /usr/bin directory:

sudo ln -s /usr/bin/openbox-logout /usr/bin/lxsession-logout

Offline

#3 2008-12-04 04:53:29

omns
#! wanderer
From: ~/
Registered: 2008-11-25
Posts: 5,131

Re: Menu applet problem

This is a great tip, thank you big_smile This should be a Howto in the tips and tricks section smile

Edit: created here http://crunchbanglinux.org/forums/post/896/#p896

Offline

#4 2008-12-04 13:58:58

NWAdawg
Bob Da Dawg!
From: Arkansas US
Registered: 2008-11-27
Posts: 192
Website

Re: Menu applet problem

Hope this helps

Note: If you do not want a personal bin directory, you could always create the link directly in the /usr/bin directory
sudo ln -s /usr/bin/openbox-logout /usr/bin/lxsession-logout

thanks corenominal


-Bob- 
Ubuntu User #24005, Linux User #480025
identi.ca  friendfeed  facebook

Offline

#5 2008-12-10 19:46:06

razienwolf
#! CrunchBanger
From: SP, Brasil
Registered: 2008-12-01
Posts: 115

Re: Menu applet problem

I could be wrong - Im not on crunch right now -

But doesnt lxpanel comes with a menu to change the default file manager, terminal, and logout dialog??
Im pretty sure that I saw this on the preference panel.

Offline

#6 2008-12-12 22:41:33

Jake108
Member
From: Pontiac, MI
Registered: 2008-12-11
Posts: 46

Re: Menu applet problem

razienwolf is right, under the "Advanced" tab in lxpanel's preferences you just need to make sure that your "Logout Command" is set to /usr/bin/openbox-logout

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo