SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2010-08-24 05:49:13

Chriswaterguy
#! CrunchBanger
From: Jakarta, or somewhere else
Registered: 2009-03-17
Posts: 198
Website

SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)

ISSUE: After installing LXDE in CrunchBang Statler Openbox (alpha 2), an LXDE session starts up okay (other than some missing icons on the left of the panel). However,  login to standard #! (Openbox session) goes like this:

I get a flash of the LXDE wallpaper, then back to the login (gdm) screen. The second time I login, I see the #! screen, which is then covered over by the LXDE wallpaper and lxpanel. If I kill lxpanel, I see tint2 underneath. Key #! features remain - Openbox menu and dmenu still work, and conky still displays in a black box over the LXDE wallpaper.


POSSIBLE SOLUTION?: If I comment out lxsession in autostart.sh, then #! (Openbox session) starts normally. Which makes me wonder - why is lxsession in the default autostart.sh for #!?

Update: Commenting it out is a good solution, and may even save some RAM in regular CrunchBang installs as well. See Andreas' link below, and my final post.

Last edited by Chriswaterguy (2010-08-25 16:09:11)


Learning Linux slowly because I'm busy with Appropedia

Offline

Help fund CrunchBang, donate to the project!

#2 2010-08-24 08:19:42

Andreas
#! Junkie
Registered: 2010-01-26
Posts: 277

Re: SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)


Meh. Interested for a Dropbox alternative? Go to https://launchpad.net/tart

Offline

#3 2010-08-24 08:56:54

Chriswaterguy
#! CrunchBanger
From: Jakarta, or somewhere else
Registered: 2009-03-17
Posts: 198
Website

Re: SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)

Oops, sorry, didn't search for that one before posting. Thanks for the link.

So, lxsession would be nice, but no great loss... If there's a way to set lxsession separately for an Openbox session and an LXDE session, that would be good, but it's not a priority.

Also interesting - #! used to use lxsession-lite, but it looks like the bugs in lxsession might have been worked out, because lxsession-lite hasn't been updated since May 2009.


Learning Linux slowly because I'm busy with Appropedia

Offline

#4 2010-08-24 15:05:36

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,418

Re: SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)

#! 9.04 was based on Ubuntu Jaunty and lxsession is not in the repos though lxsession-lite is. With Debian, lxsession is available and lxsession-lite is just a virtual package for lxsession.

Offline

#5 2010-08-24 17:12:10

johnraff
#!Drunkard
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 2,866
Website

Re: SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)

This continues to be a puzzle to me. Even with lxsession in autostart.sh I've been unable to find any processes running with any name containing "lx". Moreover, looking at what documentation I've been able to find, it seems lxsession needs some config files to define a session in order to do anything. (In the  /etc/xdg/lxsession/ directory.) Those files are missing in #! as far as I can tell so I'm at a loss what function lxsession is expected to  perform. If you install lxde however, lxsession gets its files so having it in #!'s autostart.sh might  bring some unwanted lxde stuff into #! I guess, though I thought it was supposed to be called with some "desktop" name or other...


John
--------------------
( a boring Japan blog , idle twitterings  and GitStuff )
#! forum moderator

Offline

#6 2010-08-25 04:33:39

oupsemma
#! Junkie
From: Cumbria / UK
Registered: 2008-12-06
Posts: 316

Re: SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)

A few hints are given on the LXDE wiki (lxde-lite seems to be the non-buggy session):
http://wiki.lxde.org/en/LXSession
http://wiki.lxde.org/en/LXSession_Edit

Openbox works well without any lxsession; may be LXDE is more geared towards users who want to have icons, eye-candy and to be able to change their settings graphically.
Moreover, the  lxappearance-openbox integration seems to be ok now, with a GUI to configure Openbox:
http://blog.lxde.org/?p=788

Last edited by oupsemma (2010-08-25 04:34:01)


#Linux user 482038, eeepc 901 with #!, freed 901Go with Trisquel & gNewSense,
901 with Manjaro & ArchBang

Offline

#7 2010-08-25 12:19:47

johnraff
#!Drunkard
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 2,866
Website

Re: SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)

On Statler try running 'lxsession' in a terminal. It will come back to the prompt, with no output about what happened. Then try running 'lxsession-logout' which should bring up a logout window. You'll get the message "Error: LXSession is not running." I think this must be because lxsession needs certain files to be installed in order to run. As it is, my feeling is that it should just be removed from the Statler setup.


John
--------------------
( a boring Japan blog , idle twitterings  and GitStuff )
#! forum moderator

Offline

#8 2010-08-25 16:06:18

Chriswaterguy
#! CrunchBanger
From: Jakarta, or somewhere else
Registered: 2009-03-17
Posts: 198
Website

Re: SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)

Re lxsession-lite... it turns out that's just an older name for the same package (due to a temporary fork in development, I think).

anonymous wrote:

#! 9.04 was based on Ubuntu Jaunty and lxsession is not in the repos though lxsession-lite is. With Debian, lxsession is available and lxsession-lite is just a virtual package for lxsession.

oupsemma wrote:

A few hints are given on the LXDE wiki (lxde-lite seems to be the non-buggy session):
http://wiki.lxde.org/en/LXSession
http://wiki.lxde.org/en/LXSession_Edit

I asked on the LXDE developer list. Their wiki was out of date, but I've updated it now... A developer replied: "The current release of lxsession is 0.4.4.  It would be more correct to say that LXSession Lite was renamed LXSession beginning at 0.3.8.  No support for X session management is provided."


Btw, the SOLUTION to the original question, re what LXSession actually does in #!, it's pretty minor, and it's definitely okay to comment it out in autostart.sh: The post in which corenominal explains a bit what lxsession does (h/t Andreas.)

johnraff wrote:

On Statler try running 'lxsession' in a terminal. It will come back to the prompt, with no output about what happened. Then try running 'lxsession-logout' which should bring up a logout window. You'll get the message "Error: LXSession is not running." I think this must be because lxsession needs certain files to be installed in order to run. As it is, my feeling is that it should just be removed from the Statler setup.

As I've installed LXDE, I can't really test it now, but from memory, my RAM usage dropped by 5 or 10 MB when I commented out lxsession in autostart. I think in the default setup I saw lxsession running when I checked in a task manager (install LXTask or htop). I can't explain the error you got. When I commented it out, I couldn't see a difference other than RAM usage, and from corenomial's post (above link) that's not surprising.


Learning Linux slowly because I'm busy with Appropedia

Offline

#9 2010-08-25 18:05:53

johnraff
#!Drunkard
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 2,866
Website

Re: SOLVED: Is lxsession needed in Openbox? (LXDE compatibility issue)

Chriswaterguy wrote:
johnraff wrote:

On Statler try running 'lxsession' in a terminal. It will come back to the prompt, with no output about what happened. Then try running 'lxsession-logout' which should bring up a logout window. You'll get the message "Error: LXSession is not running." I think this must be because lxsession needs certain files to be installed in order to run. As it is, my feeling is that it should just be removed from the Statler setup.

As I've installed LXDE, I can't really test it now, but from memory, my RAM usage dropped by 5 or 10 MB when I commented out lxsession in autostart. I think in the default setup I saw lxsession running when I checked in a task manager (install LXTask or htop). I can't explain the error you got. When I commented it out, I couldn't see a difference other than RAM usage, and from corenomial's post (above link) that's not surprising.

I've just tried it on 9.04 and lxsession does start up here. According to htop it's using 0.2% of 500MB RAM, so about 1MB. The package is indeed lxsession-lite, not lxsession. lxsession-logout is overridden by /user/bin/crunchbang/lxsession-logout. However this is sort of interesting:

john@raffles3:~$ ps -e | grep lx
16063 pts/1    00:00:00 lxsession
john@raffles3:~$  /usr/bin/lxsession-logout
Error: LXSession is not running.

so there might be a bug there related to capitalisation? But this is all on the outdated Jaunty stuff. I still think on Statler lxsession is doing nothing at all, not even running.


John
--------------------
( a boring Japan blog , idle twitterings  and GitStuff )
#! forum moderator

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo