SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2010-04-17 20:31:10

rich
#! Junkie
From: barcelona
Registered: 2009-01-26
Posts: 414
Website

Howto: Nvidia Geforce Fx 5200

This Howto is for Debian Squeeze or Crunchbang Statler (Squeeze Based) AND was in stalled on a CLEAN system, which means there is no mess or other Nvidia drivers or previous Nvidia install attempts complicating matters.

Eg: rabidfox had to remove the Nouveau Nvidia driver first by following this guide on Ubuntu Forums: http://ubuntuforums.org/showthread.php? … 074&page=3


If you have an older card I suggest you use the Legacy Nvidia drivers from the Nvidia website as neither Squeeze nor Sid nvidia-kernel source via module-assistant will work for this card.

**NOTE**
kodx has another method as well that was posted in the other Nvidia thread for newer cards. Also for the 5200:
http://crunchbanglinux.org/forums/post/62476/#p62476

I went through a few different methods after a few people with older cards said that the workaround for newer cards doesn't work.

Here's how I did it:

1. Download the driver for your card:(Mine is the Gforce Fx 5200 which uses the 173.14.25)
http://www.nvidia.com/object/unix.html

2. Download your driver (it'll go to your /downloads directory)

3. Hit Ctrl+Alt+F1 to get out of the graphical desktop

4. Kill X

sudo killall gdm

or

sudo /etc/init.d/gdm stop

5. Change to the /downloads directory

cd downloads

6. Run the Nvidia installer. Hint: just start the command with sudo sh NV then hit "Tab" it'll finish it for you.

sudo sh NVIDIA...........

7. Go through the motions and continue the install if it complains about gcc etc. It should install ok. There may be a gcc version check, just hit NO to continue the build

8. Load the driver:

sudo modprobe nvidia

Now startx and you should go to your desktop. If not, reboot.

That's it, takes around 5 minutes with no files to install or compile. smile

------------------------------------------------------------------------------------------------------------------------------

If you still get problems, create a xorg.conf file:

su
X -configure

If you get a "XF86Config" file in /etc/X11, just rename it to "xorg.conf" and add nvidia as the driver or run nvidia-xconfig.

Any other problems, post here, I have a working Nvidia card with this method.

Last edited by rich (2010-10-04 06:21:32)

Offline

Help fund CrunchBang, donate to the project!

#2 2010-04-18 13:24:36

kodx
Member
From: Russia
Registered: 2010-03-26
Posts: 24

Re: Howto: Nvidia Geforce Fx 5200

Is my howto doesn't working anymore?
http://crunchbanglinux.org/forums/post/62476/#p62476

Last edited by kodx (2010-04-18 13:29:49)

Offline

#3 2010-04-18 16:25:41

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,418

Re: Howto: Nvidia Geforce Fx 5200

richs-lxh wrote:

1. Download the driver for your card:(Mine is the Gforce Fx 5200 which uses the 173.14.25)

Isn't the nvidia-glx for Debian testing version 173.14 as well?

http://packages.debian.org/squeeze/nvidia-glx

And it says it supports the GeForce FX 5200 too.

Offline

#4 2010-04-18 16:39:45

rich
#! Junkie
From: barcelona
Registered: 2009-01-26
Posts: 414
Website

Re: Howto: Nvidia Geforce Fx 5200

@kodx

I just wrote the steps to how I did it. Usually there is more than one way to skin a cat, and I did a forum search for "Howto Nvidia 5200" and turned up nothing so I posted this for other users.

If you know an alternative method, please post a step by step guide and i'll link to it from here or the other Nvidia thread.

Individual howto guides (no matter how many) are far easier to find if they are in their own thread and titled to reflect exactly what they cover.

@anonymous
The nvidia binary in the repo is "nvidia-glx (173.14.09-5) and wouldn't work for me. It couldn't insert the module into the kernel. If you got it working with your 5200 I would like to know the steps as I prefer Debian drivers over proprietary Nvidia drivers.

rich

Offline

#5 2010-04-18 18:05:39

rich
#! Junkie
From: barcelona
Registered: 2009-01-26
Posts: 414
Website

Re: Howto: Nvidia Geforce Fx 5200

I have decided to install the Xfce Statler on my Tower tomorrow, so I will try your methods with a fresh install just to make sure that my previous attempts didn't cause any problems.

Maybe between us we can post a definitive Nvidia 5200 Howto with both proprietary and repo drivers.

Last edited by rich (2010-04-18 18:06:24)

Offline

#6 2010-04-18 19:55:18

kodx
Member
From: Russia
Registered: 2010-03-26
Posts: 24

Re: Howto: Nvidia Geforce Fx 5200

Ok. Here is mine how to.
Based on this http://crunchbanglinux.org/forums/topic … r-squeeze/ by richs-lxh

Add sid Unstable to your sources.lst

sudoedit /etc/apt/sources.list
# Unstable Sid
deb http://http.us.debian.org/debian/ unstable main contrib non-free
# Unstable Sources
deb-src http://http.us.debian.org/debian/ unstable main contrib non-free

*Important*
Once you have updated and installed the Nvidia source, comment out the sid repo by adding a # in front of each sid line, or better still remove it completely. This way any future updates/upgrades will come from the Statler and Squeeze repos.

Update

sudo aptitude update

Install Nvidia kernel source

sudo aptitude install module-assistant nvidia-kernel-common build-essential
sudo m-a clean nvidia-kernel-source
sudo m-a purge nvidia-kernel-source
sudo m-a prepare
sudo aptitude install nvidia-kernel-legacy-173xx-source/unstable

Make modules and install it

sudo m-a a-i nvidia-kernel-legacy-173xx-source

Install X.org glx module

sudo aptitude install -t unstable nvidia-glx-legacy-173xx nvidia-xconfig

Get nvidia-setting from Debian Lenny. One's from squeeze doesn't work well.

wget -c http://ftp.ru.debian.org/debian/pool/contrib/n/nvidia-settings/nvidia-settings_173.14.09-1_i386.deb
sudo dpkg -i ./nvidia-settings_173.14.09-1_i386.deb

Then run nvidia-xconfig
If you get a "XF86Config" file in /etc/X11, just rename it to "xorg.conf" and add nvidia as the driver or run nvidia-xconfig.

@richs-lxh

Try my howto. Maybe you'll find some mistakes, made by me. (I didn't tried my howto on fresh system)

Last edited by kodx (2010-04-18 19:57:42)

Offline

#7 2010-04-18 20:56:20

rich
#! Junkie
From: barcelona
Registered: 2009-01-26
Posts: 414
Website

Re: Howto: Nvidia Geforce Fx 5200

I am going to install Statler Xfce on my Nvidia tower and i'll use your method to get the drivers. I always prefer the drivers from the Debian repos, so hopefully it will work. I just couldn't get them to install before. The nvidia.ko module played up with the kernel.

This could have been an after-effect of trying different methods, so a fresh install will be a better test area.

Thanks for posting your guide here, I also added a link to it on the first post. smile

rich

Offline

#8 2010-04-21 13:40:54

rich
#! Junkie
From: barcelona
Registered: 2009-01-26
Posts: 414
Website

Re: Howto: Nvidia Geforce Fx 5200

@kodx

I followed your guide step by step on Staler Xfce and it all went well up until:

sudo m-a a-i nvidia-kernel-legacy-173xx-source

Then it seg faulted.

warning: passing argument 2 of 'request irc' for incompatible pointer type 

I tried a few more times, but it wouldn't get any further.

I am going to try with Nvidia Legacy (190.53)

EDIT: No go with the Squeeze nvidia kernel

FATAL: Error inserting nvidia (/lib/modules/2.6.32-4-686/nvidia/nvidia.ko): No such device

I'll try something else.

EDIT: No go i'm afraid. Looks like it's ging to have to be the driver from the Nvidia site.

Last edited by rich (2010-04-21 14:10:51)

Offline

#9 2010-04-22 20:37:41

kodx
Member
From: Russia
Registered: 2010-03-26
Posts: 24

Re: Howto: Nvidia Geforce Fx 5200

@richs-lxh
Thats odd.
I use this instructions just a few months ago and everything was great. I'll test it on new install, on next week. Thanks for test.

Offline

#10 2010-05-24 05:47:44

jnbugeja
New Member
Registered: 2010-05-24
Posts: 1

Re: Howto: Nvidia Geforce Fx 5200

Hello ,
PNY Nvidia Geforce 5200 FX pci
*Ubuntu 9.10
I followed your tutorial at the very top and downloaded the [Recommended] Package that is the 173.
Anyway I followed your tutorial step by step. Killed the GUI by ALT-CTRL-F1 even tried the sudo killall gdm which said wasn't existed or wasn't active? I don't recall.
Then change Directory to Downloads
typed
sudo sh NVIDIA [Tab]

Entered the Prompted of reading the Rules and Regulations and Agreed to it.
Allowed it to execute then after a little bit it asked edit existing settings to build (Not GCC stuff I think) But
It was to Edit my Xconfig to allow use.
I said Yes,
Then a little bar again showed progress then I was done. Back to Black screen.
I typed sudo modprobe nvidia
for good measure and it said invalid or didn't respond. I don't recall. I just remember nothing happened or appeared to happen that would have caught my eye to force into intensive reading.
Then I rebooted for I tried start x and it said invalid option.
After I rebooted Ubuntu it booted to log in and said error with video and forced to low resolution.
Said

           Error (EE) No Device Detected

It showed me some options to choose from
Boot in low graphics mode (Just loads black screen and startup music plays)
Edit config Files
Launch to terminal (I think)

I choose edit and created a backup.
I have attached the files  and I hope you can make some sense from it.
I'd greatly appreciate any help for I've always used windows and it recognises the card and works almost instantly. I just want to use this so I can stop eating off my ram for my graphics as well higher resolution.  Any help is greatly appreciated. Thanks for your time.



When I chose create backup file. It created it and told me the location.

/var/log/failsafeX-backup10053234939.tar
When uncompress it has 8 files named.
:0.log
:0.log.1
:0.log.2
Lspci-vvnn.txt
xorg.conf
Xorg.0.log
Xorg.0.log.old
xrandr-verbose.text


Here is xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Wed Jan 27 03:02:48 PST 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection



Here is Xorg.0.log

X.Org X Server 1.6.4
Release Date: 2009-9-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
Current Operating System: Linux joe-desktop 2.6.31-21-generic #59-Ubuntu SMP Wed Mar 24 07:28:56 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.31-21-generic root=UUID=50b9c6dd-6baa-4789-b23c-c046bf53b73d ro quiet splash
Build Date: 06 May 2010  09:30:46PM
xorg-server 2:1.6.4-2ubuntu4.3 (buildd@)
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun May 23 23:49:35 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
(==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(II) Loader magic: 0x3bc0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 5.0
    X.Org XInput driver : 4.0
    X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0:0:2:0) 8086:2562:109f:3189 Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device rev 3, Mem @ 0xd8000000/134217728, 0xd0000000/524288
(--) PCI: (0:2:9:0) 10de:0322:196e:01ad nVidia Corporation NV34 [GeForce FX 5200] rev 161, Mem @ 0xd1000000/16777216, 0xe0000000/268435456, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX [B
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX [B
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX [B
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX [B
    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX [B
    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX [B
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
(II) NVIDIA GLX Module  173.14.25  Wed Jan 27 02:59:37 PST 2010
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  173.14.25  Wed Jan 27 02:34:38 PST 2010
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 00@00:02:0
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

ddxSigGiveUp: Closing log

Here is
/var/log/Xorg.0.log


X.Org X Server 1.6.4
Release Date: 2009-9-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
Current Operating System: Linux joe-desktop 2.6.31-21-generic #59-Ubuntu SMP Wed Mar 24 07:28:56 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.31-21-generic root=UUID=50b9c6dd-6baa-4789-b23c-c046bf53b73d ro quiet splash
Build Date: 06 May 2010  09:30:46PM
xorg-server 2:1.6.4-2ubuntu4.3 (buildd@)
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun May 23 23:49:35 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
(==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(II) Loader magic: 0x3bc0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 5.0
    X.Org XInput driver : 4.0
    X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0:0:2:0) 8086:2562:109f:3189 Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device rev 3, Mem @ 0xd8000000/134217728, 0xd0000000/524288
(--) PCI: (0:2:9:0) 10de:0322:196e:01ad nVidia Corporation NV34 [GeForce FX 5200] rev 161, Mem @ 0xd1000000/16777216, 0xe0000000/268435456, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX [B
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX [B
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX [B
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX [B
    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX [B
    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX [B
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
(II) NVIDIA GLX Module  173.14.25  Wed Jan 27 02:59:37 PST 2010
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.6.4, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  173.14.25  Wed Jan 27 02:34:38 PST 2010
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 00@00:02:0
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

ddxSigGiveUp: Closing log

Again I don't know what I did wrong and I followed your tutorial from what seemed to me almost step by step. I'd really appreciate any help to get my settings back to origanal or to get the card to properly work I'd greatly appreciate your time. I have sent a pm to richs-lxh in hope he'd respond quicker but I'm posting here in case he is on vacation or something. Thanks for your time guys.

-Joe

Last edited by jnbugeja (2010-05-24 06:08:03)

Offline

#11 2010-07-24 17:44:24

kian-bot
New Member
Registered: 2010-07-24
Posts: 2

Re: Howto: Nvidia Geforce Fx 5200

Hi, - I am a total n00b with Linux. BUT I REALLY NEED HELP, SERIOUSLY - I NEED TO GET THIS GRAPHICS CARD RUNNING!

I have tried to follow the instructions given on this page.

I am using Ubuntu 10.04.1 LTS - if this makes a difference to the process.

* tried installing the drivers for my NVIDIA 5200 with the helpfull hardware-driver-help-finding-and-installation program included with my distribution of Ubuntu. When I restarted it was apparent that the driver was not installed since the resolution was so low. So I tried the guide by richs-lxh, but:

* I was halted on the outset because I get the message; 'no such process found' when I tried to 'sudo killall gdm'.

* Then tried to run the downloaded *.run file for my NVIDIA 5200, - but within the setup-program it says that an X server is still running (and I don't see any way of bypassing this). 

* To simply load the system without X, I tried to find the grub loader when the computer boots, but no matter how or how many times I press esc during startup I cannot enter the menu. In fact, I cannot even see grub at any point of startup.

* Thus I then tried to find a way to alter the number of seconds the grub menu will be visible during startup - but all the guides I can find that will help me with this point to a file ' /boot/grub/menu.lst' which does not exist - at least on my system.

I have been trying to fix this for 7 hours now. I hope for a quick response because I really, really need the computer by monday at latest. I will be extremely gratefull for a helping hand.

SO, MY PROBLEM RESTATED; I cannot stop X or prevent it from starting (since I cannot acces my grub menu).

Offline

#12 2010-07-24 20:43:50

chillicampari
Pinball Wizard
Registered: 2009-10-09
Posts: 1,905

Re: Howto: Nvidia Geforce Fx 5200

kian-bot wrote:

...

I am using Ubuntu 10.04.1 LTS - if this makes a difference to the process.

...

Hi kian-bot! Yep, it does make a difference. smile This guide is for Crunchbang 10 based on Debian Squeeze, the setup guide you'll want to follow for Ubuntu 10.4 is at:

https://help.ubuntu.com/community/Binar … wto/Nvidia

And the forums are at:  http://ubuntuforums.org/index.php

Best of luck!


#! forum moderator

Offline

#13 2010-07-25 07:59:12

kian-bot
New Member
Registered: 2010-07-24
Posts: 2

Re: Howto: Nvidia Geforce Fx 5200

Hehe tongue That really was a n00b's mistake. Thank you very much!

Offline

#14 2010-07-25 08:15:50

chillicampari
Pinball Wizard
Registered: 2009-10-09
Posts: 1,905

Re: Howto: Nvidia Geforce Fx 5200

You're welcome!

(psssstt... and don't be so hard on yourself, it can be all kinds of confusing at first big_smile)


#! forum moderator

Offline

#15 2010-09-25 20:17:35

rabidfox
#! CrunchBanger
Registered: 2010-09-22
Posts: 116

Re: Howto: Nvidia Geforce Fx 5200

On my #! Statler with a Nvidia Geforce FX 5200:

I tried the method richs-lxh posted, but got this error:

ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most
       frequently when this kernel module was built against the wrong or
       improperly configured kernel sources, with a version of gcc that differs
       from the one used to build the target kernel, or if a driver such as
       rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
       obtaining ownership of the NVIDIA graphics device(s).

Then I tried

sudo apt-get –purge remove nvidia-*

to remove clutter from previous attempts, but no change.

Then I added to /etc/modprobe.d/blacklist.conf:

    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv

in response to this http://openpenguin.blogspot.com/2010/06 … buntu.html...

But no change.  So in response to this http://ubuntuforums.org/showthread.php? … 074&page=3, I went in and completely removed xserver-xorg-video-nouveau, which also gets rid of xserver-xorg-video-all ... rebooted, tried richs-lxh's method again, and then it worked great.

Hurray! big_smile


...But I'm ever so squeezable!

Offline

#16 2010-10-04 06:17:54

rich
#! Junkie
From: barcelona
Registered: 2009-01-26
Posts: 414
Website

Re: Howto: Nvidia Geforce Fx 5200

rabidfox wrote:

So in response to this http://ubuntuforums.org/showthread.php? … 074&page=3, I went in and completely removed xserver-xorg-video-nouveau, which also gets rid of xserver-xorg-video-all ... rebooted, tried richs-lxh's method again, and then it worked great.

Hurray! big_smile

Oh crikey, maybe I should state that my howto was on a fresh install with no previous Nvidia attempts. Thanks for pointing that out smile

I'll add your link to Ubu forums and offer the suggestion of completely removing Nouveau.

Glad you got it working wink

Offline

#17 2011-01-20 01:11:11

charlie01
#! Die Hard
Registered: 2009-02-09
Posts: 556

Re: Howto: Nvidia Geforce Fx 5200

kodx wrote:

Ok. Here is mine how to.
Based on this http://crunchbanglinux.org/forums/topic … r-squeeze/ by richs-lxh

Add sid Unstable to your sources.lst

sudoedit /etc/apt/sources.list
# Unstable Sid
deb http://http.us.debian.org/debian/ unstable main contrib non-free
# Unstable Sources
deb-src http://http.us.debian.org/debian/ unstable main contrib non-free

*Important*
Once you have updated and installed the Nvidia source, comment out the sid repo by adding a # in front of each sid line, or better still remove it completely. This way any future updates/upgrades will come from the Statler and Squeeze repos.

Update

sudo aptitude update

Install Nvidia kernel source

sudo aptitude install module-assistant nvidia-kernel-common build-essential
sudo m-a clean nvidia-kernel-source
sudo m-a purge nvidia-kernel-source
sudo m-a prepare
sudo aptitude install nvidia-kernel-legacy-173xx-source/unstable

Make modules and install it

sudo m-a a-i nvidia-kernel-legacy-173xx-source

Install X.org glx module

sudo aptitude install -t unstable nvidia-glx-legacy-173xx nvidia-xconfig

Get nvidia-setting from Debian Lenny. One's from squeeze doesn't work well.

wget -c http://ftp.ru.debian.org/debian/pool/contrib/n/nvidia-settings/nvidia-settings_173.14.09-1_i386.deb
sudo dpkg -i ./nvidia-settings_173.14.09-1_i386.deb

Then run nvidia-xconfig
If you get a "XF86Config" file in /etc/X11, just rename it to "xorg.conf" and add nvidia as the driver or run nvidia-xconfig.

@richs-lxh

Try my howto. Maybe you'll find some mistakes, made by me. (I didn't tried my howto on fresh system)

Ive hosed my x on 2 occasions trying to get this driver working,All the procedures seem to work,until i try to get to the nvidia config,then when i reboot it says im missing xorg-conf.
The first time i just reinstalled,The second time i tried making a xorg config with no luck.

The nouveau driver seems to work for me,Im not a gamer,But im thinking the actual nvidia driver would be better.
Ill figure it out eventually,,,lol

Offline

#18 2011-01-20 02:08:17

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,418

Re: Howto: Nvidia Geforce Fx 5200

@charlie01 - don't quote such long posts. Also did you make sure to run "nvidia-xconfig as root?

Offline

#19 2011-01-21 01:53:08

charlie01
#! Die Hard
Registered: 2009-02-09
Posts: 556

Re: Howto: Nvidia Geforce Fx 5200

anonymous wrote:

@charlie01 - don't quote such long posts. Also did you make sure to run "nvidia-xconfig as root?

I would have to say no i most likely didnt.
But the truth is i just dont remember.

I ran a lspci -v and it said i was using the nvidia driver.
But after reboot is when i had the issue.

I figure i did something wrong or missed a step.

Theres no easier method of installation that i can find.
Maybe someday there will be,,lol

Last edited by charlie01 (2011-01-21 01:54:18)

Offline

#20 2011-02-09 02:17:14

charlie01
#! Die Hard
Registered: 2009-02-09
Posts: 556

Re: Howto: Nvidia Geforce Fx 5200

After all this time,I think i finally got it going.
Heres my lspci, My question is,Were it says Capabilities,Is it supposed to say access denied ?

01:00.0 VGA compatible controller: nVidia Corporation GT218 [ION] (rev a2) (prog-if 00 [VGA controller])
    Subsystem: Acer Incorporated [ALI] Device 045e
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Memory at ce000000 (64-bit, prefetchable) [size=32M]
    I/O ports at dc00 [size=128]
    [virtual] Expansion ROM at fcf80000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia

Offline

#21 2011-02-09 02:23:02

anonymous
The Mystery Member
From: Arch Linux Forums
Registered: 2008-11-29
Posts: 9,418

Re: Howto: Nvidia Geforce Fx 5200

If you run lspci as a user then yes its normal. To see the "Capabilities" run it with root privileges.

Offline

#22 2011-10-05 05:37:55

3picgillftw
New Member
Registered: 2011-10-05
Posts: 1

Re: Howto: Nvidia Geforce Fx 5200

This was the ticket for me. Worked like a charm using the Nvidia latest suggested driver for my GTX 560m card. Thank you so much! Your crashbang linux fu is strong

Offline

#23 2012-07-22 23:39:23

Griffin30007
New Member
Registered: 2012-07-22
Posts: 1

Re: Howto: Nvidia Geforce Fx 5200

Great how to.  Still relavent (just installed CrunchBang to an extra test box with a 5200FX in it).
http://debian.mirror.netelligent.ca/deb … 1_i386.deb  Link to Nvidia-Settings for module since link provided doesn't work anymore.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo