SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-04-26 23:05:22

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 150
Website

[solved] my router only allows connections every second reboot

after the first reboot and all of the lights indicate success it still wont allow me to reconnect until I reboot it for a second time

is this a problem with how my router is set up ?

Last edited by HELPME (2014-05-06 03:04:27)

Offline

Be excellent to each other!

#2 2014-04-26 23:25:05

uriel1998
Member
From: Dayton, OH
Registered: 2012-02-10
Posts: 49
Website

Re: [solved] my router only allows connections every second reboot

HELPME wrote:

after the first reboot and all of the lights indicate success it still wont allow me to reconnect until I reboot it for a second time

is this a problem with how my router is set up ?

Probably.  smile  Unfortunately, without more details, it's impossible to tell.  For the most primitive of examples:  Do you mean "connect to the router" or "connect to the internet"?

Here's the key thing:  Does it let you STAY connected after that second reboot of the router?  If so (and unless you're rebooting it frequently), and you're not having any OTHER problems... well, I had a car I had to thump on the dash to make the fan run quietly.  But only once per start.  So I thumped it a lot during the winter.  smile

Offline

#3 2014-04-26 23:29:30

Bearded_Blunder
#! CrunchBanger
Registered: 2014-04-04
Posts: 236

Re: [solved] my router only allows connections every second reboot

Also what router is it?  Google should reveal if it's a common problem with that router, if there's a firmware update to fix it if it's firmware, or if there's alternate Open Source firmware you can install...


Blessed is he who expecteth nothing, for he shall not be disappointed...

Offline

#4 2014-04-27 00:30:57

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 297

Re: [solved] my router only allows connections every second reboot

Somewhat related, my BT Home Hub 3 has started to ignore wireless connections. Wireless devices work and connect OK to internet, but are not visible on the LAN to other devices. A Reboot fixes this, for a while....

Offline

#5 2014-04-27 01:26:39

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 150
Website

Re: [solved] my router only allows connections every second reboot

uriel1998 wrote:

Probably.  smile  Unfortunately, without more details, it's impossible to tell.  For the most primitive of examples:  Do you mean "connect to the router" or "connect to the internet"?

Here's the key thing:  Does it let you STAY connected after that second reboot of the router?  If so (and unless you're rebooting it frequently), and you're not having any OTHER problems... well, I had a car I had to thump on the dash to make the fan run quietly.  But only once per start.  So I thumped it a lot during the winter.  smile

wcd89u.jpg
NetworkManager Applet connects successfully but telnet 192.168.1.1 doesnt and neither does my browser work for the internet or router so I dont know what or which it is

Bearded_Blunder wrote:

Also what router is it?  Google should reveal if it's a common problem with that router, if there's a firmware update to fix it if it's firmware, or if there's alternate Open Source firmware you can install...

I already did that before posting but my router is Dynalink RTA1025W

Joe90 wrote:

Somewhat related, my BT Home Hub 3 has started to ignore wireless connections. Wireless devices work and connect OK to internet, but are not visible on the LAN to other devices. A Reboot fixes this, for a while....

mine is kind of the same but a little inversed
it has four ethernet ports but none of them work their lights just flash if anything goes into there
the usb port works everytime but there is only one of those so maybe a hub can replace them?

Offline

#6 2014-04-27 21:54:41

gurtid
#! Junkie
From: NEW ZEALAND
Registered: 2011-04-07
Posts: 378

Re: [solved] my router only allows connections every second reboot

I have one of these routers and have no problem at all. Pretty much default settings/firmware.


all your Base are belong to us

Offline

#7 2014-05-01 04:17:51

uriel1998
Member
From: Dayton, OH
Registered: 2012-02-10
Posts: 49
Website

Re: [solved] my router only allows connections every second reboot

HELPME wrote:
uriel1998 wrote:

Probably.  smile  Unfortunately, without more details, it's impossible to tell.  For the most primitive of examples:  Do you mean "connect to the router" or "connect to the internet"?

NetworkManager Applet connects successfully but telnet 192.168.1.1 doesnt and neither does my browser work for the internet or router so I dont know what or which it is

I am guessing that "my browser doesn't work for the router" means that you cannot connect to the router's interface.  There are a couple of possible troubleshooting tips to do:

1.  Try these from the cli and give us the output (NOTE: you may need to install arp and ip.)

ip route show 0.0.0.0/0 | awk '{print $3}'

If that's not 192.168.1.1, then you've got something set up incorrectly.  Which brings us to

2.  Reset your router to factory defaults and start again.  It really sounds like your router is half (correctly) configured.

Offline

#8 2014-05-03 02:50:41

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 150
Website

Re: [solved] my router only allows connections every second reboot

it seems fixed

ip route show 0.0.0.0/0 | awk '{print $3}' returns 192.168.1.1
and the router was reset when the firmware was upgraded
it just seemed fixed because I was using the computer connected through cable
I reset it again but it didnt change

Last edited by HELPME (2014-05-03 03:02:05)

Offline

#9 2014-05-04 22:07:32

dbvolvox
#! CrunchBanger
From: England
Registered: 2011-01-05
Posts: 158

Re: [solved] my router only allows connections every second reboot

Sorry if this is a bit basic but are you actually getting an ip address assigned by the router?

If not you could try the dhclient command to see if that forces one.

Also, what is in your interfaces file

cat /etc/network/interfaces

Offline

#10 2014-05-05 01:24:52

uriel1998
Member
From: Dayton, OH
Registered: 2012-02-10
Posts: 49
Website

Re: [solved] my router only allows connections every second reboot

HELPME wrote:

and the router was reset when the firmware was upgraded
it just seemed fixed because I was using the computer connected through cable
I reset it again but it didnt change

Okay, wait a second.  So your router just had the firmware updated and this started?  That would most likely be the problem... and that's a router issue, not a computer issue.

Secondly, your WIRED connection works, but your WIRELESS does not?  Then this is an issue with the settings for your wireless connections.

Offline

#11 2014-05-05 07:38:07

Bearded_Blunder
#! CrunchBanger
Registered: 2014-04-04
Posts: 236

Re: [solved] my router only allows connections every second reboot

You might try either of:

Flashing the firmware back to the previous version, most firmware flashing tools create a backup before they flash.

Download the firmware from the manufacturer and try flashing it again, something may have gone wrong in the process first time round.

Depending on manufacturer and methods used, you may need to flash from Windows, I would not recommend Wine for such a job, if the tool is a Windows one.

It's also possible it's a hardware issue, consumer grade routers are cheap things, with cooling that they fit to commercial versions omitted, they can, and do go bad sometimes, if it's ISP supplied, bug them till they replace it,

If not, well they're not expensive these days.  Look for one that is listed as compatible at dd-wrt.com if you replace it, because dd-wrt gets security patches etc. much faster than manufacturers can be bothered to, (if indeed they bother at all once it's a year or two old).

Edit:
Also worth checking, does the power supply get hot? Worth trying a substitute if it does, or in any case if you have one the correct rating available.

If you're willing to open it up, check for blown capacitors.

Last edited by Bearded_Blunder (2014-05-05 08:59:23)


Blessed is he who expecteth nothing, for he shall not be disappointed...

Offline

#12 2014-05-05 12:18:01

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 838

Re: [solved] my router only allows connections every second reboot

HELPME, so it looks like your router gives you an IP address but you can't browse the internet, could it be a DNS issue!?
does

ping -c3 8.8.8.8

work?
(I assume

ping -c3 www.google.com

doesn't).

The other thing I would try to do is to re-issue the DHCP client, in #! should be

sudo dhclient -r wlan0
sudo dhclient wlan0

Let's first see if this brings anywhere, just FYI I had similar problems (in Arch) which I solved increasing the timeout for the DHCP client and/or the client itself, see for example this.

HTH


#!#!#! Forum etiquette #!#!#!
Are you a new member!? Have you introduced yourself?!
CLI basics | LVM | smxi | chrooting | multiarch

Offline

#13 2014-05-06 02:39:46

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 150
Website

Re: [solved] my router only allows connections every second reboot

cat /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

the router was reset to default settings with latest firmware many times since my last post

Bearded_Blunder wrote:

It's also possible it's a hardware issue, consumer grade routers are cheap things, with cooling that they fit to commercial versions omitted, they can, and do go bad sometimes, if it's ISP supplied, bug them till they replace it,

its probably old but I am new to it

Bearded_Blunder wrote:

If you're willing to open it up, check for blown capacitors.

there appears to be no way of dismantlement because of lacking screws but perhaps looks can be deceitful? I was most interested for this to replace the four ethernet ports but dont want to perma break the casing and have to use duct tape to hold it all together
it doesnt belong to me in the first place and without the ownership there is no liability
_______________________________________________________

first attempt
nm app says wireless is connected good
internet browser works and also connects 192.168.1.1
telnet 192.168.1.1 works
connectiontest from cb-welcome script passed
both ping commands work successfully

reboot router

second attempt
nm app says wireless is connected good
but everything else fails
I need to find how nm app connects

helpme@helpme:~$ ping -c3 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2015ms

helpme@helpme:~$ ping -c3 www.google.com
ping: unknown host www.google.com

reboot router

go back to first attempt because this is an endless loop

nm app crashed twice hmm so I sudo NetworkManager
it never crashed before so I keep this info here for future ref because you dont know how long it took for me to find out what it really was when after it had disappeared
I just cross this out because you dont need to read it

Offline

#14 2014-05-06 03:07:44

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 150
Website

Re: [solved] my router only allows connections every second reboot

sudo dhclient -r wlan0
sudo dhclient wlan0

fixes every second reboot but requires every time
so I will check this http://askubuntu.com/questions/203157/t … hcp-server
I dont know how to do that but at least I have a solution smile

Last edited by HELPME (2014-05-06 03:09:45)

Offline

#15 2014-05-06 06:25:56

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 838

Re: [solved] my router only allows connections every second reboot

I am glad you at least have a workaround now...

If you want to try the solution provided in that link, do

sudo geany /etc/dhcp/dhclient.conf

most of the lines in that file should be commented out, find the line

#timeout 60;

uncomment it (remove the #), save, close, do a series of reboot and see if it worked...


#!#!#! Forum etiquette #!#!#!
Are you a new member!? Have you introduced yourself?!
CLI basics | LVM | smxi | chrooting | multiarch

Offline

#16 2014-05-06 22:21:30

dbvolvox
#! CrunchBanger
From: England
Registered: 2011-01-05
Posts: 158

Re: [solved] my router only allows connections every second reboot

I would have expected your interfaces file to also have the lines

auto wlan0
iface wlan0 inet dhcp

Or is that not necessary, anyone?

Offline

#17 2014-05-07 04:07:56

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 838

Re: [solved] my router only allows connections every second reboot

^ that's needed if you want to manage your wifi CLI, as far as I know, it is not necessary when you use nm/wicd...


#!#!#! Forum etiquette #!#!#!
Are you a new member!? Have you introduced yourself?!
CLI basics | LVM | smxi | chrooting | multiarch

Offline

#18 2014-05-10 08:24:50

HELPME
#! CrunchBanger
From: the holley land
Registered: 2013-11-15
Posts: 150
Website

Re: [solved] my router only allows connections every second reboot

VDP76 wrote:

I am glad you at least have a workaround now...

If you want to try the solution provided in that link, do

sudo geany /etc/dhcp/dhclient.conf

most of the lines in that file should be commented out, find the line

#timeout 60;

uncomment it (remove the #), save, close, do a series of reboot and see if it worked...

do I need to reboot or is there a command to restart dhclient?
I've been messing around with this file for days now but nothing seems to work
I uncommented and changed all of the numbers
this is what Im left with but I still have to sudo dhclient wlan0

timeout 60;
retry 60;
reboot 10;

Last edited by HELPME (2014-05-10 10:31:03)

Offline

#19 2014-05-10 12:01:31

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 838

Re: [solved] my router only allows connections every second reboot

I am glad you have found a working config!
To restart the networking without reboot try

sudo /etc/init.d/networking restart

It might give you some warning but it should get the job done.


#!#!#! Forum etiquette #!#!#!
Are you a new member!? Have you introduced yourself?!
CLI basics | LVM | smxi | chrooting | multiarch

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo